HELP! - Trouble Connecting My Roon Core to My 2 Audio Systems [Resolved]

I’m not very computer savvy, so I was excited that I was successful at setting up my new Dell computer as my Roon Core. My Roon Core is my new Dell PC with all of my music files on a Synology DS 415+.

The problem occurred when I tried to discover my Roon Core on my two audio systems… one in my living room and one in my bedroom. My living room system is a Mac Mini and a Wavelength Cosecant Dac and my bedroom system is a Mac Mini and a Wavelength Brick Dac.

Neither of the Mac Minis were able to find the Dell/Synology (Roon Core). I noticed that the Mini’s are locating an IP address for my Synology (192.168.1.) that is not the same address that I use to open my Synology using Synology Assistant. It’s like my Roon Core has discovered someone else’s Mac Mini.

Any and all advice on how to troubleshoot this would be extremely appreciated. I would love to be able to listen to some music via Roon and Tidal tonight if at all possible. Thanks!!


You don’t say but I assume you have installed Roon remote on the two Mac Minis. If so try turning off any firewalls temporarily and see if that makes a difference.

Hi Vernon,

Do you have Accept Remote Connections set to Yes, in Settings > Setup?

Also, what computer ran your Core previously?

Cheers, Greg

Should I install Roon Remote or Roon Bridge on my Mac Minis? It doesn’t seem to provide me the option of downloading Roon Remote since the Mini is not a tablet or mobile device. Am I missing something?

Roon Remote, in the case of PCs, is just Roon but installed as a client instead of a server. Whether you want one or the other depends on how you are going to use the system. I would install Roon first. When installing just tell it you want it to be a client and it will look to find a core on your network.

But, two points about your current situation. Roon Core and Roon Remotes or Endpoints need to be in the same network space, so they all have to be 192.168.1.X. If the core is 192.168.1.X and a remote is 192.168.4.X they will not see each other.

Also, many times Firewalls and Anti-virus by default block Roonl; try turning off the Dell and Mac’s Firewall and Antivirus and see if that makes a difference. If it does, then you know that is the problem. the solution would be setting up your Firewall and Antivirus to allow Roon’s communication.

Hi Greg,

Yes… I do have the Dell set to accept remote connections. I did discover when I looked under the Audio tab that it showed a Mac Mini with a description that wasn’t my name and it had a different ip address then the one I use to access my Synology.

I’m still not sure what my proper ip address should be when I enter it. That could help clear up this issue.

I just bought the Dell yesterday so prior to that I used the Mac Mini that’s in my main system as the Core. Today, I deleted and reinstalled Roon on both of the Mini’s but that didn’t help my issues.

Thanks for your help!


Thanks Daniel,

Let me see if I can figure how to change the firewall settings on ESET if it is interfering with the Roon software.

Keep in mind the new Dell will also have a Firewall and so do the Macs.

Gotcha… I will take a look at all three machines. I have even tried getting access to my library on my iPad to no avail.

Ok… I changed the firewall settings on my Dell and Mac Minis but my Mac Minis and iPad are still not finding my Roon Core.

Is there a support line I can call? Thanks!

How do I ensure that the Roon Core and Endpoints have the same network space?

I thought i only have one address they can use.

@support looks like this needs your input.

Support will want full details of your setup as outlined here so the sooner you can post that the sooner they can provide some help.

Ok… after restarting the Mini on my main system, the Roon application opened up and had identified my Dell and was attempting to connect to it. Unfortunately, each attempt is a failed attempt,

The IP address that Roon is displaying for the Dell is not the same address that I use to log on to my network. The last two digits are off by .12.

Is there a way to manually adjust this?

Open to any and all suggestions. Thanks!

Hey Vernon, When talking about being in the same network space (or more specifically sub-net), it is only the first three number groups that need to be identical. the last number needs to be different for each device.

So, and are in the same subnet since 192.168.1 is the same for both. Now, if one of those 1st three number groups are different vs for example, then they would be on different subnets.

1 Like

@support I have all of my music on a Synology 415+. I am running my Roon Core on a Dell Inspiron 3668… i5 7400 CPU @ 3.00GHz, 8GB Ram, 64 bit 256 SSD.

My main stereo system has a 2011 Mac Mini OS 10.12.6 (2.3 GHz Intel Core i5, 8 GB Ram and Intel HD Graphics 3000), a Wavelength Audio Cosecant 96/24 Dac. I installed Roon on it again this morning after deleting the old versions I had on the Mini.

My bedroom system has a 2010 Mac Mini OS 10.13.1 2.47 GHz, Intel Core 2 Duo, 8 GB Ram, NVIDIA GeForce 320M 256MB) and a Wavelength Brick 96/24 version. I also reinstalled Roon on it yesterday.

Let me know if you need any additional information. Thanks for your assistance!

Moved to Support category.

Cheers, Greg

Hi @Vernon_Lockett ----- Thank you for your continued feedback and more importantly, thank you for your patience. Both are very appreciated!

Moving forward, I just want to make sure that I have all the details of the issue being experienced along with setup details correctly, so I can properly advise as to where you should begin troubleshooting. Please see below, thanks!

Current issue:
Remote devices are struggling to see/connect with your core machine.

Core = Dell computer
Remote/endpoint # 1 = MacMini feeding a Wavelength Audio Cosecant.
Remote/endpoint #2 = Macmini feeding a a Wavelength Brick 96/24.
Storage = Synology DS 415+

  • Please verify that I have the general details of your setup and issue correct.

Additional Data gathering:

  • All devices are running the last version of the application, correct?

  • Please provide a screenshot of “audio” tab.

  • Please provide me with the IP addresses of the Core machine and MacMini remotes/endpoints. If you’d like you can provide this information to me in a PM :wink:

  • Just to reconfirm, all active firewalls and antivirus applications have been disabled on your devices, correct?

  • Please briefly describe your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing. These devices would include any routers, switches, repeaters, extenders, powerline adaptors, etc.

  • Can you provide some insight as to how you went about switching from one core machine to another, based on the steps listed in our knowledge base article here.

General troubleshooting:

  • While it may seem elementary :innocent: have you tried rebooting ALL of your devices and not just the MacMinis? This would include your core machine and any pertinent network devices (i.e router, switches, etc).

  • From the MacMini remote/end points have you verified if you can successfully ping the IP address being assigned to your Roon core?


Hi Eric,

You captured the details of my setup and issues correctly.

I just completed the ping test on the Dell and the MacMini in my main system. Both test were 100 percent successful. I couldn’t find the Network Utility on my 2010 Mini, but I would be surprised if it didn’t pass as well.

All devices are running the lastest version of Roon and all firewalls and antivirus software has been disabled.

My network configuration consists of AT&T UVerse modem that the Dell and the Synology are both physically connected to.

The switch from having the Roon Core on my Mac Mini to my Dell involved deleting the old version of Roon on the Mini and installing Roon Core on the new Dell computer.

Thanks for bringing this to my attention. I wasn’t aware that the last numbers were supposed to be different. The first 3 groups of numbers are the same on all devices.

Hallelujah!! The Roon Core finally found my Mac Minis and iPad after I disconnected the Core and started fresh. I wish I had tried that two days ago!

Thanks for your help with this!

1 Like