HIFI Berry Digi2 Pro Not Working With Release 4.002

My hardware is a Pi4 with HiFi Berry Digi2 Pro and Roon Rock running on Intel NUC i3. In Ropieee V3 the Audio Hat was selected as HiFi Berry Digi Pro, and this worked.

I purchased the Digi2 Pro soon after its release and it has been working without a problem until the update to 4.002 last week.

Since the update to 4.002 the Digi2 Pro is no longer recognised in Roon. Under Settings About Ropieee is correctly listed showing Version 1.8 (build 806) stable. But, under Settings Audio Ropieee does not appear. At the bottom of the screen the message “No Audio Devices Found” appears.

I have tried a brand new unused SD card flashed with a new copy of 4.002, without success. I have tried changing the Audio Hat setting in Ropieee between Digi2 Pro and Digi2 but no difference. Rebooting Roon and Ropieee makes no difference.

I have resurrected my old HiFi Berry Digi Pro card which will work correctly with 4.002 using the hat selection of Digi Pro or Digi2 Pro.

It seems that the problem affects only the Digi2 Pro card.

I wonder if there is a problem in Release 4.002 affecting the Digi2 Pro card.

Any help would be appreciated.

Regards, Bob

1 Like

Bob — I’d suggest leaving Harry feedback (using the Advanced tab), in case the logs provide some useful information regarding what is going on for you.

Welcome to the Roon forum.

Feedback posted : 3d8b7e76d4bfdf1b

Bob

Hi @Robert_Pettener ,

So to be clear: you had it configured with the ‘Digi Pro’; that worked.
After the update you decided so set it to ‘Digi2 Pro’, as that is now available in RoPieee.
And it stopped working?

Anyways, I suggest you set it back to ‘Digi Pro’ for now; under the hood it uses the same driver. In the mean time I’ll try to figure out what’s going on.

Thanks

Hi @spockfish

Just to clarify.

I have 2 HAT cards a Digi Pro and Digi2 Pro.

The older Digi Pro works with all versions of Ropieee and settings.

The Digi 2 Pro worked with V3 software with HAT set to Digi Pro (Setting for Digi2 Pro was not available in that release).

The Digi 2 Pro does not work with V4 software using any settings. It is not listed in Settings Audio and therefore cannot be selected as an audio device. It is listed in Settings About which would indicate this is not a network problem.

Thanks for your help

Bob

Ok thanks, clear now.

Have inspected your feedback a little bit more carefully and I also don’t see that it actually tries to load a driver.

Can you set it back to ‘Digi Pro’, save it (commit etc.), but do not reboot it but send me feedback right after.

Thanks

@spockfish

Not sure I fully understand.

When the Digi 2 pro worked with setting of Digi Pro this was with version 3 software which I no longer have a copy of. I will do as you ask using version 4 and will post shortly.

Bob

Perfect, thanks.

@spockfish

Feedback posted: aa02bf95738d7d9f

Bob

Bob,

There’s a initialization error which points out to an hardware issue.

I see 3 possibilities: either the HAT is not properly attached, there’s a hardware issue with the HAT itself or something is wrong with the Pi.

Regards Harry

@spockfish

Harry, Thank you for your comments.

In trying to identify a hardware problem I have carried out the following checks:

  1. Connected the Digi2 Pro HAT to a Pi3 B+ running 4.002. All works as it should with HAT set to Digi2 Pro.
  2. Purchased a new Pi 4 as a test for the old Pi4. Connected new Pi4 to Digi2 Pro HAT and problem as before. Ropieee appears in Settings About, but does not appear in Settings Audio.
  3. connected new Pi4 to old model Digi Pro and all works as it should.

The problem combination is the Pi4 and Digi2 Pro.

I have now tried 2 Pi4 boards and tested Digi2 Pro card with a Pi3. I’m not sure if this still points to a hardware issue.

Before posting further feedback, I have changed the Hat setting in Ropieee to “No hat selected” then Committ, Save and Reboot. I then changed Hat setting to HiFi Berry Digi2 Pro then Commit, Save but no reboot. Feedback reference 8576f22185a7f9c9

I appreciate the time you are giving and hope a solution can be found

Many thanks, Bob.

Hi @Robert_Pettener ,

I’m a little bit confused: this seems like this is not a fresh install.
Are you swapping out SD cards?

I suggest you do a fresh install.

Thanks

@spockfish,

Apologies I started with 2 fresh SD cards but I may have got them mixed up with all the swopping of Pi’s. I’ll have another go tomorrow with a fresh install and post feedback.

Thanks Bob

1 Like

@spockfish

I’ve run the test again, Pi4 with Digi2 Pro using a fresh SD card. Feedback : 934ec7788a7cccde

Result was as before, Ropieee appears in Settings About, But is missing in Settings Audio.

For the time being I will revert to using a Pi3 B+ with the Digi2 Pro as this combination works ok.

Regards, Bob

Ok, I’ve ordered a Digi2 Pro myself to verify.

Thanks!

2 posts were split to a new topic: AUDIOPHONICS Digipi+ not working