High CPU usage of remote in Wine since Build 903 - some affected users but apparently not everyone

Immediately after updating to 903 I started having this (Ubuntu 21.10, Roon 32-bit in a separate 32-bit wine-prefix), no change after rebooting everything. Is it just me?


1 Like

I see the same behavior, and similar percentages (87% Roon + 30% Wine), with an AMD Ryzen 5 3500U and Manjaro.

Same here on my laptop, up-to-date Debian Sid on an Intel i7, with the same CPU usage as you both.

Many thanks @Pascal_Girard and @Lucas_Bonnet, it feels good not to be the only one, and I guess I won’t reinstall just yet if it’s more widespread

Mine is an i7 8th gen

We’be been discussing a bit in this thread:


  • Not everyone is affected but some are
  • I tried a vanilla install with the @spockfish script, unfortunately same issue for me (with and without login to streaming services, with and without scalefactor)
  • @Rob_Kirkbride always used the spockfish script and is also affected
  • spockfish himself and @tahsu are not affected with the script
  • danny doesn’t seem entirely opposed to looking into it, but I guess we will have to give him something tangible for what the factor is, Roon won’t figure it out themselves - in particular as not everyone is affected

One possible cause we haven’t isolated is wine versions, those may differ despite using the spockfish script.
I use wine-stable, which is wine-5.0.3 (Ubuntu 5.0.3-3ubuntu2)
And same issue after trying wine-development, wine-6.0 (Ubuntu 6.0+repack-1ubuntu1)

In this other thread you mentioned, Danny hinted at what he thinks might play into the issue:

So I think that comparing GPU, GPU drivers, Mesa and window managers (x-server, wayland) might be more important than Wine versions that are more or less the same for all, with or without the issue.

True. I guess the wine version hypothesis took a big hit when my wine-stable and wine-dev showed the same behavior :slight_smile:

Let’s decide for one thread to post in, this or the generic “Linux Control GUI” one, all info about hardware and drivers should be in one place, I suppose. I vote for this one because the other one has a broader topic.

From the other thread:

That’s what I thought yesterday, that I didn’t have it immediately after installing with your script, but it started after changing a setting. But I was tired and am not even sure I checked the CPU load in top and may have relied on the audible fans - and maybe they came on later. I am not convinced now that a fresh install today showed the same high load immediately with default settings.

Also from the other thread to keep info in one place:

My machine
Dell XPS 15 9575 2-in-1 laptop
8th Gen Intel Core i7
4K screen

Graphics (issue occurs with both):
Intel HD Graphics 630 onboard (and running the Gnome GUI)
Radeon RX Vega M Graphics (optional)

Ubuntu 21.10
Linux 5.13.0-28-generic x86_64
Xorg 1:7.7+22ubuntu2
Intel graphics drivers: xserver-xorg-video-intel 2:2.99.917+git20200714-1ubuntu2
libosmesa6 21.2.6-0ubuntu0.1
Gnome as per Ubuntu default

The Roon Core is ROCK on a NUC.
~2.8K albums, 36K tracks, local, Qobuz, and Tidal

Issue occurs on the Dell since Roon build 903 update. Using more than 1 CPU core between Roon.exe (~83%) and wineserver64 (~32%). Happens with these configs I tried:

  • wine-stable 5.0.3 (Ubuntu 5.0.3-3ubuntu2)
  • wine-development 6.0 (Ubuntu 6.0+repack-1ubuntu1)
  • self installed 32-bit Roon in 32-bit wine-prefix, Win 10, .NET 4.5.2 (this was the install that has worked since 1.5 years and all Roon updates from 1.7 and 1.8)
  • roon-on-wine script by spockfish in vanilla install and default settings. With and without Qobuz and Tidal login. With and without a scalefactor setting for my 4K display
  • both graphics cards

Is anyone handy with profiling wine? Might be helpful to know where wineserver spends its time. I’d have to read up and unfortunately won’t have much time until next weekend

Don’t delete your image cache, it doesn’t help and takes forever to rebuild

Edit: Another glitch, it does rebuild quickly after restarting. But it doesn’t help

Seems to be more widespread. @danny since we are supposed to “use Wine” as per this thread (which is usually fine), is there a chance that anyone could look into this? Happy to be available for any debugging needs


@Suedkiez, You are using just Roon in Wine as a remote, and RoonServer separately for Linux, right?

We’ve done a lot of stuff to respect refresh rate info coming out of GPUs/etc to support ProMotion, 120Hz displays on Apple devices, etc. I wonder if that’s causing load increases on Linux/Wine. Is anyone ok or is this universal for Roon / Wine?

That’s not quite right. There is no “supposed to”. Support-wise, the company supports Roon on platforms it supports, and the UI via Wine on Linux is not one of those. That said, we can try to be helpful, but we are not supporting Roon on Wine in any official capacity. We’d prefer to not break things that are working, but Roon on Wine is not part of our development or testing process.

I see how the title may imply it is our suggestion to use Wine, I’ll fix that.

Yes, just the remote on Ubuntu, the Core is Rock on a NUC. Worked perfectly fine until the new build.

In the thread I opened and linked there are already two other people with the same symptoms, but I don’t know how widespread it is, I guess we will see.

I understand that it’s not a supported option and I appreciate your efforts to not braking it, but I do admit that working under Wine is important for me. If it affects only a tiny number of machines/installations, then it’s bad luck and I can still try VMware (it’s just so clunky though, compared with Wine), but if it affects all Wine installs then it would be great if it could be investigated somehow. Even the new “you may try to use Wine” title would not help if it’s not workable at all :wink:

well, we didn’t know it wasn’t working until just now since we never tested with Wine! I’ll update it if we cant get something resolved.

ok thanks, looking into this.


@Suedkiez did you install it with my script?
I currently am not having these issues, just running as always.

Can you tell me a little bit more about your system?


No worries, just kidding. Whatever you can do, in case it turns out that it affects more than three people, is very appreciated

Thanks. Good that you don’t have it, that gives a bit of hope. No, not your script, installed by hand. It’s in a 32- bit wine prefix, Win 10 (Roon refused with 7), .Net 4.5.2. I always used the same install and updated Roon with the onboard means, always flawless.

Machine is a Dell XPS 2-in-1 i7, issue is the same whether starting Roon with the onboard Intel GPU or the optional AMD.

I’ll try your script

@spockfish Well, at first I thought that it didn’t happen with your script, but then it did. However, I was already changing Roon settings, maybe this had an effect. Will try again with a new install, but not tonight

Same high CPU load for me. I did use the script but it’s been working for me for over 12 months but now just maxes the CPU with fans running so no longer usable for me.

I’m running wine-5.0.3 on Ubuntu 20.10.

A post was split to a new topic: Wine script on Ubuntu Desktop, every so often locks up the window server,

I am running my core on Ubuntu Server and the control app on Linux Mint via @spockfish script (on a fanless NUC), so via wine. I also have HQ Player embedded on the Server. Using htop command on both machines does not show anything different really, the NUC running around 40% on its 4 cores and the Server running around 10% on its 8 cores. Currently streaming the white stripes, 192/24 upscaled to 768khz - so looks normal to me.

@spockfish Unfortunately, same result with a vanilla install from your script. I also tried logging out of Qobuz and Tidal, and I tried without a scalefactor (which I usually use because of a 4K screen). No change with either.

So apparently something is different between affected and unaffected machines, but it won’t be easy to find out what it is