History is blank

Just wondering if anyone else is having this issue but my History is blank and is not updating as I play songs
Any clues on how to get it working again?

Also, can the iPhone app display history? I can’t even see it as a menu item there

many thanks

Can you give more details about your setup? Does this persist after a reboot – you’ll want to restart Roon on your remote first, and if that doesn’t help, you could also try your Core.

In our phone interface, you can find History as part of the Now Playing/Queue screen.

History periodically blanks out on my iPhone and iPad. Restarting the apps fixes it. Same for radio stations.

On my new iPad the History is always blank. I have to kill the app then reopen it, and it then opens directly into a fully populated History screen

I’ve noticed that while I have a Roon Remote open (in my case on a Windows 7 laptop) if I stop the Roon Server process (on a 5i7 NUC running Debian), when I start the Roon Server process back up and the remote automatically reconnects to the core, play history is blank. Closing and restarting the remote on the Win7 machine brings it back. This seems like a bug to me but is pretty easy to remedy in my case.

There is indeed a very easily reproduced history bug, involves a roon master on one pc and a remote on another. Restart the central roon and history is blank on remotes; need to restart remote and it works OK

Same problem with me. Core is on Qnap. NAS was reinitialised. Music library restored from backup. Roon installed and backup restored. I can see all my music, favourites, playlists, devices but no history. Restarting doesn’t help.
Current played songs aren’t showed in history too.

Reinstalling app solves the issue… until Qnap reboot.
After reboot no library, no history.
Doing restore. Now I have library, favourites, playlists, but no history.
Doing app reinstall in Qnap.
Now I have everything working… until next reboot.

I did this cycle three times. Always the same result.

Not anymore. Now after reinstall and restore I have everything except history. Trying different sequence of reinstalls, restore, stopping and starting app, rebooting. No history.

10/20 11:27:58 Critical: scx: LevelDb.Exception: IO error: /share/RoonServer/RoonServer/Database/Core/fbb70c97e0ef48e9bdd1d889cbd1b33b/broker_2.db/019126.ldb: Invalid argument
at LevelDb.Database._CheckError (System.IntPtr err) [0x00037] in :0
at LevelDb.Database.TryGetValue (System.Byte[] key, Base.ByteBuffer& val) [0x0003e] in :0
at LevelDb.Transaction.TryGetValue (System.Byte[] key, Base.ByteBuffer& val) [0x00061] in :0
at Sooloos.Broker.Music.MusicDatabase._TryGetValue[T] (System.Object traceid, System.Byte[] key, T& msg) [0x00006] in :0
at Sooloos.Broker.Music.MusicDatabase+TransactionCache3[LOCAL,METADATA,OVERLAY].TryGetValue (System.Sooid id, METADATA& msg, System.Boolean cache) [0x00051] in <c3f83e578441427188bf8c55d2a55639>:0 at Sooloos.Broker.Music.MusicDatabase.TryGetValue (System.Sooid albumid, Sooloos.Msg.Metadata.Album& msg, System.Boolean cache) [0x00000] in <c3f83e578441427188bf8c55d2a55639>:0 at Sooloos.Broker.Music.MusicDatabase.TryGetValue (System.Int64 albumid, Sooloos.Broker.Music.AlbumData& data, System.Boolean cache) [0x00096] in <c3f83e578441427188bf8c55d2a55639>:0 at Sooloos.Broker.Music.Extensions.GetFeaturedAlbum (Sooloos.Broker.Music.Library library, Sooloos.Broker.Api.AlbumLite album, System.Boolean skipreview) [0x00011] in <c3f83e578441427188bf8c55d2a55639>:0 at Sooloos.Broker.Music.HomeResult.Home_GetStyles (Sooloos.Broker.Music.Library library, System.Int32 maxretcount) [0x001a6] in <c3f83e578441427188bf8c55d2a55639>:0 at Sooloos.Broker.Music.HomeResult..ctor (Sooloos.Broker.Music.Library library, Sooloos.Broker.Api.GetHomeDataParameters p) [0x000be] in <c3f83e578441427188bf8c55d2a55639>:0 at Sooloos.Broker.Music.LibraryApi+<>c__DisplayClass330_0.<GetHomeData>b__0 (Sooloos.Concurrency.ClientContext clientcx) [0x0000d] in <c3f83e578441427188bf8c55d2a55639>:0 at Sooloos.Concurrency.SharedState1+<>c__DisplayClass17_1[THREAD].b__1 (System.Object _) [0x00035] in :0
at Sooloos.SynchronizationContextThread._Dispatch (Sooloos.SynchronizationContextThread+SendOrPostWrapper& ret) [0x00012] in <25d73f18cc0f460fa0e05f69a9433340>:0
10/20 11:28:00 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)

This error shows in logs after unsuccesful history access.

Problem solved.
Instead using Roon backups i removed app.
Installed it again clean.
Stopped process.
Then I overwrited /.qpkg/RoonServer (app directory) and /RoonServer directly from old full system disc backup. That backup was done too with Roon process stopped.
Running Roon app. Long time observing increasing file of logs.
Waiting until logging stopped.
Opening PC app. Ewerything is like before. Perfect. Restarting Qnap. Everything is working perfectly again. :slight_smile:

It’s good to make full system volume backup in addition to RoonServer database.

Hi @Jan_Werbinski,

I’m glad to hear that you got things up and running here. If you have any questions or you see any issues return please let us know!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.