HomePod appears but no output

(Kuryan Thomas) #1

Core Machine (Operating system/System info/Roon build number)

Ubuntu 18.04.2 LTS Server
Rack mounted server, Xeon v6 quad-core, 16 GB RAM, Roon installed on SSD boot logical volume.

Roon Core 1.6, Build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Enterprise network gear from UniFi, including WAPs. Core is hard wired. All network gear is hardwired via home-wide CAT6 cabling.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Apple HomePod on 5GHz WiFi channel 36, signal strength -63 dBm.

Description Of Issue

I’m having the same issue mentioned here.

No solution is mentioned there.

The HomePod appears as a zone and can be selected and configured. However, when I click play, nothing happens. The progress bar simply sits stationary.

I do not have the problem with other AirPlay devices.
If I play Roon to my iPad and then tell iOS to set the iPad’s output to HomePod, it works.

(Kuryan Thomas) #2

I reset and reinitialized the HomePod and it appears to work now. I will keep an eye on it to make sure it’s ok.

(Kuryan Thomas) #3

Nope, spoke too soon. It seems to work right after a reset but then doesn’t work after the first queue ends.

(Dylan Caudill) #5

Hi @Kuryan_Thomas,

Has this device worked for you previously? Are you able to play to other Zones besides this one okay?

Can you share a screenshot of Device Setup for this Zone?

(Kuryan Thomas) #6

Hi Dylan,

No, it’s a new device.

Yes, all other zones function normally. Some are AirPlay zones, some are not.

Sure thing, here is the device setup screen…

(Dylan Caudill) #7

Hi @Kuryan_Thomas,

Just to verify this is a single HomePod and not being used as a Stereo Pair, correct?

Have you tried rebooting the Core machine since experiencing this?

(Kuryan Thomas) #8

Correct, a single HomePod, not a stereo pair. It is the only HomePod in our home, there are no others.

Yes, I have restarted the Roon Core. I have also reset the HomePod itself, after which it did work with Roon; however, as soon as the music queue emptied, it stopped working again. I’m happy to attempt that again if you think it would help debug.

Thanks.

(Dylan Caudill) #9

Hi @Kuryan_Thomas,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time that you start playback (but there is no sound). Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

(Kuryan Thomas) #10

5:38 pm EDT, Thursday July 18, 2019.

Again at 5:40pm.

Thanks

(Dylan Caudill) #11

Hi @Kuryan_Thomas,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

(Kuryan Thomas) #12

Could you explain what you mean by “the next time the Core is active”? Do I need to do anything in particular? My Core runs on a server that runs essentially 24/7.

Thanks.

(Dylan Caudill) #13

Hi @Kuryan_Thomas,

No, nothing in particular that needs done. The diagnostics report has already reached our servers and I’ve passed it along to the team. I’ll let you know once I receive their feedback.

(Dylan Caudill) #14

Hi @Kuryan_Thomas,

I spoke with the team about their analysis of the diagnostics report. They’re seeing some errors that appear to show that something is blocking the connection between Roon and the HomePod and they have some questions they were hoping you could clarify:

  1. Just to confirm, you did a full factory reset on the HomePod, correct?
  2. Can you confirm how the HomePod is connected to the network? If you connect it to a different access point is there any improvement?
  3. Do you have any antivirus or firewall software running on the Core machine? If so, is there any change if you temporarily disable them?
(Kuryan Thomas) #15

Thank you for getting back to me. If I may, let me respond to your questions in reverse order:

Question 3. There is no antivirus or firewall software running on the Core machine. See screenshot of login to the Core system, followed by system firewall status below…


Question 2. The HomePod is connected via 802.11ac wifi. The house was wired at construction for a UniFi system. There are 5 UniFi wireless access points connected to a core switch by in-wall CAT6 cabling. Each access point covers a different section of the house. I just moved the HomePod from one part of the house to another and made sure that it was re-connected to a different access point. Nothing has changed. See the image below that shows the status screen for the HomePod in the UniFi app. Below that is a screenshot showing the relevant topology of my home network. If you need any more details, please let me know and I am happy to provide them.

Question 1. Yes, I had reset the HomePod completely (remove it from Apple Home app, reset, reboot, re-initialize through iPhone). It then worked for a little while but then stopped. Let me try that again and I will get back to you in a few hours with the results.

(Kuryan Thomas) #16

@Dylan
Here is what I’ve discovered after multiple resets.

If the HomePod does not connect to my iCloud accounts, it works fine with Roon. But as soon as it connects to my iCloud accounts, the symptom shows again.

Following are two screenshots showing the status of the HomePod from within the iOS Home app, which seems to be the only way to interact with the HomePod. The first shows that the HomePod is NOT connected to my AppleID. In this configuration, Roon works. The second shows that the HomePod IS connected to my AppleID. In this configuration, Roon does not work.

Unfortunately, I cannot run it permanently in the configuration that works with Roon, because without a connection to my AppleID, it cannot control my home automation.

Roon works if I use another device as the output and stream that device to the HomePod via AirPlay. If we cannot get Roon working directly to the HomePod, I guess that is my only recourse.

(Dylan Caudill) #17

Hi @Kuryan_Thomas,

Thanks for the additional information here, I’ve updated your ticket and passed it along to the team for further feedback.

In the meantime, I was hoping that you could try rebooting your router once the device is in this state and let us know if that yields any changes.

(Kuryan Thomas) #18

@Dylan
Thanks. By rebooting the router, I assume you mean reboot the entire network. Yes, I have done so, including the router, switches, WAPs, etc.

(Rebooting just the router won’t affect this situation, since both Roon Core and HomePod are on the same subnet 192.168.10.0/24. Packets from one to the other would be handled “in Layer 2” by the core switch itself.)

(Dylan Caudill) #19

Hi @Kuryan_Thomas,

In the settings for your “Home” in the Home app on your iOS device, can you check to make sure that “Allow Speaker and TV Access” is set to “Anyone on the same network”?

You can read more about that setting here: https://support.apple.com/en-us/HT208341

1 Like
(Kuryan Thomas) #20

@dylan
Yup…that was it. Thanks.

That is one obscure setting!

1 Like
(system) closed #21

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.