iBasso DX160 DAP & Roon Android App - a failure

I have just bught the aforementioned DAP.
Upon installing Roon on it, everything seemed to work OK but after a few hours of playing, music has started to stop after 7-8 seconds when I opt to play a track. The app reports ‘‘audio file is playing slowly’’ and will never recover.

There’s no way to remedy the issue. Even if you close the app and re-open, it will again play for a few seconds and after that will report the same error.

I cleared the cache of the app, installed ccleaner on the device, cleared all data from play store - all to no avail.

The only thing that worked was to factory reset the player. Problem is after the factory reset and having set everything from the beginning, the device had only worked for just one day and now exhibits the exact same issue / error.

In fact apart from my Note10+ all other android devices I’ve tried with Roon are seriously painful and cumbersome in day to day use. And that Note 10+ have only started to work more reliably after the 1.7 major update.

I’m seriously frustrated and dissapointed the Android app of Roon is still in a primitive stage as opposed to the IOs app which reportedly works a lot better. That’s UNACCEPTABLE. Like it or not, most people have already moved or currently slowly moving to Android. It’s not 2010.
When you decide to raise the price or even demand more from your customers, you should at the very least address such BASIC issues.

I’d rather stop here and not continue with this rant but it seems I forked out 400$ only to fnd out it is absolutely useless to me and will eventually have to look into selling the device or returning it.

Not to mention the Linux installation which you have to be a Linux terminal cowboy in order to install Roon remote on a f laptop running Ubuntu

Hi @gtj,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Outside of the iBasso are all of your other endpoints working okay?

Hello and thanks for responding.

First off all other endpoints work perfectly fine within my local network.

  • Details on your Core machine (OS, Hardware specs)

Dell SFF with an i5 4590 and an 120 GB Sandisk SSD

  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
    My Internet Provider offers me 100/9 (down/up) mbit speed.

My local network (Gigabit) is consisted of a pFsense firewall running on a ‘‘PC engines’’ board with a couple of Netgear switches and and a Ubiquiti AC lite Wireless Access point.

  • Audio devices in use
    Roon Streamer based on Raspberry Pi board with Hifi Berry Digi+ Pro and the Official RPi 7 inch Display connected to my main Hfi System.

Topping DX3 Pro on my main PC

Another Volumio Streamer based on a Asus Tinkerboard

Galaxy Note 10+

iBasso DX160

  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)
    No streaming service used.
    All my library is based on a makeshift NAS box running Openmediavault (Rock Pro 64 board - RAID0 configuration, Very fast transfer rates locally)
    Library 10K + albums / 86K + songs / 3800 artists

Please let me know if there’s anything else you want me to check.

Hi @gtj,

Thanks for the details, and for confirming that Roon is working okay with other endpoints.

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs as well as what track you were trying to play. Then respond here with that time and track, and I’ll make sure we review the diagnostics related to that timestamp.

Hi Dylan,

Can you please check the diagnostics for me?
The reason I have not post this earlier is because after the 2 latest updates things got significantly better on the DX160.

Now it’s very much a workable situation with only occasional drops and glitches. Specifically I have not seen the problem again when a song would play for 3-4 seconds and then stop indefinitely. Now it will only fail to open some music once in a while and in most cases if I skip track or album, it will recover without me having to restart the device.

Please check the two tracks below:

Asia - Only time will tell (Definitive collection) 17. 13
Dennis Deyoung - This is the time (Ultimate collection) 17.18.

On the second example, the track did eventually start playing after 2-3 minutes. Until then it showed “loading slowly”.

Please note times are UK times.

Many thanks.

EDIT: On track Romeo and Juliet by Dire Straits (The very Best of) the music was loading for several minutes and then it started playing but subsequently stopped after a while(time: 18:40). It was then that Roon attempted to skip to track ‘‘Tanglible Evidence’’ by Wishbone Ash but the track won’t load either.

Hi @gtj — I’m glad to hear that things have improved!

Diagnostics have been enabled for these timestamps so the team can take a look.

Does this happen every time with these tracks or will it work fine with these tracks usually?

Have you experienced any similar behavior outside of the DX160 lately?

Hi Dylan,

Thanks for getting back.
I didn’t have the time to play around much with the DX160 but clearly I can now listen to music for over an hour without having those annoying loading errors.

It seems that (when the problem occurs) it’s not track specific. I mean it can happen to any track in the library and my observation is that it happens when I navigate back and forth to different artists and albums. If I stay on a specific artist and album (and better yet play that whole album) most likely it won’t give out any errors and will work flawlessly. On the other hand, when the DX160 gets ‘‘saturated’’ (if you know what I mean) it will start exhibiting the problem. I’ve been playing the whole debut album by Dire Straits and the album ‘‘Us’’ by Peter Gabriel during the past hour and I didn’t have any problem.

I will also keep an eye out on the data and cache of the Roon app and clean those up if it happens again to see if it will make a difference.

No, I haven’t noticed this happening with my other devices.

I will update the thread if the problem re-appears quoting the files and timeframe.

Thank you.

EDIT: Van Halen - When it’s love - track stopped after 5 secs (01.05). I cleared the data and cache of the app and managed to restart the song but again it stopped after a few seconds. Therefore I assume this has nothing to do with the app’s background data?

Any update with this? No progress has been since my last post and no update either.

Hi @gtj,

There was an update last week to Roon — Just to confirm, was there any change at all after that update?

If not, I’d like to run some further diagnostics if you could provide a timestamp the next time this happens so we can see what’s occurring on the latest version.


Hi Dylan,

I’ve just updated to the latest version.
I noticed performance is more stable when I’m connected to 5g instead of the 2.4ghz band.Can it be something related to the bandwidth the app uses since 5g allows for a bigger amount of data?

Another time stamp is just now : 23/6, 16:48 - the song Sugar Mice by Marillion stopped after just a few seconds.

Hi @gtj,

It’s definitely possible that this is networking related. We typically recommend using 5ghz over 2.4ghz. Is there a reason you use 2.4 over 5?

Was the time stamp you provided on 5 or 2.4?

Hi Dylan,

It was on the 5Ghz band.
I connect to 2.4 when I want to move away from the access point as the 5g band is supposed to be limited in range.

How far are you moving?

Not much as the house is not very big. I’d say from the living room where the AP is located, to the master bedroom. 10m? There are brick walls though and I found the 2.4ghz band has better coverage around the house than 5ghz. The 5ghz however is noticeably faster in all speedtests I have carried out.

Hi @gtj,

Does this seem to happen when you’re moving between between areas in the house (i.e. when moving from one AP to another)?

When I had the DX160 I can say in the short time I had it the WiFi on it sucked, it barley got past 20mb/s directly underneath my wifi ap. Moving a few metres it dropped substantially and couldn’t play anything from Roon reliably and the app crashed a lot. I sent it packing and went for the Hiby R5 which works and sounds way better. WiFi is still not as good as a decent phone , but it’s a massive improvement over the dx160 and I am not alone in this as many have switched to something else due to this problem.

1 Like

My Android phones outperform the Android DAPs by a huge margin when it comes to WiFi.
The phone works down the garden my DAPs stop if you look at them wrong.

1 Like

Yep it’s this area they seem to skimp on using old and poor quality WiFi components, the aerial placements are not great either. When in garden ok cant move the dap for fear of it loosing WiFi. So I use my phone to control it.

There’s only one AP for the whole house and the house is a not very big bungalow.