iFI Audio iDSD Micro - DSD512 capable but Roon displays DSD256 as max

Hi, I have an ifi audio dsd micro. That device is DSD512 capable but in Roon I can only choose an upsample rate of DSD256. Is that a known limitation in Roon or what is the problem here? By the way, I’m using the latest Roon build on Windows 10.

Check Device setup-Playback-Max DSD Sample Rate. That should be disabled.

In the audio device setup DSD512 is marked in color red what means that DSD512 is not recognised to work in Roon.

Thats strange because the iDSD Micro is definitively DSD512 capable.

Maybe this is a topic for @support?

I have an IDSD Micro too. Works flawless with 512 here. (Win 10)

I’m really confused with the audio device setup. Something must be wrong here. I have rebootet my machine and now the DSD512 is shown in color green but in the DSP setup I do not have the DSD upsampling option anymore. It is not shown there at all.

Lucky guy :grinning: Hopefully the guys from support can help to solve my problem. Do you have a dedicated Windows10 PC? Mine is a Mac Mini Late 2012 with Bootcamp Windows10. Maybe that is part of the problem…

Have you selected Native DSD as DSD playback strategy?

I run OSX so I’m limited to DoP and DSD256.

Yes, I have.

Hi @Jens_G ----- Thank you for the report and sharing your feedback with us. To help me better evaluate this behavior you are reporting to us, may I kindly ask you to please provide the following:

  1. A brief but accurate description of your current setup as seen here.

  2. Can you please provide screenshots of the device settings you are using for the iFi in Roon.


Hi Eric, yes of course. Please find the details below.

My Setup:

Roon version: 1.3 (build 218) stable (64bit)
Windows10 build 1607 (64 bit)
Mac MininLate 2012 w 8gb of RAM
Music is stored on a NAS
Approx. 20k tracks

The problem is that I cannot choose DSD upsampling at all under the DSP engine setup. That option is not displayed there.

You need to use “native” mode – DSD512 isn’t going to work over DoP.

Let us know if that helps @Jens_G!


Thanks for the proposal but it didn’t help. Situation remains unchanged.


Hi Jens

That Win 10 PC is the Roon Core Machine in my house.
It feeds my Roon network.
I use it to do maintance work on the database and a bit of listening with earphones while doing that.
The DAC in use here is the Ifi.
There is no Hifi System or loudspeakers attached to that PC.
It is an i7 6700 machine with a good cuda capable graphic card to do the heavy HQP work if necessary.
That PC is per se noisy and is isolated from my other listening places via network.

Can you post another screenshot of your audio settings, in particular the Playback tab?

Hi Mike, here it is.

I have a iFi Micro iDSD and can confirm the same issue, Using roon bridge on a Pi 2.

Hi @Jens_G ----- Thank you for the follow up. I had a chance to touch base with my team yesterday and we would like to kindly request one more screen shot.

Please provide a screenshot of your “audio tab” as we would like to see the zones you have in Roon.


Hi Eric, here are the screenshots of the Audio Tab. It’s really crazy. I have completely re-installed Windows10 and RoonServer. Initially the DSD-upsampling option was available but after having played some somgs it completely disappeared again and I cannot re-activate it.

1 Like

Hi @Jens_G ---- Thank you for the follow up and providing the requested screenshot.

I am fairly certain that we have an iFi in house and will schedule time to test it with our tech team. In the interest of being consistent, may I ask for one more round of screenshots in a PM displaying all of the settings you are using currently so we can test under the same conditions confidently?

I will be on the look out for your PM!