Internet radio station not working - problem only on rpi3 running dietpi

I have a very weird problem. I have six endpoints, of which two is running on RPI 3 with Dietpi. I have installed internet radio programs at Roon, which has been working fine until now. It is still working on the four not running on RPI 3, such as two RPI 2. On the RPI 3’s the radio start, but stop after three minutes with the error message something like “unable to play this channel- its address may have changed or the connection may be lost” - it is only shown for a second, and then it stops. It can be restarted, but stops again.
What I find strange is that it works fine on the other four endpoints, it is only these two (one with an Allo Boss I2S dac, and one with a Hifiberry +) that gives this problem. Furthermore, it is playing Tidal and my own music without problems, which I find really weird. I am not sure whether it is a Roon problem or a Dietpi problem? My wife use this as the radio on a daily basis, so it is quite annoying. Any ideas of what to do?

Hi @Henry_Larsen ---- Thank you for the report and sharing your observations with us.

To help aide in my assessment of this behavior, may I very kindly ask you to please provide me with the following:

  1. An expanded description of your current setup as seen here.

  2. Please outline the details of your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a completed understanding of how your devices are communicating and what tools are being used to make those connections possible.

  3. You mentioned in your report that everything has been working as expected until recently, can you think of any chances that have been made to your setup since noticing this issue? I am trying to determine if there is a variable(s) that could be having influence here. Remember, no detail is too small :wink:

  4. When you do notice this problem is it with the same radio station each time or does it occur with others as well?


Hi Eric
Thank you for responding. Here are more details

  1. version of Roon: 1.3 build 223 64 bit. Roon is running on top of Linux Mint 18 on a NUC I5 fifth gen, 8gb Ram on an SSD. Music is stored on a NAS, Synology Atom. RPI Endpints 1.0 version 86.
  2. The NUC and the Synology is linked to a switch with wifi, to which one of the RPI3 is linked with a cable, and the other RPI3 get the signal via wifi… The two RPI2 that works both get their signal via wifi. The switch is linked to a router, that gives IP addresses and is linked to ADSL.
  3. The problem include all the internet radio programs. Timewise the problem emerged very recently ( within the last two days) around the same time as the latest update of Roon. The internet radio start fine, but stops after three minutes. It can be restarted but the same happens again after three minutes. And – it only happens on the two RPI3 with I2S dacs ( one Allo Boss that is wired to the network, and another RPI3 with a Hifiberry+, that runs wirelessly. All the RPI’s are running Dietpi 4.19. There is no problem at any of the endpoints when playing music on the server or from Tidal, and there is no problem with the internet radio on any of the other endpoints, such as two RPI2 with USB dacs and a PC with a Meridian dac2.
  4. All the internet radio stations gives the same problem on the two RPI3’s. I have for the sake of it installed a new radio station – this also stops after three minutes on the RPI 3’s. I have not tried (yet) to reinstall the dietpi software. Apart from different danish stations I have also Alligator, which behaves in the same way

As mentioned - I don’t think that it is network problems since tidal works fine.

Eric, for the sake of it I reinstalled the dietpi image and Roon again at the RPI3 with the hifiberry - it is still creating the same failure. So now I don’t have more ideas of what to try.

Hi @Henry_Larsen ----- Thank you for touching base with me and taking the time to answer my questions.

I have meeting with my team, plus one of our developers tomorrow to discuss any pending support issues and I want to bring your case up to see if we can get some feedback on this behavior you are experiencing with the two end points.

In the meantime, may I kindly ask you to please reproduce the issue, note the time when the observations is made, and send us over a set of your logs.


Hi Eric
Thank you. I am not able to get the log out of the NUC right now - I need a mini HDMI to HDMI plug - will find one later today. I have reproduced the issue and noted the time, and I have also experimented with eliminating the switch by linking the NUC directly to the router, but without any change. I aim at sending you the log later today.

So here follows the file. 6.58 AM this morning the Boss stopped, 7.00 AM the Hifiberry stopped. I had started the two RPI2 (Køkken & Stue) which worked fine - however they stopped 20 minutes later, which is an exception - they have been running the whole day without any stops. I then experimented with moving the NUC, so it was shut down, and moved to link directly to the router, however the Boss RPI 3 and the Hifiberry endpoints stopped again (7.36 and 7.39. AM.

As mentioned we have not experienced problems with neither Tidal nor my own music files on the Synology server.

Sorry I forgot the link to the file, here it is

Hi @Henry_Larsen ----- Thank you for the follow up! Confirming that the logs have been received. We’ll let you know what we come up with. Your patience is very appreciated!


Eric, I came to the idea this morning to try what I would see as the “ultimate” test. I linked the NUC and ono of the RPI 3’s ( with the Hifiberry + dac) directly to the router, each with a short CAT6 cable. Exact same result - both a danish internet radio and Alligator stopped before three minutes with the message “The connection has stopped, its address may have changed or it might have come temporarily unavailable”, while Tidal works perfectly. The router is Sagemcom provided by my interned provider, running an ADSL 25/5 line.

Hi @Henry_Larsen ---- Thank you for touching base with me after running the mentioned test. The continued feedback is appreciated!

Moving forward, I would like to gather some more insight into what troubleshooting you have tried thus far. Can you verify for me if you have tried swapping out the two RPIs (temporarily of course) with two of the the other 4 units that are functioning as needed to confirm: A) that the units which have been working still function in the “zone” where the two units that were struggling resided and B) If the two units that were struggling now function better in a different zone.


I have tried to swap the RPI3 with the Hifiberry around in different configurations, wireless, as mentioned attached directly to the router to which I also temporarily attached the NUC, with wire to the switch to which also the NUC is usually attached and it behaved with the same failure every time.
Eric, maybe I should explain the configuration of my network into more details to say why I think that further experiences will not change:
From the router one cable goes to a switch, to which a PC ( Win10) with the Meridian is working perfectly, and the RPI3 with the Boss also cabled to that switch is showing the failure. Then another cable goes from the router to a switch, to which the NUC, the Synology with the music and the Wifi transmitter ( a former router) are attached, and now and then also the RPI 3 with the Hifiberry. The two RPI2 with each their USB dac that works well are linked wirelessly. They are usually grouped, which is not the case for any of the others.

I am of course interested in trying anything you would want me to try out, but I am away from my house until Sunday night. Would it be interesting to group one of the RPI3’s to the RPI2 group?

Thanks for the insight @Henry_Larsen! Can you verify the make and models of the following devices mentioned in your description:

“From the router (?) one cable goes to a switch (?) …”

“Then another cable goes from the router to a switch (?)…”

“…and the Wifi transmitter ( a former router) (?) are attached…”


I can give you this info on Sunday. But did you notice that I mentioned seeing the exact same behaviour at the RPI 3 when I linked that and the NUC running the Roon server directly to the Sagemcom router with short CAT 6 cables. I cannot see how the rest of the system possibly could influence that?

Hi @Henry_Larsen ---- Thank you for the follow up.

The reason I am asking for this additional information is so I have a complete report in the event that this issue winds up with one of my developers. Opposed to going back and forth for data gathering, if I have everything before hand, we can drive straight into addressing the issue at hand.

Moving forward, I would also like to grab another set of logs from you following the same procedure in my previous post, but this time I would you to grab them from the Roon bridge folder on one of the RPIs that is experiencing this issue.

“Please reproduce the issue, note the time when the observations is made, and send us over a set of your logs.”

Looking forward to your feedback!

I cannot find the Roon bridge folder on Dietpi - there doesn’t seem to be a roon folder in the var directory? Where should I look for it?

  • henry

DietPi B149:

root@DietPi:/var# dir
backups cache lib local lock log mail opt run spool swap tmp

No roon directory in var

and consequently when I say
root@DietPi:/# cd var/roon/RoonBridge/Logs
-bash: cd: var/roon/RoonBridge/Logs: No such file or directory

What am I doing wrong?

Is Roon Bridge at all installed on that Pi? Can you post a screencap of your signal path while playing (anything) to that Pi from Roon?

OK - I didn’t think of that. You are probably right - I installed Roon with the DietPi installer…

However - here follows the other info Eric asked about
To catch up after the long exchange – I have only problems with Internet Radio – but with all the installed radio stations ( Different Danish stations and Alligator). Everything else, including Tidal is running smoothly, and the problem is only on two RPI3’s, not on two RPI 2’s nor on my PC with a Meridian2 dac.

You asked for my standard setup.

Router TDC Homebox V50K40 ( provided by the internet provider TDC, the router is made by Sagemcom) on a 25/5 line
– linked to switch, (Zyxel GS108S) that is linked to

  • NUC (4th gen, running Roon on LinuxMint 18.2)
  • DS214play server with music
  • ASUS RT A-66U, only running as wifi provider

Two RPI 2 running USB dacs are running on this wifi without problems.

From the Router another cable goes to a

  • Switch Sandstrøm SS5PSW, that is linked with
  • RPI 3 with Allo Boss
  • PC with Meridian Dac2.

The other RPI3 with a Hifiberry Dac+ has been linked both wirelessly, and wired to the Zyxel router. Furthermore I have tested a mininal setup with the NUC and the RPI3 with Hifiberry+ linked directly to the router with short cat6 cables. Similar result – the internet radios stop before three minutes, while Tidal runs flawlessly.
Please tell me if there is anything else I can do to help solving this.