iOS (iPhone) remote freezes completely

Roon Core Machine

Roon ROCK Version 1.0 (build 227) stable
Roon Server Version 1.8 (build 898) stable
Roon iOS App 1.8.00898

iOS Roon app freeze suddenly from yesterday and had exactly the same symptom as reported before on an Android device.

Android remote feezes completely

I have rebooted the core, network, uninstall and install the Roon iOS app but no luck.
Luckily only one iOS has this issue, but it is most often used.

Anyone has experience how to resolve it? Or I need to wait for a new roon release?

Alex

more info on the device in question is needed. Model , OS version, what else is running etc

It is running on iPhone 13 with iOS 15.3 (the latest).
The Roon iOS app ios is also freshly downloaded again from the App store.
I think it is hard to list out all other applications on the phone as there are many. Having said that, the device is not jail broken and thus all apps from App store. Before the issue happened last night, no other app increased or decreased. I also try changing the phone language to English (from Chinese) but no luck. Previously it run well on the Chinese launguge.

For the ROON core, I think it is a NUC8BEB, intel i3, 16G ram. As it is running ROCK, no other software is there.

It is strange that it was workly properly and suddenly froze. And only applied to 1 device. So I think it is more on the software issue rather than environment or hardware change.

Hi @Alex_Tang1
Since I can no longer write in the now closed thread, an update on this here:
After software release Roon 1.8 (Build 884) there was a change in behaviour, everything works now except for “Home”.
This means that everything can be used and opened without errors, but as soon as I try to open “Home”, the app freezes immediately. However, the app can be force closed and reopened, and then starts at the last status before I tried to open “Home”.
I have to use another device if I want to see Daily Mixes, Recent Activities, New Releases, Roon playlists, etc.
All other 5 remotes work flawlessly.
@noris
@support
Would a video of this behavior be helpful?

I don’t have that luck. The iOS app is reinstalled and it can only start with a default landing which always freeze. I try to use mobile network, though I know it will not connect, the app will keep searching for core and show proper error message. This can prove the freeze is after it connected to the core.

1 Like

Hey @Alex_Tang1,

Thanks so much for reporting this. We’re very sorry about the trouble and would love to take a closer look and see if we can help.

Could you please:

  1. Terminate Roon
  2. Go System Preferences on your device
  3. Scroll down until you find Roon option
  4. Tap on it
  5. Toggle the switch for “Save logs to Files on next start up” option
  6. Launch Roon
  7. Go to Files → On this iPhone/iPad
  8. There will be Roon folder, you need to enter it and upload the archive here.

Thanks :pray:

The iOS app has resumed suddenly since yesterday with nothing being modified. Anyway, I uploaded the log for you. Hopefully, you can understand what is happening before.

1 Like

Hey @Alex_Tang1,

Thanks for finding the time to share this with us so quickly.

I’ve passed on the logs to our technical team and I’ll follow up as soon as I hear back. Please, keep in mind they get back to work on Monday :relieved:

After upgrading to build 903 everything is completely frozen again and nothing works anymore.
No way at all to open the remote app.
@support
Will the old thread stay closed though there is no solution yet?

Hi @Alex_Tang1 ,

Have you had any further troubles since your last post or has the app been working correctly? It looks like there were a few network-related errors in your iOS logs, including an image downloading failure. If the issue is still occurring, it would be curious to know if these same traces still appear in newer logs.

Hi @noris ,

Actually, my iPhone has another freeze a few days ago. No matter how I quit and restart the application, it will freeze once it is started. However, if you leave it there for the next day (or a few days), it will resume normally. Though I am not a programmer, I also come from the digital field as a PM. My best guess is some network-related issue like the app can’t get a token to verify it has the license to run and thus hang. This also aligns with the log finding that it has some network-related issues. I have prepared the log. Do let me know how to upload to you again.

Alex

Hi @Axel_Lesch

I have the same problem. After upgrading to the latest version, the problem does not go away.

Hi @Alex_Tang1 ,

It has been a while since you posted, are you still seeing this issue? There have been further improvements to our iOS app, if you can try to reinstall the app, perhaps that will help.

1 Like