Android remote freezes completely

I have a problem with my phone’s Android remote app since today, nothing works anymore.

Samsung galaxy note 10+, Android 10
Rock on NUC8I7BEH hardwired to the router

I have tried the following:
Removed the app and reinstalled, rebooted phone, core and router several times without success.
I have no idea what else to try.
iPad OS remote still works thankfully.
Here are two screenshots of what I see.
Nothing more can be done, the app is completely unresponsive.

Hi Axel have you tried setting your core IP address to

Have a look at this thread

Also this thread has been helpful to users

Thank you @Michael_Harris!
I don’t know how to do this …
As the above Screenshots show, there is no problem to connect to the core. But after connecting the screen is frozen und there’s nothing I can do.
Can you please advise where the core’s ip adress can be changed?

Hi Axel nop problem, if you uninstall the app, and then reinstall the app, the first link I sent you shows you where to do this (by pressing the help button when it looks for your core then you can enter an IP address of regardless of what you server IP address it)

It is sometimes caused by routers that do not support Multicast properly.
Have a little read through the two threads, as there is a lot of heavy networking going on inside Roon.

It does appear that Samsung phones have become a bit of a problem recently, but mostly with Android 11 and not 10 as you have.

Good luck

Hi @Michael_Harris
Thanks a lot for your help.
I don’t know if I am missing something, but there is no help button at all …
Here’s the complete process after removing and fresh installing the app:
After opening I am asked to agree and I do

Next I get choose your roon core
and “configure Roon os devices”
If I go to “configure” I get:

That leads me to the Rock Web ui.
So select “Done” and next “Connect”

and I get this, completely unresponsive:

Am I missing something, there is no “help” button at all?

I have tried an older Galaxy Note8, also Android 10.
This works without issues.
Strange, my Note 10+ also worked perfectly until today …

Alex have you had an update to your Note phone, also have you rebooted your phone and your Roon Core (as this sometimes happens on my Oneplus, but a reboot normally brings it all back).

Normally the issue is you cannot see the Core at all and I can see you do not see the screen I sent you, which suggests that your device is finding it right away.
In your case it is finding it right away, so you do not see that, though it could be hidden under the Language Dropdown, see if you can see anything under there.

No, there was no update.
And I have rebooted everything several times, phone, router and core.
Unfortunately, I can’t select the dropdown menu, because the app screen is completely frozen and unresponsive to all efforts.
Thanks for your help anyway, Michael.
Hopefully @support has something about it.

Sorry Axel that I could not help you.
I will leave you to support now and go to bed.

Hopefully it can be sorted out for you.

1 Like

Hi @Axel_Lesch

It looks like the connection is made successfully but unfortunately, something freezes when trying to load the Home page. I’ve enabled diagnostics so we can take a look at what’s happening here — Can you try connecting a couple more times and let me know once you’ve done so? Please close the app completely (but not reinstall) between each try. This should give us some data to see what’s happening.

1 Like

Same issue here
I have this screen while trying to launch the app.

After closing, reopening several times it finally launches the app. But it is tiring

Hi @dylan, thanks, I have done so.
The first time is a fresh install. After that I rebooted router, Rock and phone and opened the app for the first time, see screenshots.
Before reopening 5 × I have closed the app completely.

Unfortunately, the problem persists after today’s update. I did an update for all devices, rebooted router, rock and phone, but everything remained unchanged. The times I tried see screenshots:

For me , Galaxy Note 10+, suddenly everything works fine again overnight.
There was no update, neither for my phone nor for the Roon remote app …
Strange, but anyway, I’m glad about it for now!

I spoke too soon :roll_eyes:
All problems are back - app completely frozen und no way at all now to open it.

Hi @Axel_Lesch ,

This should be fixed in the latest Roon release, but please do let us know if you are still seeing issues, thanks!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

I am sorry for having to say that the error came back.
I have gone through the whole procedure, uninstalled and reinstalled the Roon remote app, rebooted router, rock and phone without success. The Roon remote app is completely unresponsive and frozen, as before.

Please see screenshots for exact times.

Hey @Axel_Lesch,

I’m so sorry to hear about this, but, simultaneously thankful that you’ve let us know. Your thread is reopened and in our technical team’s queue.

I’ve notified @noris of this and he’ll get in touch as soon as possible (we’re catching up after the holiday weekend here in the US).

1 Like