iPad12.9 Roon Remote Issue

I got an iPad Pro 12.9 for Christmas. Latest generation, software version 13.3.

Installed the Roon Remote App. Nothing else was installed. Worked fine for several days then something happened.

When the app is installed Overview is the initial or home page (no back button). Don’t know what else to call it. For some reason it got hosed up one day and Queue ended up being the home page. I could select Overview but the back button took me back to the queue page. Tried terminating and restarting the app but it did not go back to the original condition with Overview as the initial page.

I had to delete the Roon Remote app then reinstall to get back to original condition.

No idea what I did to create this situation so I can’t recreate it.

Has anyone had this issue? Any ideas? Is there a better solution other than deleting and reinstalling?

Hi Mike,

This is expected behaviour. There isn’t really a home page for the app. It should always return to the last page you visited.

Cheers, Greg

Hi Greg, I don’t think its expected behavior in this instance. I do realize the remote is supposed to start back up where you left off but there has always been a back arrow button to cycle backwards to the Overview page. In this instance the Roon remote came up on the queue page with no way to cycle backwards. I had to select overview from the menu to get to that page and go forward from there. When I backup up as far back as I could go I ended up on the queue page instead of the overview page. I don’t recall that happening prior to this occurrence. Thanks.

Thanks Mike.

If you could show the steps to get you into this state, that would be helpful for @support and the developers.

I know you can’t recreate it, but try and keep an eye out for it. I have a smaller iPad, I’ll watch for it too.

Cheers, Greg

Thinking back on the events that led up to the situation with the remote.

I had my 3 zones grouped, Windows 7 PC bedroom zone, Elac Discovery Z3 kitchen zone, Nuc HDMI to receiver living room zone, playing the Holiday Genres.

My daughter in law was interested in the new IPAD 12.9 and how it worked without the home button.

I was demonstrating the remote interface on the Ipad in Portrait orientation at the time. She picked a selection from “New Releases For You” and “Play Now” and was amazed with how easy it was and how quickly the selection started playing.

We went to the Bedroom PC zone so she could hear the selection made from the IPAD remote in the living room being playing there. The Roon remote window was displayed on the PC monitor. When I clicked on it with the mouse to enlarge the screen the music stopped and would not continue.

Went back to the IPAD and tried to continue but it would not. I ungrouped the zones from the IPAD and got the living room zone going again. I believe that was the point I first noticed it was not possible to go backwards from the queue screen on the ipad to the Overview screen. I had to select Overview from the menu to get there.

I did not intend to transfer remote control from IPAD to PC but I guess that could have happened when I used the mouse to enlarged the screen.

I will try that sequence of events again later this week to see if I can recreate the issue.

Hi @Mike_Lacey,

Thanks for providing the additional information. If you are able to re-create the steps reliably, please do let us know.

I don’t believe that the two are connected to this issue, the iPad should have it’s own set of controls and the Core as well.

If you do get into this state again, please note the exact local time + date when you observe it occur and let us know so that we can enable diagnostics for the iPad. Please do not re-install the app next time you are in this state as reinstalling the app clears out logging information.

Thanks!

Hello Noris, Happy New Year to the Roon Team.

I will do as advised if I can recreate the issue and leave the IPAD as is.

One additional bit of information that I recalled. I did have the zones grouped on the PC remote and paused from a previous session. Don’t know if that had anything to do with the issue but is part of the setup for the test scenario.

Hi @Mike_Lacey,

Thanks for the additional information, this will be helpful if you are able to reproduce this behavior. The key piece of info here is to see if this issue is reproducible, if this was a once-off issue and the iPad got into a weird state it wouldn’t provide the most useful info, but if it is reproducible each time with a specific set of steps that would make a great report for QA to look into. Do let me know how it goes and Happy New Yer to you as well, thanks!

Hello, The IPAD PRO 12.9 is back in the weird condition on the queue page with no backup button. Date 01/07/2020 time should be between 1 pm and 1:30 pm.

I had music playing, the Ipad remote was on the queue page. Next time I looked at it most of the screen was blank except for the progress bar area at the bottom. Selected the queue option at the bottom and the queue screen came back up but the back arrow was not available.

Hi @Mike_Lacey,

Thanks for letting me know that timestamp. I have activated diagnostics mode and what this action does is automatically upload a log set to our servers for analysis.

I can confirm that the Core report has arrived but the iPad has not yet, when you next have a chance can you please open Roon on your iPad so this is delivered as well?

Just to confirm - when this issue occurred, only the back button was missing? The rest of the top bar was visible including menu/forward/bookmarks/search?

If you by any chance get into this same state, could you share a screenshot so that I can attach this to the ticket as well?

Thanks!

Roon remote was up on the ipad but the screen had timed out. It is back on now.

I should have thought to take a photo of the screen. I will do that next time it occurs. Did the IPAD logs come across?

Hi @Mike_Lacey,

iPad logs have been delivered and attached to case notes :+1: . If you are able to get back into this state please do provide a screenshot. If you can also confirm this aspect, it would be useful:

On next occurrence I will take screen shots with my phone.

When I first noticed the issue I believe the screen was blank except for something in the upper left corner (not sure what it was) and the bottom area progress bar. I pressed queue and the screen came back on. Menu was there and the back button was not. Sorry I don’t recall if forward/bookmark/search was there. I catch that next time.

1 Like

Do you have everything you need from the IPAD so I can delete the remote app now and reinstall for next time?

Hi @Mike_Lacey,

Yes, diagnostics have been received, you can go ahead and reinstall the iPad app. If you see the behavior occur again, please provide a screenshot.

You can even take the screenshot from the iPad itself using screen capture (home + volume up button or power + volume up depending on the model).

Ok. Does your diagnostic mode give you access to the screen shots on the IPAD or will I need to add them to the ticket? I don’t use the IPAD for anything but Roon and don’t know how to use any of its features. If I have to add the photos to the ticket I’ll use my Note 9 phone. Thanks.

Hi @Mike_Lacey,

No screenshots are uploaded via our diagnostics system, just the text logs of what happened. If you prefer to create the screenshot via your phone, that’s fine as well. Creating a screenshot is pretty easy with an iPad though.

Hi @Mike_Lacey,

I spoke to QA regarding diagnostics and they have noted that there is unfortunately not much information listed in logs surrounding this behavior. What would really help here is a screen recording/video of the issue next time this occurs.

I know you mentioned that it occurs sporadically, but if you are able to capture the exact behavior, it would be very helpful in debugging this behavior. As a note, you can use the iPad’s screen recording feature to create a video:

Thanks Noris, I’ve been waiting for the issue to happen again and will try and capture photo/video documentation.

I’m curious if this is an issue with my new IPAD since I’ve not heard or read about anyone else experiencing this issue.

Happened again between 2 and 3 PM Jan 14. Today. Sorry for the photos, happened shortly after I responded to you last post. Need to test the screen recording feature you posted before the next occurrence.

First photo is Blurry. Had some music playing with queue screen displayed. Screen timed out. When I entered my PSW to get the screen back this is what I found, same as last 2 times it happened.

The queue screen is blank, top bar has the Menu button, Bookmark and Search buttons, no directional buttons. Progress bar across the bottom. No forward or back buttons.,

Pressed queue and the screen returned but without the forward and back buttons. At this point I’m stuck on the queue screen with nowhere to go. Have to use Menu to get back to the Overview screen.

This is the third occurrence, has only happened when I leave the display on the queue screen.