Is adding to Library from Watched Folders Automatic?

I have Roon Server running on a Win10 PC along with Roon Client (also a 2nd Client running on iPad). I have two watched folders, and I am ripping CD’s as FLAC to one of the Watched Folders but they are not automatically added to the library - no matter how long I wait. When I do a ‘Force Refresh’ the new files are immediately added.

Is this correct behavior? It’s not how I read the FAQ’s.

No. The Watched Folders should be updating in real time and you should be seeing a spinning icon to the top right while analysis is occurring. Are you seeing that icon at all ?

Can you provide some further system details which will help the support devs understand where issues might arise.

Are your Watched Folders on the same machine as Roon ? If not please provide details of the network and device where they are located.

In Settings/Setup there is an option for “Audio analysis speed”. What setting do you have there ? If it is normal, try fast. Is there some text showing how many tracks have been analysed ? What does it say ?

Let’s drop some flags for @mike and @vova to investigate further, but answers to the above questions will give them a flying start.

I don’t think this is correct behavior, but it is often ‘normal’ behavior. fwiw, I’ve found that exiting & re-starting Roon is a more reliable method than ‘Force Rescan’ to make new files show up. Often I will have downloaded multiple live gigs from Dime – as I process them into the proper folders etc Roon will usually ‘see’ the 1st 2 or so – the rest I usually have to exit/re-invoke to get Roon to acknowledge their existence. This is conceptually identical to you ripping multiple CDs at one sitting. I believe Roon is working on this for the forthcoming 1.2 release, but I might be wrong.

Also (fyi) the ‘Audio analysis speed’ mentioned by @andybob has nothing to do with making the new files appear – can’t analyze something that’s not there…

@andybob to answer your questions

  1. the only time I see the spinning icon is when I perform a “forced refresh”
  2. the Watched Folders are on Synology NAS,
  3. I am running build 99, 64-bit (but also occurred in previous build)
  4. I have the “Audio Analysis Speed” set at Normal, currently it is analyzing some tracks - but I have had to force a refresh even when there are no tracks analyzing.

Let me know f you need more information.

Thanks krjtx,

There are some known issues with real time watched folders on Synology NAS. I’ll leave it for @mike or @vova to let you know whether they’ve been able to reproduce them. Once a bug can be reproduced it generally gets squashed very quickly. If some redesign is required it can take a bit longer.

Yes, we’ve done a lot of testing and unfortunately it’s become clear that despite claiming otherwise, most NAS drives don’t implement file system notifications reliably. If you set up a linux machine and a samba share this works, but unfortunately even the major NAS manufacturers we’ve tested (Synology and QNAP) don’t seem to behave the way we’d like.

We’re working on a new strategy for our upcoming 1.2 release that will hopefully resolve this issue completely. I’m not going to say a lot more until we actually see it working, but know that we’re aware of this issue and don’t intend to leave everyone restarting Roon or digging for Force Rescan a lot longer. Appreciate everyone’s patience on this.

thanks all - appreciate the feedback.

Hello, just want to share my experience on this topic.
I use a QNAP TS-251+ with 8Go Ram. I run a Fedora 23 Virtual MAchine on it and this VM embedd the Roon server latest version.
The music folders are on the NAS and are reachable through a mounted directory in Fedora 23 (/mnt).
So the watched folders are mounted in Fedora23.

As of now the “watched folders” does not work if i’m not forcing the refresh.

Hope it could be fixed in the future.


Hello, I am wondering if the problem has already been fixed.
I am running Roon on a Synology NAS (916+; 8gb Ram) Everything is working quite well except the scanning in real time process. Almost everytime when I add music to my library I have to force a rescan of the monitored folder. Sometimes however, I’d say in 10% of the cases, the album is detected automatically but only 3 or 4 tracks are imported properly and the rest is missing. So I have to do force the rescan again.

Would be glad if there is a way how to fix that.

x2: previously I had a Roon core running on a Windows 7 PC and scanning in real time worked just fine. After switching to a Linux based system (Pink Faun Audio Streamer) as a core and endpoint the real time process stopped adding new music. Only a rescan works.
My music is stored on a Netgear ReadyNAS 424 using Ethernet throughout, in between are 2 unmanaged switches.

Would appreciate some feedback on this issue.

Hey @Semaxx @Gabriel @Patatorz – as a general rule, Windows picks up changes more reliably than Linux or Mac, but all of this really comes down to the NAS consistently reporting changes back to the machine running the Core. For the most part, we’ve found that most NAS drives do not do this reliably, particularly when the changes don’t involve creating or modifying folders.

We’ve recently added the option to customize how often Roon manually rescans your NAS for changes, which is a workaround, of course.

While this is really a limitation of the platforms involved, we do have some more long term ideas about how we can make this more consistent, but I don’t have any timeframe to offer here, for now.

Some more information in these threads:

@andybob, @mike, @danny, @brian -

Sorry, but that’s Roon’s problem not the NAS manufacturers.

Believe me, it kills me to say this, but JShiver has no problem automagically updating its libraries.

I ran a series of tests with 12 CDs and posted the results here, but I think I accidentally deleted that post.

I can recall what the results were for those in @support who might care.

This is an ongoing Roon problem.

The last time we did research on this we found otherwise, but it’s possible they’ve changed something.

As Brian mentioned at the time:

Which platforms and NAS’s have you tested with @xxx?

About a month ago, I accidentally delete a long detailed post that I, at your request, did some experimenting with in this regard. I can recall the results of that post, but since I wrote down some observations as they happened the original post would be better.

If I delete a post is it gone forever or can you recover it? It was addressed to you. Let me know. If you can find it, the original would be better…

My experiments show otherwise.

BTW - in the 2 or 3 years I used JShiver, it has never had problems picking up updated files from the NAS.

I found it.

Some of this is interesting, but I wonder if some of this is just a rescan bug we fixed in October.

From the release notes:

@mike - Thanks for your efforts to find my OP. I wasn’t looking forward to paraphrasing it. I thought I had dealt with you, but I see now it was Ben. When, a couple of weeks ago, I asked you for a response to my OP, you seemed to have had no knowledge of it. Of course, as you couldn’t have. :grin:

I didn’t remember Ben’s reply. Really, there wasn’t much there; other than stating that previously he thought that this was only a macOS problem. Since this happened under WIN10, that’s not the case. It’s been stated in other posts that this is a non-SMB sharing problem with Linux/macOS, but I had it happen under WIN10.

I guess that it’s possible that all my efforts only concerned a bug Roon techs had already known about, but I don’t think that explains the sequence of errors spread out over the 12 CDs.

It seems like there is still something else. Why do some CDs, in no particular ripping/moving order show up in their entirety? Why do a couple of CDs, again in no particular order, not show up at all. Why do most CDs have only their 1st track captured? It seems like if Roon was aware of a least 1 new track, then effort could be put in to discover accompanying tracks.

Yes, it’s been obvious to me that JShiver rescans on preset timer. You seem to imply that Roon scans on a default of 4 hours, but I left things as they were for 12 hours. No scan occurred. Yes, that probably is your rescan bug, but in the months that I’ve been using Roon it’s never successfully rescanned on its own volition, IIRC.

In the months I’ve been on this forum I’ve noticed that 3 themes occur over and over.

  1. The incessant whining about the price of Roon and the accompanying adolescent cajoling of the Roon principals to give people a ‘better deal’.
  2. The ongoing battle between the objectivists and the subjectivists concerning the value of ‘audiophile’ cabling and expensive, boutique endpoints.
  3. The fact that Roon does not, in many opportunities, succesfully automatically update it’s library.

The first two are probably unavoidable, but maybe Roon should stop giving the impression that its library is automatically updated.

It seems like you are saying that were I to repeat my test today, all the CDs would be correctly and completely and automatically updated in Roon’s library. Is this true?

Since I discoverd TIDAL, I don’t care as much and, in truth, having to manually rescan my small library never was anything but a minor annoyance over a promise not kept. Now, except for CDs I have to buy to satisfy a nostalgia for the music of my youth or classical music in boxed sets, I get my music from TIDAL.

It occurs to me that a fourth theme on this forum might be related to Roon interval rescans. People sometimes post about getting mesages to the effect that ‘a music file is loading slowly’. Do you think that, on maginally capable machines, this might coincide with the 4 hour interval scan. I know that since I moved my Roon server off of an inadequate i5 Mini and onto a Xeon machine, I no longer get that message, even with 4 endpoints playing in a zone.

IMHO, Roon still has a problem concerning library updates.


Just an observation from me… I don’t have a NAS, so I’ve never been bitten by this issue. Up until now, my library (stored initially on Windows 10, and now on ROCK) has always been updated automatically.

However, I noticed that with the Fall Creators Update of Windows 10, one of my Windows 10 PCs started consistently failing to see other PCs and devices on my home network. It seems that Microsoft turn off SMB 1.0 client capability after 15 days of running the FCU, and this seemed to cause the issue. I know that they’ve done this with the best of intentions (security), but it does seem to have broken the user experience.

Thanks. Definitely something to remember as I never turn off my server machine, but this problem predates even the FCUs.

@mike is there a way to improve the reporting back on the NAS side? In my case a Netgear ReadyNAS 424. I know it’s not your hardware, but maybe you came across something along these lines.

There’s probably not a whole lot you can do on the NAS side – anecdotally we’ve heard from some people that using SMB2 helps, but we haven’t seen anything that makes this as consistent as we’d like.

We released the configurable re-scan timer a few months back, so you can have Roon scan for changes more (or less) often if you’d like.

I run two Cores at home, and while my Windows Core pulls from the NAS, my ROCK machine has a USB hard drive connected, and both work pretty well.

As I mentioned, these limitations are frustrating for us, and we would love to see an app that does better than us across all the platforms we support – that would mean it’s possible :wink: For now, I’ll just reiterate that we are actively discussing some ways we could make this better in the future.

1 Like