Issue with Roon + Qobuz + NUC

Hello - I have the exact same problem described in this thread.

Roon + Qobuz work well when node runs on my PC
Roon + Qobuz do not work when node runs on a new NUC.
when selecting a track, Roon endpoint software plays 1 or 2 seconds of the track, then jumps to the next track and does the same until the end of the playlist.

I attempted Test 1 described above (NUC is used as core, and I try to play track on my PC’s output … same behavior as described above.

When running ROON core on my PC, everything works well and track plays correctly on PC’s audio output.

Please advise - thanks,


I would raise this as a separate thread.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hello @Hector_G, do you have any issues playing local content?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Hello @Hector_G, you can download some local content here for the test.

Hello - Thanks for the link. I installed an internal SSD in the NUC ROCK today and loaded some music on the Internal Storage folder. It all works well, plays flawlessly from my Roon Library.
Once again , the problem only occurs when playing QOBUZ using the NUC ROCK as core. The problem is intermittent - tracks cant load, and jump to the next track.
Problem disappears when running the Roon core on a Windows PC, or improves for some time after rebooting the NUC.
Please advise on how could I troubleshoot this problem. It seems several other users have described the same problem. Thanks.

Hello @Hector_G, and thanks for testing that! Could you please reproduce the issue one more time with the NUC and reply here with a timestamp of when you do? I’d like to enable diagnostics for your account and take a look.

Hello - Could you send me instructions of how to run the test ? I can easily recreate the fault, but how do I create a time stamp or log file.?
Thanks - Hector

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i7BEH , RoonOS, Latest stable build downloaded from ROON
8 GB RAM, 256 GB M.2 SSD

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

AT&T BGW210 main router.
NUC ROCK Roon core: directly connected to router by Cat8 ethernet cable.
(new unit, latest BIOS update, Roon OS Version 1.0 (build 219) stable

Audio Devices (Specify what device you’re using and its connection.)

Cambridge Audio 851N Network streamer (connected via WiFi to router)
iPad Pro used as Roon remote, connected via WiFi to router
Dell PC (as test output device) (connected via WiFi to router)

Description Of Issue

Roon + Qobuz work well when core runs on Windows 10 PC.
Roon + Qobuz do not work when core runs on the new NUC ROCK.
Symptoms: With NUC as core: when selecting a track, Roon plays 1 or 2 seconds of the track, then jumps to the next track and keeps jumping from track to track until the end of the playlist.

When running ROON core on Windows 10 PC, Qobuz works well and track plays correctly on PC’s audio output. Qobuz works well by its own app, at all resolutions.

Many users have reported this problem - but no solutions. Network speed gets blamed. But the problem only appears when running the ROON core on the NUC. Run the core on a PC and all works fine.

After many days of reading and dealing with this, I’ve got some esoteric suggestions such as “change the router to Google DNS” and “Set the router to media prioritization for ROCK” but no further instructions on how to do this.

I’m down to installing Windows 10 on the new NUC. Which makes no sense: the whole point of purchasing the NUC was to have a dedicated, high quality ROON server.

This is an absurd problem for ROCK. Qobuz is one of the most important high resolution services. Why cant it work with ROCK ?
Someone in Roon seriously needs to work on this problem and find a stable solution. Thanks.

I’m running a NUC8I3BEH and some days play Qobuz via Roon all day long without any issues, so I would not say it’s all NUCs,

As you mentioned use Google DNS, check your quality setting, perhaps turn it down a notch, but I use the highest setting possible.

One problem I did have is my main PC is up 24x7 and it would receive some notification, chirp out a little bell and steel the focus away from Roon, it took me a while to put 2 and 2 together to find this, so now I’ve isolated my PC from my stereo and haven’t had much trouble at all.

Other issues I’ve seen, is sometimes when starting a song via JRiver, it pops up a box stating it’s spinning up drives, if I get a similar network/NAS delay with Roon, I can get those dropouts, so I moved my music internally into my NUC, and that issue appears to have quieted down.

I’ve also had issues with the Qobuz App itself, stopping play and stating something about the song is not available, I found it was related to Imported songs, so I deleted all local music in Qobuz. So now I don’t use the Qobuz interface anymore and don’t Fav or Import from Qobuz. And from within Roon I also don’t do anything with Qobuz music such as Fav or Import,I just listen, and when I find something I like I either add it to a playlist or Add to my Library, then I play it from the Roon section, Album fiefs, and in there I Fav or Star them, in other words I stay away from Roons Qobuz screens.

I realise that it’s no comfort, but for the vast majority of us (me included), Qobuz works perfectly with ROCK. There’s some sort of environmental issue - likely network-related - going on, and this is clearly difficult to solve at a distance. I can understand your eagerness to adopt the workaround of installing Windows 10 so that you can listen to your music, but that is not going to let @support help you get to the bottom of what is going wrong in your setup.

Rock user here, No issues here unless it happens Roon server side.

Can you run successfully Qobuz on your ROCK NUC with no issues at all ?
What do you mean “unless it happens Roon server side” ? Do you need to restart the roon server in ROCK sometimes ? Thanks

The ROCK platform is dead solid; two years with only one restart here!

Have you tried swapping out a different cable from ROCK to router, perhaps a Cat5?

1 Like

I have submitted a detailed report to @support two weeks ago. Got two short replies asking simple questions , then the trail died. Have not heard from Roon support again.
I understand that Roon is a greatly complex product and that it has millions of users. At the end of the day, we are mostly on our own.
The problem needs to be solved at the product level, in this case the RoonOS running on ROCK. If you look this problem up in the support blog, there are many many people with the same Qobuz problem with ROCK, and no clear solution has been identified yet.
Roon is a fantastic product and I hope that this will be identified and solved … one day.

very same NUC (in a Cirrus7 fanless case), Roon ROCK OS, Qobuz Studio streaming (+ local files on a NAS) and… no issue at all since when I bought it one year ago
oh… CloudFlare DNSs here. seriously: give these (or Google’s) a try :wink:

Two questions:

  • are you running ROCK on your NUC ?
  • did you have to change your router to Google DNS to get Qobuz to work properly with ROCK ?
    Lowering the quality setting is completely unacceptable. The whole point of paying for Qobuz is to have access to high resolution music. Plus, Qobuz works perfectly with Roon at all resolution settings when the core runs on a Windows PC. The issue here is that Qobuz + Roon doesnt work for many users when running ROCK on a NUC. It seems it would work if I install Windows 10 on the NUC, but that defeats the purpose of having purchased the NUC in the first place.

I’ve tried several cables, CAT7, CAT6, different port in the router … it made no difference.
Have you changed your router DNS to Google DNS to make Qobuz work with ROCK ?

Paolo: Is your end point directly connected to your router (via ethernet cable), or is it connected via WiFi ?
Did you change the router to CloudFlare DNS specifically to make Qobuz work with ROCK, or did you have other reasons ?
Thanks, Hector

not either @geoB or @John_V but… yes: I did!
and that was already the case when running Roon on a dedicated Mac Mini, long before moving to a NUC/ROCK :wink:

Thanks - I’ll try switching DNS server on my router and will report the results …
Have you tried both Google DNS and CouldFlare DNS ? Any preferences ?