Issues with SOtM SMS200 since Build 234 [Resolved - Firmware update]

Hi - First post…

This is the second time this has happened but can’t remember how the heck I “fixed” it last time!

I have as my core a Mac Powerbook running OSX 10.12.4 Sierra. My endpoint is the SOtM SMS200 into a Rega DAC-R. I’m only using Tidal hi-fi for music. Everything is working great when all of the sudden the music stops. The SMS200 is no longer shown in AUDIO >Networked. I’m unable to add it (again) since it seems it can’t be discovered. I’ve tried to reset Roon in the SotM software, Eunhasu and then quitting roon. Followed by starting roon - without results.

In these crash situations, Roon is still able to run the internal speakers on my Mac. This is the only other zone I have set up besides the SOtM.

Thanks for your help! -Kurt

Hi @Kurt_Lantz ---- Thank you for the report and sharing your feedback with us, both are appreciated!

Moving forward, I would like to gather the following information from you as well as have you perform a very simple test for me. Please see below.

  1. During your troubleshooting of this issue, have you tried power cycling ALL of your equipment? I see that you have rest Roon in the SOTM software :thumbsup: but am curious how things hold up if you reboot your core and any networking hardware. This would include your router, switches, etc.

  2. Can you please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a clear understanding of how your device are communicating across your network and what tools you are using to make those connections possible.

  3. As a small test, may I kindly ask you to please access the same directory in which your Roon database can be found. With the application not running please locate your RAATServer folder in the directory mentioned and rename it to ‘RAATServer_Old’. Once re-named, launch Roon again and confirm how things hold up.


Hi Eric -

  1. Yesterday I cycled my equipment: shutting down my mac along with modem, router and SOtM. I rebooted all in this order: modem, router, SOtM, Mac and Roon.

  2. Don’t know what you mean by describing my networking config/topo. Let me know how I can find this information out and relate it to you. My hardware, besides the Macbook Pro and SOtM SMS-200 are: Modem: Motorola surfboard SB6120. Router: TP-Link AC1200.

  3. I tried renaming the RAAT server as per your directions after I quit Roon: RAATServer_Old
    After doing this and restarting I received the message at the bottom of the Roon screen “No Audio Devices Found” along with the button: Manage Audio Devices.


Hi @Kurt_Lantz ---- Thank you for the follow up and providing the requested feedback.

In regard to the test, the idea was to see if using a fresh RAATServer folder would hold on to the SOTM SMS200 zone (almost the same idea as starting with a fresh DB). When performing this procedure I would expect you to have to re-enable those zones along with their settings. Are you not seeing any of your devices listed in the audio tab?


Correct. The SMS-200 doesn’t appear in Audio > Networked. Clicking on Add Network Device only gives me the option to add HQPlayer

I just tried rebooting everything again too, just for good measure.

Hi @Kurt_Lantz ----- Thank you for confirming that for me. Here is what I would like to do moving forward.

  1. With Roon not running - Please delete the current RAATServer that is in place and re-name the original one (currently = RAATServer_Old) back to “RAATServer”.

  2. Log gathering:

  • Very important - Please replicate the issue being reported and note the time that the observation is made.

Everything is working great when all of the sudden the music stops. The SMS200 is no longer shown in AUDIO >Networked. I’m unable to add it (again) since it seems it can’t be discovered. I’ve tried to reset Roon in the SotM software, Eunhasu and then quitting roon. Followed by starting roon - without results.

  • Once the issue has been replicated and the SMS200 can now be reached from Roon, please follow the instructions found here, and send us over not only a copy of your Roon logs but also your RAATServer logs.


Hi Eric -

I’ve carried out all of your instructions. The SMS200 cannot be reached from Roon. I’ve zipped both the RAAT and Roon. The issue occurred at 6:45pm


I am having a similar problem with a SoTM SMS-200. After the latest software upgrade to my Roon Core running on a SonicTransporter i5, the sMS-200 has disappeared from Roon. I can log into the SoTM, manage the config via the GUI, etc. I have rebooted and power cycled both the SonicTransporter and the SoTM. I have multiple other RoonReady devices on my network including 2 microRendu, an exaSound PlayPoint, and a dCS Upsampler and they all work fine. It is just the SoTM that has completely lost visibility to Roon.

After looked through some other posts and finding that the SoTM can disappear from Roon if it isn’t connected via USB to a DAC and the DAC is on, I double-checked my set-up and discovered that was the case with mine. I was playing around with a new LPS for my Uptone regen and apparently while it has the right V it doesn’t produce enough A, so the Regen wasn’t powered up. The Regen power light is hidden on my installation, so I didn’t notice until I checked. All is fine now.

1 Like

Hi @Kurt_Lantz ---- Thank you for the follow up and my apologies for the slow response.

Confirming that I have received your logs and and that they are in our queue to be evaluated. In the meantime, I would like to see how another network based endpoint behaves. Is it possible for you to load either Roon (as a remote) on another device OR Roon bridge? For this scenario to work either of these option must be loaded on to a laptop/desktop computer. The idea is to see if those devices remain stable.

Looking forward to your feedback!

I had been enjoying a 2 month trial - working perfectly with the sms-200. Trial period ran out so I registered yesterday. In the process I received a message that an update was available so I updated. Since the update Roon will not work with the sms-200. A song will play for a few seconds then stop and skip on to the next song in the queue or stay on the same song and skip constantly.

Taking the sms-200 out and swapping in a Squeezebox Touch cures the problem, Also, the sms-200 works perfectly when running LMS instead of Roon.

Any help would be appreciated.

I have the same problem with my MicroRendu. I did a clean install of Roon and it works fine again but only with the older build. After updating to 234 the problems occur again. Are you using Win10 (and maybe in “bridged mode”)?

interesting, thanks. I am using OS X in bridged mode.

Hi all,

We’ve heard of a few issues with this device since Build 234 went live, so I’ve most all the posts into one thread so we can gather info in one place. There were some RAAT streaming optimizations in our most recent release that were rigorously tested and have been widely stable, but we’ll be investigating this and following up with SOtM to see if we can get a handle on what’s going on here.

If you haven’t already, can you all please let us know the full details of your setup, as described here. In particular, it would be helpful to know the details of your network, and the networking settings of all the devices involved. The more details we have, the more likely it is that we can reproduce this issue in house and make some progress here.

I noticed that two people have mentioned “bridged mode” so that may be a clue – any relevant details about exactly how you have that set up would be helpful as well.

Thanks in advance for your help, and your patience guys.

@SEAN_MCTIGUE @yellowblue @Kurt_Lantz @ksalno

Hi Mike,

Thanks for the follow-up. My problem turned out to be an anomaly with the SOtM where even if it is connected and powered up, it will not respond if the USB connection to the DAC is not working for any reason (unplugged, not selected input). Nothing to do with Roon, just my learning curve.


Sir I have tried to establish connections with my Sotm SMS200 the unit has been in the system for several months now and suddenly I have lost the connection and it does not showup on my list of Zones.
I have also lost the remote connection t my tablet, I have a screen shot showing the Sotm sms200 is connectd to the system as it is identified on the Eunhasu music player but this will not give it to Roon and also cannot use the system as it is controoled by my tablet in the other room from the server.

Hi @David_LAw ---- Thank you for the PM. I went ahead and moved your support question out to this thread were we are addressing this behavior you’re reporting.

Moving forward, may I kindly ask you to review @mike’s post from above and supply the requested information.


Hi Eric -

I’m away until next weekend. When I get back; I don’t have another device available but could I use my core (Mac Powerbook described above) as the endpoint as well? Let me know if that would be helpful.

I’ll keep my eyes on this thread to see if another solution is discovered in the meantime.

Hi @Kurt_Lantz ---- Thank you for the follow up and proposing an alternative test. Very appreciated!

Unfortunately, this test will not work for what I am looking for in terms of testing a network endpoint. Your logs are still with my tech team so hopefully they would be able to provide some insight once their analysis has been completed.


How can this all be ok and then Build 234 comes along and no Sms200 Connectivity this is crazy we are paying for a service and not being able to play my music because of your build is madness.
Please sort this out do not try to blame other manufacturers or connections if people have not changed their connections and the only difference is in the latest build then please revert to a build where I can listen to my music.
You see that’s what I pay for.

@David_LAw ---- I understand that these types of situations can be frustrating and just like you, we too wish that there was a quick, “turn this off and restart” type of explanation to this behavior, but unfortunately this is not the case.

As @mike has already mentioned, we are doing our best to understand the nature of this behavior and address it accordingly, as we have always done. When a situation like this appears we rely on the feedback provided by our users because without that, we are flying blind.

Moving forward, David, if you could please provide the information being requested in the post above it would be very helpful and appreciated!

Looking forward to your feedback!