Lagging when starting playback [800k track library]

My Roon core runs on Windows 10 and I’m experiencing the same problems as @Spence_Marquart.

I hope whatever fix is implemented also resolves the issue I’m having. The one where it takes 6-7 seconds before a song starts playing.

1 Like

Hi @Leonard_Co

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

How often do you see this occur? Does it happen for all endpoints? All types of content?

Is this consistent, or does it slow down over time? Does a reboot speed things up?

Hi @dylan, all the information you requested is here, and my last post in that thread is over a week old. I hope Roon @support prioritizes a solution.

1 Like

800,000 tracks! What an impressive collection you’ve got. That’s in the top 0.0001% of all Roon subscribers (and I’m probably missing a few 0s). :exploding_head:

Keeping that in mind, the behavior you’re describing sounds about right. You’re pushing Roon and your hardware to its limits and seeing a maximum of 6-7s loading time only in certain cases. It’s not ideal, but with a collection so large stored on NAS, it’s not a bad result either.

If I could suggest any improvement, it’s to remove the NAS from the equation and go for directly attached storage. Our CTO’s post below lists a number of advantages that come with directly attached storage.

I have been buying CDs since the early 90s, @kevin. And I’ve been ripping them to lossless ever since. When iPods became popular in the early 2000’s, friends and family would dump their collections of CDs with me and I would rip them one disc at a time. The same thing happened a few years ago when vinyl records became popular. And when HDTracks, HighResAudio, NativeDSD and other web shops started selling high-res albums, I would buy from them. That is how my library became so big.

Anyway, back to my issue which I hope you can help me with. I recently tried what you recommended. I bought four 10TB Western Digital RED hard drives and installed them in my computer. I used SATA cables that came with my new Asus Dark Hero motherboard and power cables from my new Corsair 850W power supply. Windows 10 had no problems recognizing the four drives and formatting them as NTFS. Then I alphabetically copied my entire library over from my NAS which took a little over 2 days at gigabit speeds. The first 10TB drive contained artists and bands whose names began with A to F. The second drive, G to K, so on and so forth. Then I disabled my NAS from Roon, powered it down, and let Roon scan the contents of the four new drives. Sadly I experienced the same issues during playback. There was no improvement whatsoever.

Here’s what would happen. Let’s say I begin from everything powered down. I switch on the computer running the Roon core and the rest of my hi-fi system, including the endpoints. Once everything is up and running, I’ll grab my iPad, run the Roon Remote app and tap on any song from any album. It will play instantly. If I choose another song within 30 seconds, it will play instantly too. As often as I like, I can choose any song from any album and it will play instantly as long as I do so within the first 30 seconds of the currently playing song.

HERE’S THE PROBLEM. If I let the current song play for more than 30 seconds and then choose any other song from any other album (even a song from the same album as the one that is playing), the song timeline will swing purple left to right 6 or 7 times before it plays. Let’s say the currently playing song is on its 31st second. If I tap on any other song from any other album or even the next song, the song timeline will swing purple left to right 6 or 7 times before it starts playing.

Then I discovered a shortcut. If I want to hear the very next song without the timeline swinging purple left to right 6 or 7 times, I simply drag the dot on the timeline to the rightmost end and the next song will play instantly. The song timeline remains flat and it will take 6-7 seconds for the “waveform” graph to show up but it will play instantly.

This happens even if I restart the Windows 10 computer running the Roon core.

To make sure the problem isn’t with my network, I decided to use UPnP/DLNA to play my songs. I have four Roon endpoints, a Sonore OpticalRendu connected via USB to a Sonore UltraDigital feeding an I2S input of a PS Audio Directstream DAC, the Network Bridge card inside the PS Audio Directstream DAC, a Sonore UltraRendu feeding the USB input of a Meitner MA3 DAC and the Network Bridge card inside the Meitner MA3 DAC. All of them support DLNA/UPnP. I have Minimserver installed in my computer and the mConnectHD app on my iPad. When I use mConnectHD to play music from Minimserver to any of the four endpoints, any song from any album plays instantly with no lag, no delay. At any point in the currently playing song’s timeline, I can select any other song from any other album and it plays instantly.

Since I also have Minimserver running on my Synology DS918+ NAS, I switched it on and waited for it to boot up. Then on the mConnectHD app, if I chose music from my NAS and any song from any album played instantly with no lag and no delay. At any point in the currently playing song’s timeline, I can select any other song from any other album and it playback starts the moment I tap on the song title. This exercise proves my home network works well and cannot be blamed for any issues I have with Roon.

Going back to why I think neither playback from a NAS nor playback from hard drives directly accessed by the Roon core is the problem - I cannot understand why Roon will instantly play any song from any album I have on either my NAS or my hard drives as long as choose the next song before the 30th second of the currently playing song. If I let whatever I’m listening to play for 31 seconds or more, the song timeline will swing purple left to right 6 or 7 times before the next song I choose starts to play. This, combined with the fact that storing my albums on hard drives the Roon Core can directly access is why I am convinced the fix lies within Roon.

I certainly hope Roon @support can help.


Thanks for the detailed reply Leonard, would you mind sending me a screen recording of the behavior? Both the shortcut you described and the delayed playback. It would be helpful for us to see it happen in real time, thanks!

@Leonard_Co and @kevin, I just have tried on my system, and I experience the same behavior Leonard is describing.

If I start to play a track (local or Tidal) and click within 30 seconds on another track, next track, previous track or another album altogether, reproduction of the newly selected music will start immediately. In the case of Tidal it may understandably take a second, but not more.

If, on the other hand, I wait until after 30 seconds of reproduction of a track and click then on the next or previous track or another album, it will take approx. 7 seconds to start. This does occur with both local and Tidal tracks.

My system: Roon Core on dedicated server with Intel Core i5 8600K processor, 16 Gb RAM, Toshiba NVMe SDD 256GB for OS and Roon, Ubuntu 20.04 server, 190.000 tracks, of which about 60.000 are on a local Toshiba 2 TB SATA SSD; the rest is Tidal. Core connected via Ethernet to Synology Router. Endpoint WiFi connected.

As I mainly listen to complete albums and very rarely click on a new track or new album during reproduction of an album, I don’t experience this behavior as annoying or interruptive. But I can see the point of those who do listen to tracks and are used to click from track to track. So this is simply to confirm the reported behavior and its easy reproducibility.


Ditto, this is another longstanding issue that’s been reported in the past.

Thanks for sharing, Philipp. Yes. I like to switch between tracks frequently. It took over 25 seconds tonight to switch to a track on a different album. So it’s a major issue and Roon should treat it as so. Especially when running very high end equipment but Roon runs too slow for that to make any difference. I sometimes think they don’t see this as a major issue. I disagree. It’s an incredibly frustrating experience and I wish I knew they were at least working on and not treating it like it’s some kind of “feature request”. It’s broken. @support

1 Like

Another good indicator of the lagging is in when Roon Radio plays. Between songs, it can take up to 10-15 seconds for the next track to play. Broken…

1 Like

@dylan @support Any update on this? It just took nearly 30 seconds for a song to start playing. This can not be ignored. It’s a broken program. Can you confirm you guys are looking into this?


@dylan @support @brian

Hey guys. Listening this morning the problem gets worse. Several minutes of lagging when I switch between tracks. Any update on Roon looking into the issue? Please update before the weekend.



I decided to post my own support request on this:

I think it is the same point. I even tried the experiment with changing a track before 30 seconds and it is the same as described above!

There is definitely some bug here. Roon, please focus on this!


Hey everyone,

Our team is looking into this and we are hoping that we can get some additional data points to help with this.

If you’re able to reproduce this, please do this a few times and note the time that you press skip and the name of the track you are skipping. Then, use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service).

I’ll get these logs and examples over to the team so they can analyze them.



I’ve been listening all night and the issues keep happening. I believe you guys have access to my logs. This has been persistent for months. Try to play any track after listening to a song over 30 seconds in and it takes a good 25 seconds for the track you select to start playing. I’m glad you say they’re looking into this. It’s been a known bug for a while.


Currently on Roon 1.8, Build 884 (64-bit). Still the exact same behavior as my (long) post here:

This topic was automatically closed after 21 hours. New replies are no longer allowed.