Lenovo remote freezing at launch

Core Machine (Operating system/System info/Roon build number)

1.7 build 521

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

I just logged into Roon was asked to upgrade.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Sonos Connect
My two remotes will not work. A Lenova tablet shows what is running on the Roon Core but the screen is frozen. My Samsung Galaxy running Android 10 won’t even connect to the Core.

In addition, I have TWICE run sync library with Qobuz and the albums do not sync.

How can I go back to the previous Roon version which was working fine???


Hi @richard_rubenstein,

Lenovo Tablet
Is it frozen as soon as you launch Roon? Are you able to use it at all? Any change if you reinstall or reboot?

Galaxy Phone
Does it see the Core machine at all? What happens when you try to connect? Are there any errors? Can you share a screenshot of what you see when you launch the app?

Qobuz Sync
Is it just specific albums that aren’t syncing? If you go to Settings > Services > Qobuz when does it show the last sync time was?

Room remote on the Lenova tablet is frozen as soon as it launches. It will not respond at all. All it does is show in the window at the bottom, what is playing on the Core.

The Galaxy phone does not see the Core at all. It says ‘Looking for you Roon Core’ and hangs.

Ok I synced again, foe the third time, and the albums now show up.

The Samsung Galaxy is now working.

When I run Roon on the Lenova tablet, it shows what is playing on, in this case, the Sonos Connect. But the screen is frozen. After a minute or so the Room Remote ends and goes back to the home screen on the tablet.

Thanks for the update, @richard_rubenstein.

The team is currently investigating the issue with the freezing remotes on Android devices and we have enabled diagnostics so we can take a closer look. I’ll be sure to update you as soon as more information is available.

I updated the software at my second location where I have two Samsung Galaxy Tab A 10" and two Samsung Galaxy Tab A 8" tablets. The two 10" worked fine. One of the 8" hangs as did the Lenovo. The two 8" tablets are identical, same model, purchased at the same time, same software but one works and one freezes as soon you run Roon.

I have been using Android on phones and tablets for years and have never had a program freeze. What would cause that? I’d really like to know. This is now a big issue for me. In the past when I’ve submitted issues, I have never had a resolution and now I need one.

Two other issues:

When I went from Roon location 1 (2-Galaxy Tab A 10", 2-Galaxy Tab A 8") to location 2 (Lenovo Tablet), I tried using my Android phone, which was working in Location 1, and it did not work. I restarted the phone and it worked.

At both locations, on the devices (Lenovo, Tab 8) that froze, when I ran the Roon Remote, on the screen was reflected what was running on the Core including album, artist, song and how far into the song the Core was (time). So the remote is communicating with the Core before it freezes.

Hi @richard_rubenstein,

I’ve posted an update about the current status of this here:

Thank you for the update!

2 posts were split to a new topic: Huawei Think Pad hanging on launch

Roon has determined that there is a problem with a certain GPU. They have recreated the problem and are working on a resolution.

A post was split to a new topic: Roon will not play on my Bluesound 2, my Sonos Connect or a Sonos Play:1


We’ve released a new update, Roon 1.7 Build 528, which contains improvements that we believe will help with the issues you are experiencing here. Please see our release notes below:

The Team At Roon Labs

Samsung Tab 8 working. Lenovo is also working.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.