Lenovo Yoga Stuck in portrait

Have tried to reply to your PM but it bounced. The data has been sent back to you.

Re the other information you requested:

Roon 1.2 build 142

Android 5.1.1 (the roon server is on a macmini OSX 10.11.5)

Lenovo YT3-X50F, 10.1 inch screen, Qualcomm processor, Android 5.1.1, 1gig RAM, 16gig storage

Cheers, Geoff

Geoff, reply to a PM within the forum; not via a reply to the email notification you may have received.
Access via the top right corner of the screen.

1 Like

While waiting to here back from Vova it occurred to me to ask if it’s possible to go back to Roon 1.1 and see if that makes a difference… Is this possible?

Thanks @Geoffrey_Binder,

We received your logs, they are being analysed.

If you want to reimport, sure. The Roon databases are not forwards compatible, so 1.1 will not do well with 1.2 databases.

I’ve looked at your logs, and the problem is indeed DPI reporting – it’s causing your tablet to be classified as a phone. I’m trying to think of a solution that will fix your issue, while not negatively affecting thousands of phones out there.

On Windows machines with high DPI display you can launch the app with the scalefactor command. I use it on a laptop with a 2560x1440 display to work around the “fullscreen” issue.

Is there something similar in Android that could be used as a workaround?

Thanks Danny, Sounds like a hassle as I’ve got Roon on 2 PC’s as well.

Is it worth trying to revert to an earlier version of Android? (I’ve got the tablet booked in to go back to Lenovo today)

not as far as I know

Hi @danny , any luck?

Hi @danny, I thought I post an update of my frustration trying to get this sorted. Lenovo, speak to Android (Google).

Google, speak to Lenovo.

Neither can assist with rolling Android back to 5.1.

Any luck at your end?

Cheers, Geoff

Hi - Has there been any progress on this issue? I have just purchased a Lenovo Yoga 3 10.1 for Roon use and have the same problem.

I have made progress on this. The follwing link gives instructions for changing the android dpi without rooting the device.

How to change DPI in an android device

I am messing around with the DPI. 140 works but I’ll keep going until I find the cutoff point.

Cheers
Tom

2 Likes

cutoff point around 190 dpi

cheers
tom

:unamused: wished I’d found that out before upgrading the tablet…

What did you go for? It’s far from perfect as all apps have become less stable. I need to do some more testing!

Cheers
Tom

I stayed with the Lenovo yoga’s because I love the built in stand and the huge battery. I got the next model up - much higher spec’s and a built in projector! Very happy with it!

This works… set mine to 190 and it 's fine.
Thanks for that!

Ok, I got to the root of this… and it looks like the others got this right by messing with the DensityDPI setting.

The problem is that Android source code (I checked latest) has a mechanism of detecting phone mode, which is: smallest size * 160 / densitydpi – if that value is < 600, you are considered a phone, and Roon trusts the OS.

This device, being 10 inches diagonal and 1280x800, should have a DPI of ~150, as per https://www.sven.de/dpi/

The problem is it is reporting a densitydpi of 213 (TV). If they really wanted to stick to the Android steppings, it should be reporting 160 (MEDIUM).

If they did the right thing, Roon would want to run in tablet mode (landscape). But, because of this stupid setting, they are making your 1280x800 tablet feel much more like a 960x600 tablet :cry:

NOTE: I also speak to the technology in Android behind all this here:

https://community.roonlabs.com/t/where-is-alphabetical-navigation-in-android-client/13659/21

Hi
Do you know why lenovo would do this?

Cheers
Tom

A hardware team that area and a software team without a clue about product experience. Pretty much par for the course in the world of hardware manufacturers.

1 Like