Library disappearing one album at a time over and over again

Hello John,

Thanks for your reply. It seems Roon can not help us to solve this problem.

I do not use a 3rd party tool like Bliss, but I use an iMac as my core.

Hello guys, thanks for the report and apologize for inconveniences. We are still working on this issue in attempt to find reliable reproduction steps.
We were able to reproduce this issue several times in our QA environment but with unrealistic circumstances - 99% loss of network data. This is apparently not your case, because even with loss of albums you are still able to interact with the Roon Core using the Remote app.
At this point I would like to ask you several questions, which can help us in the investigation:

@Arno_Veldhoven would you mind to tell us more about your setup ?
@John_Hunt, did you have a chance to try a direct wired connection between your NAS and machine were Roon core is installed ?

Thanks in advance.

My setup is as following:

I play with a Meridian MC200 - iMac - QNap TS879 pro. As a remote I use an iPad pro.
My Amp is a Devialet 250, and my speakers are Revel Ultimate Salon2.

My network is with cables, I use Audioquest network cables. I have about 7000 albums in Flac and DSD in the library.

You can understand why I am so annoyed when my database will count down everytime.

Would you mind to describe your network setup in details?
How often is it happening ? Can you reproduce this at will?

My network setup is really simple, my qnap has a shared drive called FLAC and ISO.

In Roon I have setup two connects:

smb://AV001/FLAC and smb://AV001/ISO

It is connected over ethernet, through DHCP and a manual IP adres, my iMac has 192.168.19, my router has, over subnet

@vova, yep I hardwired as instructed. Issue continued to crop up. Hope you are able to quash this bug. It is really extremely irritating. Roon is once again re adding the library after counting down to zero as I write this reply.

Any news on this problem ???

@vova, seconding Arno on this. Literally watching Roon reimport my collection again as I type this. I’m really not sure what else to do. I’m about at my wits end with this issue. It really does render an amazing product basically useless, as i never know from one use to the next when my collection will be there and when it won’t. With 10,000 albums the reindex process is slow at best. I keep hoping each release will have fixed it, but no dice. I’m really hoping you have something up your sleeves.

1 Like

I’m seeing this happen today :confused:

I have 94k+ files stored on a directly-attached Firewire drive. I noticed earlier today that tracks were “disappearing” from the database (couldn’t find them via search or anything). Took a look at the storage tab and instead of 94k+ tracks, only 40k (or so) were showing!

I removed the folder from the configuration altogether, figuring something had gotten corrupted and I’d let it rescan. It “sees” all 94k+ files, but now won’t add any of them to the library! Watching it count down smaller and smaller numbers of tracks, adding none to the library :frowning:

So what’s going on!?

To my surprise the database seems to be stabile now. An error didn’t occur anymore. The only thing I changed was setting in my network.

Hopefully it stays this way.

Which setting in your network?

I changed smb://AV001._smb._tcp.local/FLAC to smb://AV001/FLAC

After that the problem didn’t happen anymore.

How does your link from roon to the nas looks like ??

A post was merged into an existing topic: Roon on macOS (OS X) not working with large library (70k albums)

This behavior continues to plauge me. I’ve seen others continue to mention the same problem. Has anybody found an actual solution? I’ve tried everything suggested to date? Thanks for any additional help or suggestions.

Hi John,
I can see from the posting history this has been plaguing you for a very long time now.
I’m leaving a tag for @support and @Brian to follow this up with you.

1 Like

Hey @John_Hunt – we discussed this and I believe @Eric followed up via PM.

There are some known issues in this area, but your experience seems to be uniquely unstable, and it’s really unfortunate these issues have dragged on for so long. @Eric is going to work with you see if we can nail down what’s going on here, as we continue to address the issues mentioned in the post I linked above.

Thanks for your patience here @John_Hunt!

I have the same problems with a Qnap NAS T809 Pro. All the settings mentioned here I have tried but the problem persists. Now it’s a daily problem and some times more times a day. It seems to progress. It seems that the trigger is also a Network loss when Roon is running. Some times by accident my network cable is pulled out my laptop a little. Apple has no secure Rj45 connection in a laptop.

I have a MacBook pro connected with El Capitan 10.11.6. Latest Qnap Firmware on the NAS. And the latest Roon version.

I reported the problem on 8 February 2016 direct by Roon. They send me back to the community forum. But good not find a similar subject. Now I have I hope to see a solution for this problem.

I have some expirements planned. Connect to an other NAS (Synology) (my back-up). Connect to an USB HD directly to the MacBook.

I will report back my findings when these experiments are completed.

5 posts were split to a new topic: Library counts down when adding new content