Linux Roon Server and Auralic Aries; zone disappearing

Anyone else also having issue with Aries RAAT and Roon when Aries suddently stop playing and it disapears from Roon as available endpoint please?

Aries AirPlay being stable, no issues here. Also feeding Aries via OpenHome (UPnP) works fine, only the RAAT is not stable.

To fix the situation I always have to restart the Aries (via remote). It is happening fairly often, usually after few tracks or even more frequently…

I’m running Roon in Linux Docker container on Ubuntu 14.04, having latest Aries firmware.

Yes, exact same issue. Running Roon on Ubuntu 16.04. Aries just disappears.

Hey @Chris_Sauer @maniac – sorry for the slow response here.

Can you guys give us a little bit more information about your networks here? We’re not seeing this issue in house, so it may be that our configuration is different from yours.

If you’re still seeing this issue consistently, drop a PM to @vova and myself, and we’ll walk you through getting us some logs – it’s possible we’ll be able to get a better sense of what’s happening here by looking at the logs.

Thanks, and sorry again for the slow response!

Hi Mike,

In my case PC with RoonServer running in docker is connected via gigabit switch to airport extreme wifi to which Aries is hooked to.
Docker is using bridged network configuration - e.g. RoonServer is running in same ip range as Aries. The virtual interface of Docker is connected into bridge with lan interface of PC.

Maybe a bit complex, but from Roon perspective it should be usual setup.

What I noticed in the meantime that usually it helps when go into Audio Setup inside the Roon client application - it will detect Roon Ready Aries device.

Airplay streaming to Aries is available all the time, no such issues as with RAAT.

Also I believe it is not wifi problem (however i can try ethernet if it would help) as aries is able to stream double DSD files via OpenHome via the same wifi connection without any issues.

thx, Tomas

EDIT: sometimes I am also having small droppouts (<1sec) during playback to aries. This could be due to lower performance of PC where RoonServer is running (i am waiting for more powerful passive cooled HW) so i could understand the dropouts, but the disapearance of Aries RAAT is annoying :slight_smile:

I’ve stopped using the Aries for the time being - I’m pretty sure this is an Auralic problem. I’m having problems with the Aries when I’m not using Roon. And I don’t think this is related to running Roon Server on a Linux box.

I hooked up a Windows 10 box to my DAC and it’s working fine. I’d rather listen to music than mess around with the Aries.

I’ve been running Roon and connecting to my Aries just fine from my Windows 10 laptop. However,I just installed RoonServer yesterday on a brand new NUC with Ubuntu 14.04.1. No extraneous packages. Everything works fine, except I can’t see the Aries RAAT anymore as a network zone either. Airplay is there. Meanwhile, if I look at the Aries through the DS Lightning app, the Aries is behaving normally.

The NUC is running on Ethernet. The Aries on wireless in the same subnet. Though if Airplay works, I guess that proves its not a networking problem.

I am happy to send log files along and work with Roon folks on this. I really would like to get my Aries back on line with Roon.

The RAATServer seems to be running:
root 2851 0.0 0.4 873424 36436 ? Sl May14 0:18 /opt/RoonServer/Mono/bin/RAATServer --debug --gc=sgen --server RAATServer.exe

@Paul i’m having same issue with the same setup.
Sometimes it helps to turn off / on aries via remote control and seldomly it’s enough to open sound settings within the Roon app to get RAAT back.
Airplay working OK all the time.

@maniac Thanks. I did restart my Aries and could then connect via RAAT!
And, I gave it a day, and it didn’t drop the connection.

Seeing lots of good messages in the log files like this:

05/17 18:16:26 Trace: [transport/raatclient] GOT [3746] {“status”:“Success”}

Thanks for your advice. I hope it remains stable.

Hey @Paul_Kissman @maniac @Chris_Sauer – can you guys confirm when this issue occurs, does restarting your Roon Core cause the zone to reappear? Or do you have to interact with the Aries to get it back?

Mike, it was enough to restart Aries, but as far as i can recall restarting of Roon core could help also (but took much longer of course than to restart Aries so it was not practical workaround).

Currently, with latest Roon Core 1.2 build142 I am no longer having the zone disappearance issue any more, which is great! :slight_smile:

I am still having few drop-outs (usually 1-2 sec) of sound here and there, however it may be caused by slower atom htpc which is quite loaded as Roon is still analyzing my library in fast mode as it was taking ages - now it’s 5th day in a row of analyzing, currently in about 80% done.

Okay thank you Mike, no worries I am patient :slight_smile:

Just an update to the Aries RAAT zone disapearance - this morning when woke my mac running Roon as controller i have noticed Aries RAAT is gone (Airplay still present).

Here is what i have tried in this order:
Restarted Roon controller on OSX - NO change
Restarted Roon core on Linux (docker restart roon) - NO change
Restarted Aries via it’s remote - NO change
Physically Powered off Aries - NO change
Restarted Roon core on Linux - NO change
Stopped Roon core on Linux (docker stop roon ; sleep 20 ; docker start roon) - NO change

In the Roon core logfile I can not see anything related to Aries Raat (greping for Aries IP address).

I have not seen such situation yet. Have to go to work now, will try it again in the evening.

Question - should RAAT be discovered even if my USB connection from Aries to DAC is “not working” ? I have now recognized that USB Regen between DAC is powered off - can this be reason to not propagate the RAAT zone to Roon Core?


EDIT: by providing power to the USB Regen I have now got RAAT zone back in Roon Core now.

This is normal for a USB zone. They aren’t detected unless active. If you used some other output from the Aries (AES, coax or Toslink) then the RoonReady zone should always show up. AirPlay is different and shows up regardless of the active output (don’t know why). USB zones come and go depending on whether they are active. The unpowered Regen appears to be making the USB zone inactive.

1 Like

Just to throw in my two cents.

I just restarted Roon core and the Aries Zone was gone.
I restarted the Aries and it reappeared.

With regard to the USB / DAC vs Airplay vs Toslink / Coax discussion further down in the thread, I have a coax connection from my Aries to my DAC.