Live Radio vs DSP

Roon Core Machine

Synology 1522+ with 24GB of RAM

Networking Gear & Setup Details

Wired gigabit ethernet

Connected Audio Devices


Number of Tracks in Library


Description of Issue

Trying to play Live Radio from Roon to any endpoint using DSP (tried on a Bluesound Node, Bluesound PowerNode, and Rose RS-250) produces no sound. It looks like it is playing, signal path shows signal going all the way to the device, but no sound comes out.

Switching “Bypass all filters” (I only have convolutions for each room) gets the sound working.

Is there some incompatibility between the two?

Short answer: no - and it is working here, see screenshot.
Unfortunately, I have no tips or solution…

Seems to be slightly more subtle now that I’ve tried it with more stations.

Stereo ones seem to work with or without convolution. Mono ones only work without convolution at least (did not try with other DSP yet).

Could applying a stereo convolution filter to a mono signal completely cancel it out?!


Might be stupid what I say as I do not have experience with this. Can’t you make a special dsp preset for mono? To have first both channels summed in to one and apply DSP after that

Interestingly, the news station playing in my screen shot is monaural, at least both channels contain an identical signal, something I can clearly hear and also see with my roon-dynamic-range-metering-bridge.

Maybe share that mono live radio station, so I can check on my side…

1 Like

It’s an old issue - still unresolved apparently.

1 Like

@Marin_Weigel it’s

In your case the audio itself might be mono, but the signal shows 2ch. In mine, the signal literally is mono - 1ch so that might be the difference.

@BrianW - aha, that would explain it. Not a showstopper for me (on the system where I want to listen to the news, I could just play it through Bluesound app) but from Roon, having to turn DSP on and off is annoying…


You might be able to prepare an appropriate single-channel filter. This suggests that Roon can apply multi-channel filters:

Happy to give this a go as a test with the appropriate stream.

Edit Apolgies @Traian_Boldea I missed your suggestion.

1 Like

So that does the trick, take any filter and turn it into a genuine single channel file and you can apply it.

To convert a filter:
ffmpeg -i <filter_to_convert>.wav -ac 1 <mono_filter_name>.wav

This works fine when the filter L/R channels are identical, if that’s not the case the results might be surprising :wink:

Edit Another approach is to force the mono to two-channel before applying a two-channel convolution filter:

Another edit The second route is probably easier/preferable, it basically forces Roon to do the 2 channel conversion before applying a filter. You can just add the procedural step and save it as a mono DSP profile.

I guess that would work, too, but if I have to switch profiles for that stream, I might just as well simply disable DSP altogether. It’s a low quality local news stream, so applying room correction to it would be more of an overkill.

And then, what would the input channel be here? Being a mono stream it doesn’t have left, or right, or even LFE channels.

The single channel files present themselves as a center channel. Roon labels it 3.Centre. You can see it in the screenshot. Roon converts it to two channel as a final step Switching profiles is as easy as disabling but I see your point on quality. It was an interesting enough technical poser anyways :slight_smile:

1 Like

Ah, thanks. Then, if I make a permanent channel mapping to send Center to L/R, and if I don’t have any tracks that are anything other than stereo, will I have the original quality (+ convolution) when playing stereo files?

I wondered about that, and yes it will work for conventional two L/R channel audio as well as single centre channel. Things may get weird with 3+ channels though…

Edit Am getting the urge to make a feature request for conditional DSP.

1 Like

A lower priority I’d say, but a good thing to have…

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.