Loading album and artists shows moving Roon icon indefinitely


(Mark Kelly) #1

Hello,
As of yesterday, when I try to load certain artists or any album by those same artists, Roon hangs indefinitely until I hit the “back” arrow. These are albums hat I’ve had in my library for a long time so they are not new and subject to analysis.
Interestingly, if I do a search for the same artist, their albums appear and I can select them and play them. It just the browsing by album or artist part that is hanging.
I am running a Roon Rock I5 connected via an unmanaged switch into an HP router. Control is via a laptop running Roon connected by ethernet.
In my collection, on example is the artist “throwing snow”.


(Mr Fix It ) #2

Have you tried restarting ROCK from the GUI in a web browser?

As a matter of interest you should also make sure the version is the latest release on both the core and client B363

Also what graphics driver is being used on the laptop…if it’s intel HD is possible a windows update might have changed something. You could also try installing the 32bit version of roon for the laptop to see if this helps


(Mark Kelly) #3

Hi,

This is not a white-screen issue as such but I did (sorta) what you asked and something has fixed the issue.
The build on the Rock is B363 - I just did a restart as you suggested.
I also uninstalled and installed Roon on the laptop and it seems that I am now able to successfully browse all artists by artist or album. I reinstalled the 64bit version though!
Not sure which did the trick but I am leaning towards the Roon ROck restart.

Mark


(Peter Jones) #4

What is ROCK? Sorry for my ignorance, I’ve only been using Roon for a few days.


(Ged) #5

It is version of Linux and the roon server built by roon to work on Intel NUC small form factor PCs.


(Peter Jones) #6

Thanks Ged.
How do I restart ‘ROCK’? Can’t try at the moment as I’m not at home.


(Andrew Cox) #7

Use the RoonOS web interface accessible from within Roon.


(Mark Kelly) #8

OK, today the issue has suddenly started again.
My dedicated graphics card has it’s drivers up to date but since there are no graphics artifacts, I cannot see how that would be the issue anyway.
I am running a one day old install of Roon on my laptop so that will be completely up to date.
I have the latest install of Roon Core on my Roon Server which was rebooted about 60 minutes ago.
The artists that I have this issue with only have a few albums so there should be no issue with reading large amounts of tracks.
Background and on-demand analysis are set to fast.
If I wait a few minutes to try the artist / album again, it hangs again. So there is something about the artist or attributes of the files that are causing the hang.I have been able to play these same artists / albums in the past.
Again, I can do a search, find the artist or album and then play it this way but navigating will not allow me to do so. I checked and one of the same artists (Throwing Snow) is giving the same issue as before.

As you can imagine, I am not entertaining the idea of having to restart my Roon Rock continually and I am not going to reinstall the Roon software on my PC continually either so a permanent solution would be great. I guess you can look up my log file?

Mark


(Mark Kelly) #9

And now it seems to be getting worse.
If I look up many albums or artists in my collection, now all I get is the moving Roon symbol - again indefinitely.
The issue is also spreading in that if I click on an artist link when reading a review about an artist then this gets the moving Roon symbol only and sometimes when I search for an Artist and click on one of the albums it is now doing the same thing.
HELP!


(Mark Kelly) #10

And now I am getting albums, selecting them and finding no songs inside them!


(Mr Fix It ) #11

flagging @support here for you @Mark_Kelly1


(Noris) #12

Hello @Mark_Kelly1,

Thank you for providing that information. We have seen users have a better navigation experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?

Thanks,
Noris


(Daniel Beyer) #13

How is you music stored relative to the Roon Server? for example, is it local files, on a NAS, external USB drive? I suspect that if you are having such a slow time with the album files, that the issue might be related to the storage.

Also, When you setup a new Roon sever, it is going to go through audio analysis which, depending on a number of variables can take awhile. Under settings / library you can see if analysis is running. If so, turn it off and see if function improves.


(Mark Kelly) #14

I have my music collection via an external USB3 2.5" HDD with a direct connection to the Roon Rock. There haven’t been any issues up until a few days ago.
There have’nt been any new tracks added to my library since late last year so there is no analysis going on. I have tried turning analysis off and that didn’t fix the issue.
Please note that this seems to be a browsing issue. I can find the tracks sometimes through other methods but browsing by album or artist gives me the issue.
I’ll have to investigate the DNS server thing when I get a chance.


(Daniel Beyer) #15

I was going to suggest that you copy some music from your USB drive to a location on the laptop hard drive. Disable the USB Drive and then enable the local music to see if that responded quicker. How many tracks are on the USB HDD?


(Mark Kelly) #16

But surely a direct connection to the core would be superior to a connection to the remote??? A direct connection would be the ideal way to arrange your library wouldn’t it?
The delay also happens if I use my Ipad as a remote. I can’t see myself copying my library to my Ipad as a solution any more than copying my library to my laptop would be!

As it stands the only official suggestion from support is to try changing the DNS settings. I am not in a position to look at this until next week as I had to go in for a medical procedure yesterday and I’ve been told by my Doctor to rest and recuperate.


(Noris) #17

Hello @Mark_Kelly1,

I’m hoping that you’re on your way to recovering as quickly as possible!

I spoke to the team about your case earlier and in addition to the DNS change I initially proposed, we would also like to verify if the same behavior still occurs on a fresh database as to rule out anything strange occurring in the database. I would follow these instructions whenever you are ready to continue troubleshooting:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new database
  • Let me know if the same issue still occurs

Thanks,
Noris


(Mark Kelly) #18

Noris,

As soon as I am upright I’ll have a look at this :wink:

Mark


(Mark Kelly) #19

Noris,

I followed the instructions regarding rebuilding the database and browsing is now working correctly. My concern is that is now the 2nd time that I have had to rebuild the database due to corruption. Both of the issues leading to having to rebuild the database occured after an update. Obviously it would be good to identify what might be a contributing factor to instability in a user’s database.

Mark


(Mark Kelly) #20

Also on the topic of rebuilding. Is there any way to recover my old playlists??? They’ve disappeared with my new database.