Local roon versus roon server (core) devices

Roon Core Machine

Mac Mini, M1 (4+4), 16GB

Networking Gear & Setup Details

Home WiFi

Connected Audio Devices

Roon on different MacBooks and iPads

Number of Tracks in Library

Description of Issue

I used to run my Core on a PC running Windows 10 for years without problems. Recently I switched to a Mac Mini which appears to also run just fine (incl. ARC).
However, also switching my MacBook from Intel to M1 Max running Roon it didn’t run at first. Going to Settings->Audio I was surprised to see the Mac Mini under “this Mac”, instead of the M1 MacBook. A safety check intsalling Roon on my wife’s MacBook (she got my former 2019 Intel one) shows the MacBook under “my Mac”.

While weird I found my m1 MacBook under “other network devices” via AirPlay and went enabling AirPlay. Whiel I enabled AirPlay for all (w/o PW). I now get a notification popping up almost every time I select a new song whether to accept or reject as “” attempts to transfer something … perhaps the “” is my MacBook itself?

I reinstalled Roon twice locally, no effect. Do I need to also scratch and reinstall and reconfigure the core? Any thoughts?


Macs running Roon as endpoints will show up twice under Settings>Audio.
The output options under “This Mac” will use Roon’s RAAT streaming protocol.
The outputs under “Other Network Devices” will use Airplay.
Airplay has some limitations so you’ll probably want to use RAAT.

I don’t recognize the error message you’re seeing but I’m wondering if the MacBook is still set up as a Roon Core? You can only run one Core per account although theoretically you can switch between Cores by logging out of one and logging into the other.
But this isn’t something one would normally do.

Hope this helps.

1 Like

For some (unknown) reason when installing Roon on the Intel MacBook it properly recognizes itself as “my Mac” in the Audio settings (the core being with the Mac Mini). However, when installing Roon on the M1 Max the Audio settings refers to the Mac Mini as “my Mac” and the M1 itself only shows up as AirPlay connected and I get the weird pop ups …

I just scratched everything. Both, the M1 Max Roon and the Mac Mini Roon Server and Roon (local), and started over. Still the same behavior. This is extremely weird. I can only guess some residual data is kept some place I don’t know. Why would the Intel MacBook behave different than the M1 Max?

I seem to remember you having some insight into what might be a similar issue with Macs?
I honestly have no idea what’s happening here or if it’s related to the other issue but perhaps you might?

@Placebophile and @Ingo_Adlung
Nope not much insight. I did read the thread 5 hours ago but I have no idea.
There is a known change in the core audio drivers between last osx and Ventura. I think apple added an extra layer for the mixing of the osx sounds with sounds from others apps. Dacs disconnecting if used for osx sound and roon loosing them (not seeing them)
I have the server installed on an m1 Mac mini and the app on an old intel
Here is what is looking like:

1 Like

The only commonality between the Mac Mini and the M1 Max is that they share the same iCloud ID, while the Intel Mac uses my wife’s …

I use 1 mini and 1 iMac (Catalina) 1 iMac (volumio), all same iCloud ID

I do not remember if on wifi I would be able to use only airplay on iMac as an end point or all the connections appear. I’ll try to check

@ Traian_Boldea

That’s what it looks for me (from the M1 Max)

Can you plug an ethernet cable to see if there is any change… I’m trying to pull out ethernet cable from the remote iMac to see what happens when using wifi.

I also Know a thread in here were they were having problems with the speakers from an studio monitor

Hmm, same settings over wifi nothing is changing.

The core is actually connected via Ethernet, only the Roon (client) is Wifi connected

1 Like

I’m clueless. Did you check on the Audio Midi settings? Maybe there is something wrong in there

I went back to the Mac Mini and generated a new user account, and set up the Roon Server again. Now it behaves like expected. Using the same account on 2 Macs appears to confuse Roon badly


Maybe try turning off airplay for the mini. Apple menu > System Settings, click General in the sidebar, then AirDrop & Handoff, scroll down. Turn off Airplay receiver. Or just turn off airplay for all to see what is going to appear on roon audio settings

Wow… super… glad that it was that easy and worked out

Our messages crossed - thanks for trying to help. It appears I have a circumvention, except now I have disabled so many apps … seems Roon got an issue with identical accounts on core and client …

Apparently this wasn’t the case when I had the core on a Windows PC before …

I do not have that issue, but it is true that the osx are different on them, if the same osx it is possible. I think I read long time ago that it is recommended to have different users (when I was reascarching network connections for back up and music folder)

Glad it worked out. Happy to help (even I did not :slight_smile:
All the best

That’s odd. I have one Roon account and I am using the same Apple account on both my MacBooks. And Roon just works.

My 2017 MacBook Air is the Roon Core. And my 2020 M1 MacBook Pro connects to it without problems.

Same for me. But maybe depends also if they are on the same osx. Might be features for the Ventura. Like the one with the core audio drivers conflicting the exclusive setting on roon

Hmm shouldn’t be an issue. My MacBook Pro is running on 13.1.0 Ventura, while my MacBook Air is running on 12.6.2 Monterey. As Apple decided not to support Ventura on my 2017 Air.