Long gaps between tracks since build 1169

Yeah @Fergus_B I recall
At that time I had to change my router.
All of a sudden at this point my old Asus RT-AC88U couldn’t do it anymore. After years without problems!
Now I have an Asus AX86U connected to my Huawei modem. And it all works again.

As Uli will know there just does not seem to be rhyme or reason with this issue. I’ve had some of the kids home over Xmas and New Year and at one stage as I was using Roon without any issues we had on the following:
Roon playing 192/24 on Core to Matrix Mini I Pro 3
Roon using Ipad on WiFi as endpoint playing different 192/24 to Rotel Amp
3 Different 4K Hi Definition Movies streaming to 2 Apple TV outlets and a MacBook Pro
Streaming Spotify on iPhone
Streaming Premier League Football to another MacBook Pro
Son’s wife using iPad Pro and using bandwidth intensive AI Software for her Art Design.
All that on 100 Mbps down/40 Mbps up.

5 hours later. Only Roon being used and getting a 10 sec gap on 44/16

Internet Consistent all day!! Go figure?

1 Like

100 Mbps down/40 Mbps up is what we got here as well.

I am more like, quote:
“5 hours later. Only Roon being used and getting a 10 sec gap on 44/16”…


1 Like

This album is gapless here without any problem at all. And even before I did another Fritzbox unplugging.

Okay, maybe you can try that more in between. To find out whether your Fritzbox is delivering less and less throughput with each passing day after prolonged use without restarting it.
(My last FB ended up having to be restarted daily.)

Other albums that I know for sure running 100% gapless, always:

1 Like

Roon has been playing in background overnight… Now 5.00 am and whilst not a gapless album playing, the playback is spot on at the moment.


@UliR How has your system been going?

I have mixed results the last few days. Played up again after my last post. so switched to Audirvana. Played 9 hrs 32 min playlist and it took 9 hrs 32 min 14 Sec. Yep 14 Seconds over 9.5 Hours!!!

So went back to Roon yesterday and it went well for awhile, 3-5 sec lag on tracks for most of the day, gapless for 3-4 hrs (yah!!) and then back to 3-5 sec for hours and then 16 sec, 32 sec and 16 sec between 3 tracks in a row…

Very frustrating and switched off, back to Audirvana, which again just streams perfectly, but i do so like to have all my other facilities that Roon offers so hoping that something is sorted out soon…


@Fergus_B - very mixed emotions here… Your description reminds me of my situation. Today it was way better than on Tuesday, but still a lot of gaps whenever I create mixed playlists. I turned off DSP and volume levelling for all endpoints and this helped a bit. Perhaps only in my imagination…

Thanks for asking! :slightly_smiling_face:

1 Like

@Fergus_B just a second ago - my personal “long gaps between tracks all-time high” - 45 seconds - it is getting worse. :wink:

I bought a new streamer which is capable of using DLNA, this will arrive next week, then I can use Audirvana again with my system. I am a bit irritated that I really bought Roon lifetime, but now it is unfortunately too late.

1 Like

Wow @UliR that is some gap!! Gotta hope that it gets fixed soon.

Fingers crossed for all of us.

1 Like

I don’t get it.
I had music playing all afternoon. Until now.Not a single gap. Also in Germany.
Fritzbox dying?

1 Like

ISP says “all good”, Fritzbox looks fine, I don’t get it as well… Anyway, I lost fun searching for a problem on my end, and Roon support will not say anything about e. g. Qobuz being the problem for me, so I am done for the moment. Very frustrated, but done.

EDIT: Supplementary, the ping times in my network are less than 1 millisecond, for all devices that are hard-wired. And all Roon devices except the remotes are hard-wired.

1 Like

It’s not you isp or router it’s Roons caching issue for streaming content more a less said as much to me in a different support thread. A fix is incoming just not sure when.


I hope so. It is just very strange that not all users are affected…

I am not that affected tbh but it’s there in the logs regardless. So perhaps some systems just more susceptible to the issue.

1 Like

That’s how it must be. Nevertheless I don’t get it

Just to be on the safe side, I’ll say it again: I only ever have gaps when I mix songs from different albums in the queue. Whole albums usually run without gaps.
Your example albums from above, @Axel_Lesch, run gapless when played in their entirety.

It’s an issue when it plays tracks of different bit rate and frequency. It gets worse (the gap is longer between songs) the longer the core has been running since a server software restart.

It was better for a while but the latest update - the issue is back in all its glory. It is a very big problem - can’t be rebooting the core every day. -and if you don’t - makes playing music unplayable- unless you’re ok with 20-30 seconds of silence between tracks.

It’s NOT a network issue a Nucleus player local tracks on the Nucleus itself with the hdmi out as the output - has the same issues.

However - using ARC either on the same lan or remote - issue doesn’t exist.

Roon needs to fix this - it’s been well over a year.



I agree. Although I am relative newcomer to Roon, having purchased a lifetime license a year ago, I am appalled at the lack of consistent functionality of the app considering the expense. The gap between tracks has become a chronic problem for me since about November. Even after a daily reboot of my Roon Core, the glitch emerges after about six tracks. I have to rely on other applications now, which play the same files without a single issue.


Same here.