Looking for Roon Core


After changing wireless router, android devices or mac via wireless, cannot connect to Roon core. Had no problems with old router.

Roon Core installed on qnap TS -453mini. I have no problems accessing library or playback when connected to mac via wired connection. As soon I switch to wireless connection I loose access to roon core. Wireless router - ZyXel x.

Please let me know you thoughts.

You need to check the new router is allocating the same wifi IP address range as the LAN network…if its different then you won’t see the Core or other LAN based endpoints.

Also make sure you are not on the Guest Wifi as that won’t see anything.

Thanks for your answer.

My Lan ip range 192.168.0.x
wifi ip range 192.168.212.x

Are these the same ip address ranges?

nope… you need the wifi to use 192.168.0.x too

Time to read the manual or go to the Zyxel website and search for a solution based on the model

I will try writing zyxel.

If you correct, how come the Qnap app on android device connects to qnap nas without the problem. Yet roon app on same android device cannot connect to roon core. Roon core running on qnap nas. Cut this short - same networks lan or wifi but one app connects nas and the other does not

Roon needs all the devices on the same IP address range…other APPS might not have this issue as your router is able to see the connections to both and make them seem as one network.

I am correct sorry to say.

Once again, thanks for your answers

I have switched new zyxel router to a bridged mode. Now my android devices are connected to same network as nas
Ye result is the same app is still indefinitely looking for Roon Core

Solved. After switching my router to a bridge mode I have restarted nas and all works perfectly

There you go…not too hard after all :stuck_out_tongue:

I was too quick to celebrate. I have exited app and roon cannot reconnect again. Still same - looking for roon core indefinitely. After many experiments, noticed that roon only connects to my android device when I stop roon service on my nas and open it again. Only on this moment when roon service restarting my app connects.
Next I tried to return my zyxel router to normal mode. My android device now is on different network. Still when I restarted roon service on nas, my app connects but only for one session. When switch app off and on I am back to indefinite looking for roon core

Flagging support for you…NAS setups can sometimes do weird things so logs might be requested. @support

I have the same issue reported by Gediminas_Razgunas respecting Android Roon Remote, running on Asus ZenPad 3S 10, being unable to find Core unless Roonserver is restarted. This does not happen with Roon Remote on my Galaxy S9+ phone.

Can either of you PING the CORE from from your Androids? Maybe even see it with something like FING?

There’s a long thread on Android > Core connectivity issues:

There’s no clear fix yet, but in my case, unfortunately the problem only happens to a small fraction of users and Roon developers have been unable to replicate it enough to debug it, even with extensive help by some affected users. In my case, turning off IGMP snooping on my router(s) solved the problem.

2 posts were merged into an existing topic: iPad can’t find Core on Mac mini