Lost Connection when RoonServer screen is off

After having multiple issues with my library I decided to do a clean install of Roon today, and it’s currently re-building my library. I’m having the strangest issue though, and hope it can be solved easily.

I have my RoonServer running on a NUC connected to my living room TV, and I have Roon installed on my stationary computer in a nother room, with a wired connection between them running through the main router from my internet provider.

This is a brand new issue and was never a problem before… but when I turn off my TV, I loose connection to the RoonServer on my other computer. As soon as I turn it back on, it reconnects.

With the TV on, I can change channels, source input and whatever I want and I still have a connection, but turning it off cuts the connection at once. The NUC running RoonServer keeps on running through this, and it even keeps on working with adding new albums in the background as the number of albums have grown each time when I turn the TV back on.

I’ve tried searching the forums but to no help… and any tips are most welcome!

What operating system is on the NUC? What version NUC? also adding @support so they can chime in. They may need to know more details on your setup.

In the meantime you might check for a “sleep” or “hibernate” setting in the OS and bios and disable them. Or an option to remain active when HDMI is inactive. Also look in the tv and nuc Os and bios for HDMI CEC mode which is used to communicate over the HDMI cable to turn devices on or off depending on their state and capabilities.

It’s Win10 on the NUC, and all settings should be just the same as a few hours ago when it worked perfectly… so strange if this is an issue with the maschine itself or any Windows setting.

Just try and ping the NUC and then turn off the TV. If you loose the ping you will know that HDMI CEC is most likely the culprit.

Hello @Henrik_Richter_Schie,

Thanks for contacting support, I’d be happy to look over this issue with you. When you say you “lose connection” to the NUC, do you mean that the Audio stops playing and the Audio zone becomes inaccessible or that it completely stops responding? As others have mentioned, HDMI needs to have a powered on connection for it to detect an output source. Turning your TV off in this situation is akin to unplugging the HDMI cable as the “handshake” would be broken and the source would be lost. As others have said, I would take a look at the CEC settings, maybe also replace the HDMI cable in case it went bad. Also make sure to update Roon to the newest version if you have not done so yet.

Please also provide us a overview of your system setup using this document as a guide so that we can better assist you here:


Thank you for all your replies and I have today learned what HDMI CEC is, and checked on my Samsung TV that it’s called AnyNet+. It’s enabled on my tv and has always been so no change there.

On the computer sleep/hibernation is set to “Never”, so that shouldn’t be the problem either.

It’s not only Roon that’s acting this way I have found, so this is most likely a computer / TV issue. The TV needs to be on for TeamViewer to connect as well, and this wasn’t an issue earlier either.

Here’s what makes this even stranger… If I unplug the HDMI from the NUC then Roon is still working fine, but again if I turn of the TV, even though it’s not even connected to the computer running RoonServer, it immediately looses connection and says it’s searching for RoonCore. Turning the TV back on and withing 5 seconds Roon is running fine again. Only thing I could think of connecting them is the ethernet cable, although through the router and as I unplugged the ethernet cable from the TV i lost connection again! I have found the problem, but not the cause…

Only other device I have connected to the TV is a Chromecast. Could this be causing any trouble?

Hello @Henrik_Richter_Schie,

I apologize about my slight delay in getting back to you here and I do have to say that this is one of the more interesting cases I have seen. How close is your Router to your TV? I did a bit of digging and saw someone was experiencing the same issue as you due to interference from the TV itself: http://forums.whirlpool.net.au/archive/2170822.
It is possible that interference occurs when the Ethernet cable is not shielded and acts as an antenna to amplify RF signals. The next steps that I would take here are:

  • Try another Ethernet cable (preferably a shielded CAT6 cable)
  • Update the firmware on the TV, you can do so in settings or check the manufacture’s manual for exact instructions
  • Check to see if all of your network drops when you power off your TV
  • Confirm the distance is sufficient between the Router and the TV as to not cause interference

Can you please also let me know what model Router/Samsung TV you have exactly? There may be some more hints for troubleshooting that way. I hope these suggestions help but please let me know your findings.