Lost control of audio device after BluOS update

Core Machine (Operating system/System info/Roon build number)
Roon version 1.7 (build 619) stable (64bit)
Windows10 home 64 bit operating system x64 bit processor

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Telstra ethernet & wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
NAD C390DD amplifier with MDC DD-BluOS Module recent automatic update end Aug 2020

Description Of Issue
Since the BluOs upgrade Roon has stopped working.
Get the message

“lost control of the device” or similar.

The player appears in the audiozone then disappears with the above message.

Restarting it shows again then disappears when trying to play anything.

The BluOs app is able to stream from Tidal and other streaming services.

Roon is able to search the Tidal streaming service but not play back losing control of the audio device. However, Roon is able to play back music stored on the HDD/?LAN attached HDD without problems.

I have disabled every protection app I can find without resolution. (ESET, ghoserty etc).

I have no idea how to find the BluOs update number.
Thank you for your opinion.

Have you re booted your Roon Core, not just the app?

How do I do this? Thanks

It depends on your system. My Roon core is on a Qnap TVS471 so I just go to apps, select Stop Roon, then Re Start Roon. Wait a couple of mins and… Bingo…
You could Re Boot the laptop, or right click on Roon and select stop. (Just guessing here as I don’t have Roon core on a laptop

I think it may be the same as the issues here:

It’s a temporary fix, but if you adjust your MQA settings in Roon, you can get it working again.

Hi @paul_woodhouse,

Does this happen with any other endpoints?

Does this happen every single time you try to start playback?

I’m sorry but I am uncertain what an end point is.
The ROON server is only talking my NAD Amp.
Everything has been switched on and off many times with the same problem.
Should I uninstall ROON and reinstall?
I haven’t tinkered with the MQA settings yet but will try this and give feedback over the next few days.
Thank you again for your help.

Depending on what you use for a Remote, you might want to try playing though any speakers that it has and see if it changes anything, but there seems to be an issue playing MQA files through BluOs at present.

Hello @paul_woodhouse, changing the MQA settings sounds like a good idea! Let me know if you notice any changes when doing this. And by endpoint, Dylan means the speakers, DAC’s and anything else you have that plays audio connected to your system. Did you have a chance to restart your laptop since this issue began?

I haven’t tried changing the MQA settings yet as it produces a 20min cycle of restarting programs, apps and the amplifier for each cycle.

However I have tried to summarise the journey so far…

“BluOs vs ROON

I thought it might be sensible to produce a summary of my problems and send it to both NAD/BluOs support and ROON support.

I am really happy for both support teams to discuss directly with each other. And I am really happy with support received.

The problem started following the penultimate BluOs automatic update a week or two ago. ROON stopped being able to communicate with my NAD C390 amplifier which has a BluOs module installed that is plugged into my LAN.

The topography.

Telstra fixed wireless NBN

router -telstra supplied - TG800vac Gateway


Amplifier NAD C390 with BluOs module

Desktop (ROON core)



Desktop -only connects if LAN not connected

The main streaming service is TIDAL

The iPad has an TIDAL app and is able to stream TIDAL to the iPad without problem.

The iPad has an BluOs app which is able to control the NAD C390 amplifier and stream TIDAL after it is added via “add a music service” and natively “TuneIn” and “MQA” work seamlessly. These all work correctly. When ROON is started on the desktop the service appears in the same area. (It just doesn’t work and crashes the amplifier’s interaction with the LAN/WAN).

The iPad has a ROON app. It is possible to search ROON (Tidal and attached NAS libraries) But not play. (More later).

The desktop computer (Windows 10 home 64 bit) has the ROON server (1.7 (build 610) stable. I have reinstalled the latest download from the web(the same version)- (Although I didn’t delete the previous settings etc). I also found “ROON ready: NAD C390 version 3.10.0 RAAT SDK version 1.1.36 under device info- somewhere.

It also has a TIDAL app. Both are able to stream and play back through the local computer even when the NAD C390 amplifier has gone off line.

The problem starts when ROON tries to play back the Tidal stream to the amplifier (NAD C390). Initially the amplifier is seen but then a message that ROON has lost control of the device appears on the desktop program. It fails from controlling both using the desktop program or the iPad app. When this happens the address of the NAD C390 disappears.

A new BluOs update has just loaded. This allowed the ROON program on the ROON server desktop computer to search and play one streaming album but crashed the BluOs module in the NAD C390 amplifier on trying to play a different album stream.

At this stage it would appear to me that while the recent BluOs module updates (x2) are working well using the iPad BluOs app, they appear to be incompatible with the current release of ROON.

I would be grateful to supply more detailed information on the Heath Robinson like state of my LAN or any other detailed information that would be of use.

With many thanks. “

Thanks Paul

Hello @paul_woodhouse, I’d like to enable diagnostics for your account so I can collect more information about the issue. Next time you’re able to reproduce, could you please reply here with a timestamp of when the issue occurred and the track that was playing at the time? From there, I can enable diagnostics for your account and get a report to our team.

I’d also like to collect Bluesound logs from your device. You can get these logs by navigating to Bluesound’s IP Address in a web browser -> Diagnostics -> More -> Copy + paste the text into a text editor and send it as a shared Dropbox/Google Drive/Firefox Send link

Thanks will do.
However a curious thing is happening.
ROON, even after the BluOs upgrade, is able to search everything.
Also it will play everything except MQA files - where it crashes the amplifier.
BluOs will play the MQA files without problem.
On the ROON Core computer the default browser is mozilla firefox. This doesn’t do hi def music rates. However this was also there when ROON was working.
We have guests so I will probably need a week to collect the info.
Thank you again.

Thanks for your request. I will try to get the logs and send to you shortly.
I have copied what I have sent to BluOs support.
I have run into a slight problem in that it took me too long to respond. I am hopeful that the ticket can be re-opened.
Thank you again.

Sent from my iPad

On 23 Sep 2020, at 02:03, Support <support@nadelectronics.com> wrote:

Thanks Jade,
I have power cycled the whole house. With the power off for 30mins. That should do it.

Unfortunately the problem hasn’t gone away. I have sent a support request with #194244 as the subject.

Interestingly the BluOs App on the iPad will play back a Tidal stream both MQA and CD quality directly on the NAD C390 DD amplifier perfectly and is completely stable.

The ROON App on the iPad controls my ROON core on my desktop computer and IS able to play back a Tidal Stream to the NAD C390DD amplifier provided it is NOT MQA. It works for CD quality streams. ROON also works finding information etc. However trying to play an MQA stream causes the ROON to lose control of the device (the NAD C390DD) -the amplifier loses its address After this happens the BluOs App on the iPad also loses the NAD C390DD amplifier. However going to ROON it is able to stream a Tidal MQA stream to other devices eg the computer speakers.

Once the amplifier has lost its address it needs to be power cycled to allow the BluOs App to work again (and ROON in its non MQA search and playback).

Thank you again.

Many thanks.

##- Please type your reply above this line -##

This is an email to remind you that your request (#194244) is pending and awaits your feedback.

\ 40x40 Jade L. (NAD Electronics)

Sep 21, 2020, 11:07 AM EDT

Hello Paul,

Thank you for your detailed report!

Based on your description of your network and setup I do not see anything that stands out as a potential problem. Can you please confirm that you have done a full power cycle of your C 390DD as well as your networking equipment to ensure that everything is on a fresh boot.

In order to investigate this behaviour further I’d like you to please use the BluOS App and send us a support request. This request will automatically include a diagnostics log of BluOS from your device for me to review.

In the BluOS App, navigate to Help >> Send Support Request and fill out the form. Please use the current ticket number as the subject of the request (#194244) so I can easily identify it in our system.

Kind regards,
Jade L.
NAD Support Crew Analyst

I have just recreated the issue ca 21.30 to 22.45. Have taken screen shots and photos if this will help.
Re: bluos logs.
I have got to the diagnostic page. There is no “more” any more.
it just says v 3.10.3 C390-00AE then control panel. Diagnostic then statistic collection (off)
with button to force hotspot mode- I tried pressing and nothing seemed to happen
and “reboot” tried this - nothing happened - nor did it reboot.
I power cycled the amplifier after this.
I would welcome your thoughts on how to get the logs.
Perhaps you could liaise with BluOs (see previous) however I haven’t submitted this event.
Thank you.

Hello @paul_woodhouse, when I spoke to our device team they recommended I get BluOS logs over to them while you were talking to NAD’s team. Could you please do the following? I’d like to get this info over to our team as well.

You can get these logs by navigating to Bluesound’s IP Address in a web browser -> Diagnostics -> More -> Copy + paste the text into a text editor and send it as a shared Dropbox/Google Drive/Firefox Send link

The BluOs team is hoping to use teamviewer to find out what I have done wrong! The problem is Queensland is +10.00 hours UTC vs their hours. (M-F etc but they seem to work out with these if necessary.)
Working on it though.
Is there anyway you can liaise with the BluOs team?
I am happy to give consent and for you both to play pinball while I’m asleep.
I have a currently very workable solution which is to use ROON as the primary source. But if an MQA album comes up I listen to it using BluOs.
It is really only a minor inconvenience.
Thanks again.

A post was split to a new topic: Roon loses control of the BluOS app

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.