M.2 SSD in NUC8 keeps dying

If this is the way, people are treated in an official support forum, I’m off.

Seems like a lot of people tried to help you. That includes Roon employees as well as other Roon users who are not Roon employees. If this was happening to me, I would not have the knowledge to try some of the suggestions. I guess I would swap out the SSD with a different brand another time or two. If that didn’t work, maybe I would return the NUC as defective.

Hi Matthias_Dahms,

I spoke to our QA team regarding your report and QA agrees that this issue is hardware related, it is not clear what is causing the drives to fail, but further diagnostics is required to troubleshoot this issue, one possible suggestion is installing another operating system and running a diagnostics tool.

While ROCK is an “appliance style” device, it is built using your own hardware, and hardware sometimes has issues and needs to be replaced.

Since this is not a Nucleus, we cannot comment on the quality of SSD in use of if there are some other issues with your specific NUC’s hardware.

If you don’t want to troubleshoot this further yourself, you can also look up your local Roon dealer, they might have some experience with ROCK and/or troubleshooting bad SSDs.

Hi @Supersonic,
Stumbled upon your post. I too have had a bad experience with NUC and Kingston NVMe-disk, similar to yours and @Ken_Talbot (I’m not running Roon on it as of yet though). I would be very happy if you continue to share your experience with the forum. I’m about to open a support case at intel and any help and further information about this problem would be highly appreciated. Somewhat comforting not being alone in this.

I have a NUC8I3BEH and Kingston SA2000M8/1000G. Failed on me twice since march due to smart bad blocks. Replaced the first time and refunded the second.

edit: Spelling item=>Intel

I don’t understand. Why should this be an Intel support request when a Kingston model failed twice?

Unless a SSD from a different brand using a different SSD controller design also failed, there is no reason to suspect the NUC to be faulty.

Are these Kingston modules listed by Intel as compatible?

Thanks for your reply @wklie. The two Kingston disks I tested may both have been faulty of course, I see your point. What leads me to believe that this is an Intel issue is that Kingston seems to be a good brand in general and that the faulty disks behaved in a very similar way before crashing. The model is also listed as Manufacturer Validated on Intels web site.

Additionally, I would indeed like to test another disk and get my system up and running, but i feel that I’m running a risk on spending more time and money on failing disks. I hope that intel support can shed some light on this matter, or at lease letting them know that these issues occur.

HI Fullscreen

Have you seen this thread

I am as sure as I can be that the issue I had was with a Transcend M2 SSD

This is the thread (below) where I raised the issue, I replaced the SSD well over a month ago and so far no more issues (fingers crossed). When the Transcend SSD was in place I had to reboot every day or so

Yes, under “Drives: M.2 PCIe”, model “960GB A1000 PCIe NVMe”, part number “SA1000M8/960G” in my case.

Hi @Ken_Talbot, thanks for the links. Jay seems to have had a problem with power outage which caused is disks to crash right? Unfortunately, I have not had the same problem.
Which disk did you end up using after the Transcend crash? Still using an NVMe disk?

XPG SX8200 Pro M2 2280 PCle Gen 3X4

Thanks @Ken_Talbot, seems like a decent disk. Thanks for sharing!

I agree it’s a good brand, but that does not mean every product must be perfect. Same with Intel - I knew someone who was hit by the Intel Atom C2000 defect, but that’s another story. Try google “bait and switch” prefixed by your brand.

I’d like to reiterate my recommendation of only buying a SSD from a manufacturer who manufactures its own NAND chips.

I re-installed the ROCK OS on my NUC a few days ago (no hardware change) and it’s been somewhat more reliable. It crashed again shortly after the install, but then worked find for several days before crashing once more yesterday. It’s been working since.

I agree that it sounds like a hardware problem. I ordered the Intel SSDPEKNW512G8X1 which was the least expensive drive ($65 from NewEgg) that was Intel Validated on their compatibility list for the NUC8i7BEH - expected in about a week.

@wklie, thanks for elaborating, now I understand what you mean, and your recommendation to buy from original manufacturers make a lot of sense! To be honest, I have not realized the difference until now.

Hi @Jay_Torborg, thanks for answering this thread och updating us on the current situation. Good luck with the new disk.

I use Samsung. Never had an issue. If you are looking for a brand to try.

I think it’s been 4 months now. Please confirm that using a different brand of SSD solved the issue you reported.

Hi Peter, I can confirm, that the NUC works without problems since I installed the WD SSD.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.