Metadata Improver:Halted

I am having same problem. says,: adding music to library: of 40 tracks, 40 added, 0 identified
Then is red exclamation mark in a circle-- Metadata Improver:Halted. Roon needs a software update.
tablet running roon version 1.7(buiild 571) stable
Core on sonic transporter( running same version of roon
I rebooted transporter and Network Bridge with same result. Music plays fine just hung up on identifying tracks. 'circle going round and round for a couple days now.


The Roon @support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. hence I split out your topic.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

A post was split to a new topic: Metadata Improver – Halted

A post was merged into an existing topic: Metadata Improver – Halted

AT&T supplied gateway/router-(ethernet)-Small Green Computer Sonic Transporter running Roon Core-(ethernet)-dCS Network Bridge-(coax)-PS Audio Direct Stream DAC-AES balanced out to amp and speakers iPad with Roon controller

I would recommend your clear Roons server cache. You should be able to enable this for access in the Sonic Transporters UI and access it as file share on your computer. Stop Roon delete the contents or rename the cache folder, restart Roon.

Same can be done on QNAP, not sure where the folder is located though.

This worked for me and many others.

Hello @Joe_Lazenby, crystalgipsy has some solid suggestions here as well, but also let me know if things change if you disable your firewall/antivirus/VPN. Thanks!

I do not know how to do any of that. The whole thing worked flawlessly for 2 weeks and then started misbehaving shortly after I paid my yearly subscription. I may need Roon to control my computer and take care of problem.

This is very frustrating and disappointing! Non functional Metadata takes much of the positive aspects of Roon away. The album covers are not even visible! Why is there not “chat” or something similar available for help? Old folks like me did not grow up with computers and this is difficult to navigate!

CrystalGipsy, after making myself get past my frustration and thinking about what you suggested I did as suggested and it fixed the problem!!! So, thanks to all who responded to my plea! Protect yourself from this pandemic, stay at home and enjoy the music!!!


Super, enjoy!

@nuwriy, I think you need to get the developers to have a serious look into what’s causing this issueas its only started to happen to users since the previous Roon update to the last one and its effecting quite a few users across many different platforms. Have they changed they way updates are done as it only happens after updating.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @Simon_Arnold3, thanks for the feedback here. I’ve been working with our QA team to provide data about this error message to our development staff since the issue started popping up in threads. We appreciate everyone’s patience while we actively work towards a solution.