MQA Files will not decode sometimes

Hi, I’m using Roon v1.6 (build 401) with HQplayer and mostly using Tidal Hifi. I’m also have problem with MQA.

Mostly, Roon plays Flac format whether media is MQA or not. But sometimes Roon plays MQA format. It is completely not logical. I’ve tried everything, but Roon didn’t play MQA properly. Nearly all time, I see this signal path for source and output (On hqplayer side I’m using DSD upstream mostly):


So, is this a known bug? What can I do to handle this?

Is that file supposed to be MQA, because if it is, it isn’t being identified as MQA.

Hi emre,

I moved your post so that it will show up as a new support thread as your issue may not be the issue of the poster of the other thread. Let me know if you want to change the title.

Hi @emre_kapix,

If you play the MQA file to a different endpoint that is not HQPlayer, is it identified as MQA? Does this same issue happen across multiple types of MQA files or just specific ones? Does local MQA files exhibit the same behavior for the HQPlayer zone? If you don’t have any local MQA files, you can download a few off the 2L Test Bench:

Hi, Thanks for replies.

I’ve tried local MQA file from, and yes Roon identified as MQA:

But using with Tidal, most of my collection is consist of well known jazz recordings and nearly all of them have MQA version also. I have a Tidal Hifi subscription. I think this screenshot shows the current situation:

Works for me. I would say your not actually playing the mqa version. In the versions tab check which is currently active. How did you start playback? Did you press play from the album page as shown in your post?

MQA version (in my screenshoot) is primary version on versions tab:


And yes, I’ve started from album page, @CrystalGipsy did you play with different way to choose/play MQA version?

No played that way.

If you open a Tidal app, in settings > quality > streaming, do you have Master set?

Is there a change of behavior if you don’t send it to HQPlayer and just route it to a Roon endpoint?

Hi @emre_kapix,

I too have been able to play the MQA version properly from TIDAL. Since local MQA content works as expected, this behavior looks like it’s limited to TIDAL streaming MQA content only. Can you let me know if this occurs on other endpoints as well?

Assuming this is not a case of Tidal regional licensing issue that prevents you from hearing certain albums in MQA, your Roon configuration got the wrong 16-bit non-MQA version from Tidal as shown in the signal path. All Tidal MQA streams are 24-bit, as shown in CrystalGipsy’s signal path.

Try this:


Sorry, that was an irrelevant question. I was thinking there was a single control for the quality. There isn’t.

Hi guys,

I couldn’t understand why, but after updating build 401 to build 416 and problem fixed :slight_smile: Many thanks

Now, I have another problem :slight_smile: Hqplayer doesn’t accept 48khz and its variants (96, 192 etc.) So I had to convert it to 44.1, 88.2 … and it worked.

Hi @emre_kapix,

Thanks for the update here and glad to hear that the new build helped with this issue!

This thread may be of help in that regard:

If you haven’t managed to get 48Khz variants to work after giving that a read, you may want to start a new post in the HQ Player sub-section of the forum. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.