Multi part affecting credits

I have met now this problem in this (roon identified) album:


as you see, track 2 has 4 performances.
i tried disabling the multipart group for the album, because of tracks 4-5 where the the division of the title tracks (Dove… Quando… pt 1 & pt 2) in an invented “Dove” WORK and “Quando” Part is clearly an error.

Anwyay, what happens after changing this setting?

as you see… now track 2 has only 1 performance. moreover, the composition has disappeared.

so, i don’t see why this should happen.

in any case, here i ask again to the @staff & @support an explanation for the problem of tracks with no composition.
this is IMO the biggest BUG in roon… something that spoil in a way the so called “magic of roon”, which is to cross links various albums with respect to performers compositions and composers.

it’s something that i have pointed out now several times, but have received no answer so far.

no answer at all.
@joel ?

Hey @Niccolo_Terzi,

Currently this is the expected behavior here. When the Multi-Part compositions are disabled this also affects how these compositions are identified. Since this appears to be “working as designed” I would recommend also posting your suggestion in the 'feature request" section of the site.

Our product team and developers keep a close eye on that category, so that’s definitely the best place to propose a change like this and get feedback from the Community.

As for the tracks not displaying properly, the best option here is using WORK/PART tags and leaving multi-part compositions enabled.


@Niccolo_Terzi, you see how a simple turn of a phrase can change your whole outlook on a phenomenon? You only thought this was a bug. Actually, this is a … uh… negative feature!? A one-track composition, once Multi-Part is disable, becomes a…a…one-track composition, thus rendering it unlinkable.

Well, if you are having trouble with these expectations, have a dose or two of your favorite mind-altering substance. It might become clearer.

Besides, do you really expect the entire album to be correctly displayed?? C’mon.

1 Like