Composers links problems [no more only Greek]

in my library i have quite a lot of greek music albums. in most of them, i’ve used the latin translitteration.
anyway, in roon metadata i’ve got a lot of links to composers in greek alphabet like this:

i’ve noticed that the links don’t work: if i click on the link, nothing happens.
in the composer page the names are present, though. so i think it’s a bug, because the same happens with all of these greek links…

Hello @Niccolo_Terzi,

I’m going to pass along this information to our Q&A team. I will reply to this thread once they’ve had a chance to investigate this issue. Just to be clear, the translitteration links work, but the links using the original greek alphabet do not?


i can add that the link does not work in the album track list view (like the screenshot i’ve posted). if i go in the composers screen, the links do work. and if a select one composer, and look at compositions, like here:

then both greek-alphabet links do work.

Hello @Niccolo_Terzi,

The Q&A team is looking into the issue, and they would like to have some sample media to test. Is there any way for you to zip up a few of the tracks that are showing this behavior and send them to me using a service like dropbox? If you do not use or know how to do something like that, I can provide you a direct link to upload.


@john, more on greek links.
i’ve added another greek album. here are the first tracks:

in the first track, the first and third composers are the same person. the first comes from my tags, the third from roon.
as in previous posts, the greek alphabet link does not work (the others do).
what’s more, in the composers page, i can find the latin alphabet composers, but i cannot find the greek alphabet one! that’s why (i guess) the links are inactive, there’s nothing to link to!
note that in the composers page, at the end of the list, i have some greek alphabet artists, so this section is not empty. and it turns out that if i follow from the greek-alphabet composer to the album, and then look back from the album tracks the composers link… some of them actually do work. only some, most of them do not.
so i could confirm (as far as my inspection reveals) that:
-it’s NOT a general problem, some greek links do work
-nevertheless, most of them do not
-it’s not album related, in the same album some links work, others don’t.

hope this can be usefull

@john Here is another, different, case:

here, the greek-alphabet composers link do not work. but even the latin one do not. more preciclely:
-mikis theodorakis do work
-kostas karyotakis do not work (comes from my tags)
-the greek alphabet ones do not work (come from roon metadata).

so… i don’t know actually what’s going on. two notes:
-in any case, it seems only greek related
-filenames in this case are latin, in other cases are greek.

@john, sorry if i add also this problem… because i admit that i’m getting really very, very, very confused.
looking at the previous example, as you see all the tracks are by 4 composers (at least they are treated as such). but if i select any track, and pass to the composition i get this:

so, the composers shown in the album list seem that are different from the composition’s composers!
-this could explain why all the composers links (in this example) do not work
-note that the composition title is different because in my library settings i do prefer the file track title over roon’s metadata

so, what’s going on here? i don’t want to add confusion to all this, but something actually is wrong. in experimenting with greek albums, i’ve been trying to change composers in tags to see if something happened. but i noticed that even though the composers in the album view were different, they did not link to corresponding composers in the composers page. it is as though it were impossible to change composers, even if other composers are shown.
in one of the examples above, the first track composition is:

while in the album view it is:

only one of the composers is associated to the compositions!
and actually, of the various composers links, only that one … links to that compositions. the others are inactive (the last one, in greek), or do link to a list of compositions… where this one is missing!

while in the files i’ve sent you via PM the first track is:

but the corresponding composition says

and actually, only one composer link works… mikis theodorakis.

and here is another example, not greek:

in the composers link, herbert comes from roon metadata, herb from my files. in the corresponding composition page i get:

in this case, the herb magidson link do work, but links to another composition of the same composer, not this one.

i hope that all this helps you, and if this is a problem of my library you can help me to solve it :slight_smile:

ok, i was going to sleep, but this last one is really beyond my comprehension:

track 2, composer is dorival caymmi (it’s in file tags and roon). dori caymmi is the son, and it is added by roon. check in allmusic, there are both.
anyway, in the corresponding composition i get

so, roon agree with me :slight_smile: . why then does it show dori c. in tracks composers?
if i click to the composer link, it links to another composition in another album.

if i did not have that other album, i think the link would be dead, like in the greek tracks.

i think i’ve learned that:
-even though i ask roon to merge my file composers tags with it’s metadata, actually the composers links do link only to roon metadata composers. i hope this is a bug that can be solved…
-it happens that even in roon the composer of a track can be different from the composer of the compositions… which is meaningless.

i definitively confirm that … (despite of the post title) it’s not anymore a greek alphabet problem. it’s something (more general) related to composers and compositions in roon.
the problem emerged in greek albums for one reason:
-in my tags i don’t have greek-alphabet composers
-roon added them… and that’s why i noticed…
-and also clicked them because i wanted to merge with my tags

Hello @Niccolo_Terzi,

Would you mind sending a dropbox link to files of the last few examples you have posted? We’re continuing to work on this issue, I hope to have an update for you shortly.


regarding this composers problem, i also add this example.

the album is not identified… so i suppose that all the album informations/credit should come from file tags. am i wrong?

but looking inside the credits, this is not the case:

here, “Miki DelPrete” is a wrong version of “Miki Del Prete”, and it comes from Roon (not in my tags). the same about “Mariano Detto” (that should be “Detto Mariano”).
Then I look at the compositions, for example the second track:

Roon ignores my tags, and uses its wrong composer. even though in the album tracks view:

the correct composer is reported, and not the wrong one (DelPrete). and if for the same track i open the credits window, i obtain

Finallly, if i here click the link “Miki Del Prete” i get a list of compositions that DOES NOT comprehend the track 2:

i hope this helps to solve the problem.

@john, any news about this problem?
i’d be glad to know that it can be solved, or that there’s a ticket about it.

Hello @Niccolo_Terzi,

The QA team was unable to find an issue with the “ballades” archive, I’m hoping to get analysis of the other set of files by the end of the day tomorrow. I will keep in touch and let you know what the next steps will be.


ok, thanks for the reply.

hey @john
no news?

Hello @Niccolo_Terzi,

We are working on some metadata related bugs for our next update of Roon. Since it’s currently in development, I’m not able to comment on the current status of the issue. However, I hope we’ll be able to get this release out soon and we’ll be able to see if their fixes solve this issue!


Hi @john
i’ve installed roon last version (1.5), and as far as i can see, nothing changed about this problem.


Hello @Niccolo_Terzi,

We are still actively investigating this issue. We’ve been able to reproduce the behavior you are reporting on our end, and we’ve passed this information on to the developers. I will reach out to the dev team to see where they are regarding this issue, and I will update this thread when I hear back.