Network issues on one Unifi ap not the others!

Roon Core Machine

Server, Roon Core 1.8 (Bild 913) stable 64:
An fileserver with Windows 10 PRO, wired network, ssd drives and internal HDD drives. Roon on ssd and music on hdd. 24gb ram and Intel i5-4460 3,2GHz.

Networking Gear & Setup Details

One Unifi UAP-AC Lite 4.3.20 on every floor (three).
USG-3P 4.4.55
All APs are connected with POE.

Connected Audio Devices

On my laptop.

Number of Tracks in Library

113 000 Tracks

Description of Issue

When i play my local FLAC files 44/16 on my ground floor it takes about 10 secods before it starts playing and it just plays about 4 seconds. Then Roon jumps to the next song and after about 4 seconds it continous to the nex song and so on.
It says when skipping to the next song that “an audio file is loading slowly this may indicate performance or hardware error”

When i move to another Ap (second floor) in my house it works like a charm. I have three Unifi APs, one on every floor. They are the same brand and model. I have exactly the same settings on every AP.
This happens EVERY time i want to listen to musci on my ground floor.
I have about 1 250 Artist, 113 000 Tracks and 8 000 Albums.

Does it have to be this hard to use Roon. Why is it so darn sensitive with network. I dont have one singel problem with anything else! ONLY Roon!

Playing Device, Roon Remote 1.8 (Bild 913) stable 64 :
Laptop HP ProoBook i5-8365U, 1,9GHz and 8gb with Windows 10 Pro using Wifi with full connectivity.

Is the laptop on WiFi?
If so, I would do a site map with the wifiman App on your phone to see if you have some low signal areas. You can use the floorplan mapper to “see” the signal heatmap.

Its likely that the ap on that floor is getting more cross channel interference than the others from other WiFi around you. Is this on 2.4ghz or on 5ghz. Are you distributing the channel that suit that zone the best for each ap? Do an RF check for that ap and see what channels work best. If your Roon endpoints have to use 2.4ghz they may suffer more as this frequency is easily over utilised. From my experience 2.4 in my area is just useless too many other users of it.

1 Like

I am not a network expert, but I happen to run Unifi network at home too.

Are all your APs hard-wired to the ethernet to your switch which is hard-wired to your USG-3P gateway? You didn’t mention the switch, which makes me think you have a single AP connected to the USG that is meshed wirelessly with the other 2 APs.

You can check and find out from the Unifi Network Application (formerly Controller) which AP your laptop connects to when you move around the house.

1 Like

Thank you all for answering!!
I forgot to write that i have an D-Link DES-1024D switch on my ground floor where the problem is… Sorry!
I tried to play from my core to my TV that is wired to the D-Link swith. I get the same error.
Could it be my switch that is the problem??
I have no other problems what so ever. I stream movies at 60mb/sec and stream spotify and watch youtube and other stuff.

How is the core machine connected? Lan or Wifi, if Wifi this is probably where to look as roon recommends a core always be hardwired.

I run Unifi too and have an extensive network with both LAN and Wifi roon endoints but my Core is hard wired. I use all unifi switches and AP’s and use the UDMPro but in the past used USG3P also

it is more likely a channel degradation on the AP’s if the Core is LAN connected

your software on the Unifi is pretty old now too…

The core is hardwired.
How do i know wich channel to select? Even if the APs software is old i have no problem on any other floor.
And i dont understand why i dont notice this on any other software och streaming service?

I just tried to connect my laptop to my switch. I still have the same issues as before. So does this mean that the error is in the switch??

Try swapping the AP to a floor that is working and vice versa and see what happens

The later firmware gives much better info on network performance.

1 Like

looking at the specs of the switch it is only 100baseT so “could” be a bottle neck.

I would look into swapping it out with a gigabit (1000BaseT) switch. Maybe the DGS-1024D if you want to stick to the same series of switches.

In the meantime try hooking the troublesome AP direct to the router with no switch if possible and see what happens. Were you able to do the heatmap and check for WiFi signal strength? In particular where you typically use the laptop and see issues.

I used to have similar issues, but ever since I upgraded all my switches to better quality gigabit and and went to a mesh WiFi, I have not seen any issues caused by slow access. I am on “nearly” synchronous 240Mbs fiber.

Bypass it or replace it (Edit:) with a contemporary gigabit switch. If you don’t need that many ports, get an unmanaged Netgear GS108.

1 Like

I cant figure out how to switch my laptop to another AP. Or is this setting in a later version?

I tried it but coldn find any heat map…
But the laptop works fine. I starting to think it is the switch.

Thanks for the tip! I guess i will need to replace it. The only problem is that almost every network part is out of stock in my country :frowning:

Do you think that “TP-Link SG108S” a god switch? My local store has this.

I only use unifi switches in my setup makes it easier to manage and they all work together in harmony they feed power to the aps as well.

1 Like

I have ordered unifi swithes, the problem is that they are not in stock and hasnt been since before christmas…

The global chip shortage I guess. So the ap with the issue is getting it’s uplink from the dlink switch ? And no other aps do?

Yes, thats correct.
Do you think that “TP-Link SG108S” can fix my issues until unifi can deliver their APs again?

No I mean physically relocate 2 of your AP’s to swap locations and see if it follows the AP