New Firmware SOtM Eunhasu 0.4.5


#63

I too had stuttering after upgrading to the 4.51 SOTM OS. Increasing the buffer duration and resync delay fixed the problem.


(xFreeezer) #64

Thanks for the tip with the 0.20 that works.


(Scott Dempsey) #65

I am also experiencing serious stuttering after the upgrade to 4.5/4.51. I’ll try to change the buffer duration.

One of the bugs that 4.51 supposedly fixed (sMS-200 showing up as an uncertified device) continued for a bit in 4.51, but now the warning is gone. Don’t know what happened.


(Mikael Ollars) #66

I think that the RAAT implementation needs to be restarted. I updated using GUI a couple of hours ago, took just a minute or so this time.
Try and go to the Roon Ready settings and press Save, it worked for me.

Now i see (and can change, but haven’t) both the Buffer size and the Resync values.
It seems very strange that a null value in Resync could cause stutterig though? Unless SOtM label this function very differently i should mean “the allowed time for the DAC to adjust to a different sample rate or format”…


(rovinggecko) #67

worked fine in 4.5 for me, but in 4.5.1 it now shows uncertified…


(Alessandro Silvestro) #68

Installa un’altra volta v4.51


(Alessandro Silvestro) #69

re-install the new v4.51


(rovinggecko) #70

That did the trick.


(Fredrik) #71

After reading a thing in the SOtM thread at Computer Audiophile I decided to wipe the SD card (16Gb class 10) clean and download the 4.51 image from SOtM and burn it to the SD card.

Took perhaps 15 minutes to download the 7.4Gb file and another 25 minutes to write and verify the card with USBimage program, I use a SD card reader that is connected via USB internally in my desktop computer.

Started my Neo and the front light is lit up constantly after it has booted up not flickering all the time as before, started up Roon and still the light was constant, pressed play in Roon and the light started flickering as it used to do with 4.22 so my conclusion is that there is something different with the download version compared to the one I did the upgrade to in Eunahasu webpage earlier this week.


(Fredrik) #72

Today firmware 4.52 was available for download. Re-burnt my SD card and Roon works as it should.


(Stefan Stefan) #73

Hi, did you get 4.52 ?
The latest FW I can see is v0.4.51


(Fredrik) #74

You need to download it from SOtM:s webpage and burn it on to the SD card no upgrade from Eunhasu right now as it seems.

http://docs.sotm-audio.com/doku.php?id=en:eunhasu:burn_sdcard_image

Go to bottom of the page there you download the image. It is 7.7Gb so it can take some time.


(Stefan Stefan) #75

Interesting! Thanks for the link, will try it tomorrow. They don’t seem to mention it on their website, except I can see the updated date on the burn image “Last modified: 2019/01/15 23:41”

I’m curious if it fixes a bug for me : can’t change the hostname. Whatever I change it to it still can only be reached by eunhasu.local


(Stefan Stefan) #76

This is interesting: just wanted to DL the 4.52 version and now the latest version link is back to 4.51…
Also, they seem to have updated the page “Last modified: 2019/01/17 02:49”.

Since @sotm.kim is potentially also read this, I would kindly like to ask if this is a known bug or just happening for me: - No matter what I change my hostname to, the web interface it’s still only accessible via eunhasu.local (or IP).

The settings are saved, and even after rebooting my new hostname is displayed in the eunhasu settings but ignored.

Thanks!


(Tim Wilson) #77

I wasted a couple days trying to update to 4.5 through the web interface which failed a few times and resulted in the original SD card not working at all. Then I got a new class 10 16GB card and a usb adapter to write the newest image to.

Everything was going pretty smoothly until the software finished writing the image. 3 or 4 new drives suddenly appeared inside the SD card and windows freaked out about not being able to read what was in the drives. Also the writing software said verification failed meaning the image was probably messed up. Rather than going through this whole process again I decided to just stick the card in my sMS-200 and see what happens.

It works! So just because the software fails to verify doesn’t necessarily mean the image is no good. Maybe mine is not perfect somehow but I haven’t run into any problems. Although Roon no longer displays a picture of my sMS-200 which is disappointing. Does anyone know a way to get Roon to re-recognize the SOtM and display it’s picture?


(gnewelly) #78

Hi there,
I’m playing catch up on this.

I’ve just been through this twice now unsuccessfully. I can create an sd card (new 16g) and use dd utility to write 0.4.51to the sd.
When i’ve powered down, inserted new card, it won’t boot. I’ve tried re-formatting the sd card again both tried MS_Dos fat and ex-fat on a mac mini.

Am I missing something ? I’ve tried to follow the instructions, but no luck yet.
Cheers
Graeme


(Stefan Stefan) #79

I’m on macOS and just burned the disk image with dd-utility for macOS Inserting the card in the sotm SMS-200 Ultra it just worked on the next boot. Using the cheapest 16GB Lexar card I could find (not sure the model, nothing fancy).

Always good to have 2 cards to keep the old working one as a backup, just in case.

There is no need or purpose to formatting the card separately, as writing an image also clones the disk formatting.


(Stefan Stefan) #80

There’s also a new firmware version: 4.54 available.

http://www.sotm-audio.com/sotmwp/english/fw454/?fbclid=IwAR391lDLVS23vn2VDoHvY2H6nrL22yw-bpGajke3cgZiTqXhY09zAaBwUAg

Looks like there’s no disk image for this one yet, but the update does show up in eunhasu.


(MGXmusicUK) #81

ONCE INSTALLED
In Roon Ready config page, you can adjust the buffer duration from 0.1 to 1.0, and Resync delay from 0.05 to 10.


(Philipp Schaefer) #82

Thanks for the info. This forum is the best way to keep up to date.
I installed that new version (Kernel first, then firmware) via the browser interface. Took 5 minutes total, worked fine, everything is playing and sounding good.