New Firmware SOtM Eunhasu 0.4.5


(Tejay Haller) #124

I read through the thread in its entirety, and your post did answer most of my questions - thanks.

There are a few things I’m still not sure about. The first is the SD card size – a few people are purchasing 16gb cards to replace the original 8gb. It’s been mentioned that this was either as a safety measure to keep the original card image intact as a backup, or alternatively that this is necessary because the new image files’ size exceeded the capacity of the 8gb, which would render it a necessity to buy a new card. Which of the above is true?

Second, I cannot access any of the SoTM links so I can cross reference their instructions because their site is down. Does anyone have this downloaded that they can send me? Or, perhaps it isn’t necessary because it just details what was already said here…

Third, is it necessary to unplug my DAC while doing this? I don’t see why it would be, but one person did just to be ‘safe’… but, I don’t see any risk in it. SoTM recommends unplugging USB ‘disks’ when update via the web GUI, but this is a different scenario… and also a DAC is not a USB ‘disk’ – they are referring to plugged in HDDs I think.

Thanks! You saved me having to search around for 'best software to do X and Y". I’ll use as you suggested.


(Stefan Stefan) #125

not sure you can update with their website down… sorry, I don’t have a copy of the page. :frowning:

as to your other questions: SD Card size.

  • Looking at my current install the total size of all partitions is 7 GB. Only 1 is left and I can imagine temporary stuff sometimes filling that up. 16GB just gives much headroom… and this is also important because:
  • Most SD card (cheap ones especially) get slower the fuller they are. Saying this from personal experience.
  • They are really so cheap at least around here that there really isn’t worth for 1, 2 eur extra to not get a 16 GB one.
  • I always keep a working older card as a backup just in case - but it’s not necessary.
  • Interface updates are usually quick and painless, kernel ones can create problems and are slow. See my previous post on when I use which and why - with each having advantages and disadvantages.

USB DAC disconnecting

  • I never did this - nothing broke :slight_smile:
  • Don’t have any directly connected drives so no idea about that. However I do access my NAS via MPD sometimes
  • My dac has multiple USB inputs but only one bus - so when switching between my computer and the sotm on the dac, it always disconnects the SOTM (which is normal). Once I reconnect to the SOTM Usb port, it instantly recognises the DAC and works. (SoTM say to have the dac connected on Boot).

Don’t worry, you can’t destroy the SoTM by messing around with firmwares and SD cards.


#126

Personally never had a problem with an 8GB card. Just sayin.


(Tejay Haller) #127

Cool, thanks so much guys! So, while the 8GB may still work, I guess I’ll just pick up a 16 or 32 as long as I’m on the job already… Plus, someone early in the thread mentioned that May of SoTM recommended this as well.

I’m off to Best Buy to pick one up now. I was going to start in on this tonight, but… Argh, the site is down! That sucks. Does anyone have the original download of the latest version available that they could share? I know it might be a lot to ask since it’s so large… Google Drive does give everyone 15gb for free though :wink:


(Tony) #128

The website is back up and running now.


(Tejay Haller) #129

Got it! I’m back up and running with 4.56. Thanks again for the input everyone!

In case anyone has trouble changing the background image like I did (it kept saying ‘error uploading’) – After some trial and error, there seems to be more to the upload requirement than just that it is ‘under 5mb’ as written above the upload box. I only was able to get it to consistently accept a new image if I first cropped it down to a 16:9 ratio (I just used 1920x1080). I’m not sure about this, but it also seemed like it may have been also rejecting the upload if the file name was too long or had any spaces in it. I’m not positive on that last point, but it’s something to try if you are getting errors and scratching your head for possible solutions.


#130

Good news, hope it’s sounding great. BTW, all previous updates before this one worked fine with the GUI on the webpage. So I would use that in the future for more minor updates, it’s normally quick. However, they are incremental, so if you haven’t done it for a while you may have to go through several updates…
PS not responded till now because you didn’t give the secret password in your first post…:face_with_raised_eyebrow:


(Tejay Haller) #131

That was the case with me too - all my previous updates were through the GUI and never had failed. I’m glad this was a global occurrence and not just my particular unit. She’s working perfectly now with a new fast 64gb card and updated software… And puts out a very sweet sound :slight_smile:

I knew it! I’ll continue to wait outside the door for the hope that one day I may be allowed in the temple.

I wanted to add that May of SOtM did respond to me as well soon after I posted on this thread. She gave the exact directions I needed, as is matched by the advice given here, and was super friendly as usual. I’ve only had great experiences with their support team so far. I thought this would be good to mention for possible onlookers who don’t own any SOtM stuff yet.


(MGXmusicUK) #132

Version : V0.4.57

  • Date : 18-3-2019
  • Added the ethernet speed selection feature : 100BASE-T, 1000BASE-T
  • Disabled some unused back ground processes
  • Speeded up some back ground processes
  • Enabled the skip broken repo server for install or upgrade error
  • Fixed some USB devices which can not be recognized by kernel updates
  • Fixed the Reboot button in the system config and upgrade page
  • Fixed the Reboot button bug.
  • Added the Automatic ethernet MAC address update to the config file
  • Increased the Roon Ready buffer duration to 2.0 sec
  • Upgraded the HQplayerNAA to 3.5.6 by reinstalling
  • Upgraded the Librespot to 1.0.5 by reinstalling

(MGXmusicUK) #133

I would like to add that the new Firmware SOtM Eunhasu V0.4.57 is very stable.
On long listening tests with buffer settings, I managed to find the optimum sound quality for my system running abouth 20 to 30 metrs of Cat6 cable in between an i7 PC (core) and sMS-200 Neo. The final Roon Ready buffer duration that produced the best sound is 0.45 sec. Experiment yourselves it makes a difference.


(Serge K) #134

Mario_Grech_Xerri,
Is it in the SMS-200 / Roon settings or in the Roon Server on a PC?


(MGXmusicUK) #135

It’s in the SMS 200 settings/roon I’ll post a snap shot. Hope it helps

http://eunhasu/roonconfig.php


(Serge K) #136

I use 0.2 and 0.05 for the OPPO Sonica DAC. Music playback is smooth in all modes.


(Serge K) #137

New FW 0.4.58 with 100BASE-T dont work correctly with RoonReady.

Version : V0.4.58

  • Date : 27-3-2019
  • Fixed up system upgrade time out error
  • Fixed up kernel check time out error
  • Fixed link speed setting bug
  • Improved special charector USB ID recognize bug

(MGXmusicUK) #138

What’s the problem with it Serge.


(Stefan Stefan) #139

can you please detail?


(Serge K) #140

After update to 4.58 I have problem with RoonReady - cant play music and see message in Roon about mistake with speed of content. After returning to 4.57 all good again.

My current RoonReady settings are 0.5 and 0.3,
System settings: Static IP (10.0.0.2 for discret net) + 100BASE-T + Wi-Fi is OFF.

Some details you can see - here

4.58 for download - here or link on this page - sometimes links are changes


(Harald Kerkmann) #141

Dear Barrowboy, you made my day. After almost 8h to get the sms-200 updated with the advices from SOtM and this imageUSB-thing, i finally did it with SDFomatter and Etcher.

Tahnks a lot

Harry


(René) #142

I tried Etcher to write a new downloaded image of 4.59 to a spare SD card and inserted the card into the sMS-200ultra. No luck, the machine didn’t start-up anymore.
Wrote the same downloaded image of 4.59 to the same SD card with imgUSB, worked like a charm and is running fine!