New Firmware SOtM Eunhasu 0.4.5

(John Kenyon) #144

I am having the exact same issue. Its making me want to pull my hair out.

(John Kenyon) #145

@aggielaw just tried using sdformatter to format and etcher/balena etcher to write the SD. Worked after hours of getting the same error you are describing!!

(Kjell Hulloeen) #146

I just updated the SD card (7,9 GB) with 0.4.59, but once I put it back in SOtM sMS-200 everything is dead. There are no lights on the front of sMS-200. The network light on the back is blinking. I have tested with two different power supplies (original + S-booster 9V).

Anyone who have experienced the same or know what could be wrong.

I have also tested this forced rebooting: http:///exec.php?cmd=sudo echo -e “\nTimeout 3600\nProxyTimeout 3600” >> /etc/httpd/conf/httpd.conf; sudo reboot now;
Looking forward to your “emergency support”!
Brg
Kjell

(John Green) #147

I had that.

It all worked once I had formatted the card and used the software as mentioned in the post just above yours… 1.SDFormatter. 2. ETCHER/BALENA ETCHER

Then it worked a treat.

1 Like
(Kjell Hulloeen) #148

Thanks - I will try that and report back!
Brg
Kjell

(Kjell Hulloeen) #149

Reporting back - the SD Formatter combined with BalenaEtcher worked perfect and I am now up and running my SOtM sMS-200 with Roon. Combined with Accuphase DP-430/DAC50 and Accuphase C-280L (Pre) and Accuphase P-600 (Power) it sounds fare better than playing from my MacAir.

THANKS!!

Brg
Kjell

1 Like
(MGXmusicUK) #150

Last version information

Version : V0.4.6

  • Date : 17-06-2019
  • Added Ethernet auto negotiation selection feature
  • Added a new feature that prevent installing and uninstalling the apps if Eunhasu server is not ready
  • Upgraded ROON Ready to the version no. 1.1.36
  • Upgraded Squeezelite to the version no. 1.9.0.1157
  • Upgraded Logitech Media Server to the version no. 7.9.2-git1559745322
  • Improved the upgrade system
  • Enabled read and write feature on external USB disks via network share folder
2 Likes
(Philipp Schaefer) #151

Update went smooth. I always do it via the web interface and had zero issues so far.
New version plays without any issues.

1 Like
(MGXmusicUK) #152

Same for me…

(Fredrik) #153

4.6 is available on SOtM wbpage now for download.

https://docs.sotm-audio.com/doku.php?id=en:eunhasu:burn_sdcard_image

(Vitor Teixeira) #154

Updated yesterday, manually, from upgrade to upgrade, to 0.4.4 (some issues with this one).
Is it more reliable to upgrade with the SD card or the way I’ve been doing via eunhasu?
If SD card is the way to go, are there any problem in using a micro SD 16 GB with an SD adapter?
Thanks in advance.

(Vitor Teixeira) #155

No one?
Appreciated.

(Philipp Schaefer) #156

Hi. I did all updates via the web interface - and never had any issue. Lots of ppl do it via an SD card - and have lots of trouble with it (just read the thread). But if an update via web fails, you’ll need an SD card to restore. So better have one ready :wink:

(MGXmusicUK) #157

micro SD of 16 GB is perfect

(Vitor Teixeira) #158

Just downloaded the image and the dd utility, pretty strait forward so far.
But…when trying to extract the image ( Eunhasu V0.4.60) with Zipeg on a macbook pro i get an error, so i’m stucked in 0.4.4 - which by the way sucks, by far the worst firmware I’ve encountered. I’ll attach a print screen.
Any help to fix this issue will be much appreciated.
Thanks.

(MGXmusicUK) #159

Maybe download the image again or try it on PC if you have one …

(Chris Stewart) #160

Personally I’m getting tired of the poor quality of these firmware updates. They seem to be poorly tested and I’ve encountered corrupt images several times. The most recent v0.4.60 gave me errors when imaging - I tried several times on multiple SD cards with an “unable to write to a particular sector error”. Writing v0.4.22 (which is the only other version available for download on their website here: http://docs.sotm-audio.com/doku.php?id=en:eunhasu:burn_sdcard_image#micro_sd_card_image_files) worked fine each time. But as no other more recent versions are made available to downloaded, I’d then have to go through the slow and painful process of updating via the WebUI if I wanted a newer version. I simply don’t bother anymore.

I now notice the datestamp for v0.4.60 has changed - does this suggest an updated v0.4.60? Perhaps its been recompiled or repackaged and will correct the issue I experienced - it’s anyone’s guess though as no information is provided.

TLDR version

  • Tired of being a beta tester for these rushed firmwares.
  • SoTM please provide a repository of all known good firmwares so people can download them and image to their SD cards as required.
  • If for example v0.4.60 doesn’t work and you change and repost an updated image, change the version number (or at the least include information describing the change made).
2 Likes
(Gary Evans) #161

I totally agree with you—feels 20 years behind the times. Another complaint I have is that there is never a SOtM rep responding to anything on this site! Mine is just about unusable as it loses its connection after 30 minutes or so.

(Chris Stewart) #162

Hi @Gary_Evans,

I had the exact same issue - device losing network connectivity randomly - completely innaccessible via the WebGUI or as a Roon endpoint. Couldn’t even ping the IP of the device. Sometimes it’d dropout in 10 mins, 30 mins or longer. Other times it’d work for a whole day. I’d have to pull the power to restart the device each time.

In the end my unit got sent back to SOtM who could not replicate the issue. It arrived back to me with v0.4.60 on it which would not output any audio to my Marantz HD-DAC1. Said it was connecting and streaming, but my DAC showed no signal sync. It now has v0.4.22 on it and interestingly it’s not lost connectivity once - uptime is now about 7 days straight.

(Gary Evans) #163

Seven days straight? Amazing!! I think I’ll follow your lead and downgrade to 0.4.22. Thanks, Chris.

1 Like