No Connected Audio Devices after a restore from backup

Roon Core Machine

Roon Core installation:
Intel NUC w/ROCK
CPU: Intel Core i5-10600K
Memory: 16GB
Internal SSD: Samsung SSD 980 Pro 250GB
Operating System: ROCK Version 1.0 (build 259) production
Roon Server: Version 2.0 (build 1311) production
Firewall status (type, whether enabled): Enabled
Network connection (WiFi/ethernet, IP address): Ethernet 192.168.50.139

Roon Remote Installation:
Operating System: Win 10 Pro Version 22H2 OS Build 19045.3570
Remote Build: Latest version
Firewall status (type, whether enabled): McAfee AT&T Internet Security: Firewall On
Network connection (WiFi/ethernet, IP address): Ethernet 192.168.50.193

Networking Gear & Setup Details

Network configuration:
Network hardware (routers, bridges, switches, media streaming devices, network security hardware, etc)
All devices connected via ethernet

  1. Verizon 5G Hone Internet Gateway
  2. Asus RT-AC86U Wireless-AC 2900 Dual Band Gigabit Router  TP-Link TL-SG108E 8-port Switch for 3a thru 3d
    3a. Remote Client Win10 Pro PC
    3b. ROCK Core Intel NUC Kit BXNUC105iFNH2 i5-10210U Processor
    3c. Synology DS212 NAS
    3d. Dlink 4-port switch for 4a, 4b, and 4c
    4a. D&D 8c
    4b. D&D 8c
    4c. D&D 8c

Connected Audio Devices

Connected devices
Core – None
Remote – Benchmark Dac1Pre
Networked Endpoint – D&D 8c (3)

Number of Tracks in Library

Description of Issue

After a successful restore from backup and Roon restart, zero devices appeared on the Setup Your Audio Devices page.

image

I’ve tried restarting all devices to no avail. I’ve zip my log file folder (larry_logs.zip) and uploaded it to your zoho site for your review. I’d like to get my system going again and would appreciate any help you could provide. Thx.

Hi @Larry

I’m just a fellow user.

In your screen shot your still in the initial setup process.

Click finish, then head to Roon Settings and the Audio tab. Do your endpoints show up there?

Sometimes for me no devices show during the initial setup stage.

Hope this helps as you have done everything (in my eyes) right so far.

:innocent:

Have you tried to reboot the devices?

Hi @AMT. thanks for the suggestion, but failed to mention I tried that and received the following “No audio devices found” msg.

@Stefan_Mauron, I’ve rebooted (restarted) everything, several times in fact, but did see any change. Thanks.

Check that your McAfee AV has exceptions for Roon and Raatserver…

That could explain why you are not seeing any audio devices on your Roon Remote - but I would have thought that your D&D 8c speakers should be unaffected by this.

I notice that you are using at least one managed switch (TL-SG108E). Roon Labs recommend the use of unmanaged switches in a home network unless you are a network expert. I am not:

Core and devices are in the same subnet? And, you are sure, your firewall does not block local traffic between devices in your LAN?

What led to you to restoring from a backup?

Hi @Geoff_Coupe, I also tried connecting with my McAfee firewall turned off and still saw no devices.

Per your suggestions, I picked up a Linksys SE3008: 8-Port Gigabit Ethernet Unmanaged Switch to try. It arrives tomorrow. I’ll let you know if it makes a difference. Thx.

I use Fing from my phone to check the devices on my network. I can see my PC w/DAC, my NUC ROCK, NAS, and my D&Ds on the same 198.162.50.* subnet, so I suspect I should be okay. But I’m not a network guy so I’m not sure how to check if local traffic is being blocked…

If I recall correctly, over a week ago Roon failed to start. I received an “issue loading your library” msg on startup and an additional msg to “Restore from Backup”.

Aha.

Remove your storage and see if that helps.

This weekend my USB attached storage caused havoc on my setup. Within Roon nothing played from it and failed to allow Tidal to play. Unplugged it and Tidal started playing :man_shrugging:

When the storage was attached Plex would play what Roon wouldn’t. One of those oddities.

Just a thought.

What does the status page of your core say?

I’m not having an issue playing Tidal at the moment and my Roon library (storage) resides on a Synology NAS. Sorry, I’m not following how removing my NAS could help.

The ROCK status page shows the NUC is on the same subnet. as all of the other remote and endpoint devices. It’s using DHCP, and the IP addr, Gateway and DNS Server are on the same subnet.

Is there any other information on the status page that might be useful?

Exactly how I thought with my brief spell of issues at the weekend.

Long story short. I hot-swap my SSD for Windows and Rock occasionally. I swapped to Rock. Done this before without a hitch. This time I had a similar issue to what you described. I then decided to remove my attached storage and it resolved the issue. Added the storage back after Rock had finished updating the database with new additions to Tidal.

Then I had no issues.

Doesn’t make sense now, but it worked.

Your library is on a NAS so may not help though. Just a thought that Roon could be trying to read from the NAS and updating Tidals library databases at the same causing an issue.

Just my 2¢ worth of help :+1:

This would seem to be the common point of failure. I’d try connecting at least one of the D&D devices directly to the TP-Link switch to see if it shows up connected that way.

Also, turn off IGMP Snooping on the TP-Link switch.

A quick update… the new Linksys SE3008 unmanaged switch arrived today. I swapped it in, but I’m still receiving the “No audio devices found” error. I’ve run out of things to try.

My only hope now, is Support will find something in the Logs to identify the root cause of the issue. Fingers crossed.

Thank you to everyone who’s taken the time to assist with with trying resolving my issue so far. Your help is very much appreciated.

Just noticed that in your screenshot of Roon’s Settings > Audio page you have the red warning triangle icon showing in the top right of the screen.

What message do you get if you click on the icon?

It’s a msg indicating my automatic backups failed, which for now is fine since I don’t even have an intact database.

@Geoff_Coupe Would you happen to know the typical response time for Support to review the Logs?

There’s less than a handful of people in the Support team, and they operate a queue system, which has quite a backlog of issues at the moment. It can take over a week before your issue gets to the front of their queue, I’m afraid.