No connection with Asus RT AC 68U

Hello @support,

I have a system with a MacBook Pro connected to the LAN and an iPad running since a while without any problems connected through wireless LAN with an Airport express

Now I had to replace the Airport Express station and have connected the MacBook with a LAN switch and connected and ASUS 68U wireless router to the same LAN switch

Unfortunately I cannot see the Roon library any longer on the iPad

My configuration:
MacBook connected to LAN switch
Asus wireless router connected to same LAN switch in the same network
iPad connected to the wireless LAN of the Asus wireless router

Can you please help me solve this problem?
Is there any configuration of the wireless router I have to change?

Kind regards

You need to ensure that the WIFI network in the new router is assigning IP addresses from the LAN side address range.

if your iPad is not on the same subnet then you wont see the CORE on the LAN. One way to test is to connect the laptop to the same wifi SSID as the iPad and if that works then its highly likely the subnets are different.

you could install and FING on the iPad and see what subnet you are on and if it sees the other machines on the LAN side like your mac

1 Like

Hi @Rene_R_Wenzel ---- Thank you for the report and sharing your feedback with us, both are appreciated!

@wizardofoz, has offered some very good advice :thumbsup: which I would highly recommend taking. Having the outcome of the proposed test via FING will be a good data point for our evaluation of this behavior you’ve reported.

Lastly, could you please verify the make and model of “LAN switch” that you are currently implementing?


Thank you very much for your reply and your kind suggestions
I use a TP Link 8- port gigabit smart switch Model no SG108E

I looked at the network using FING and found the iPad and the iPhone in the WLAN but not the MacBook although connected
I enclose the settings of my wireless router- unfortunately I do not know how to configure it correctly to put it in the same network

Thank you very much for your kind support !


Hi @Rene_R_Wenzel ---- Thank you for the follow up and verifying that information for me.

If I am not mistaken the TP Link SG108E is a managed switch and we have seen a few issues crop up with these devices in the past ( Example: #1, #2, #3). I would recommend enabling flow control on the switch, as we have seen it help other users.


Hi Eric
thank you so much for your kind reply
It looks as if this could solve the problem
however it seems to me a rather complicated to find the web interface of the TP LINK for the Mac to configure the smart switch and enable flow control

So I decided to purchase a cheap gigabit switch (D link DGS1008D desktop switch) without the smart function hoping that this will solve the solution !
(Will arrive in two days)

I will keep you updated! Thank you again!

I removed a tplink sg108 as it’s not able to be managed by other than the windows app it comes with. I wasn’t having any issues with it mind you, but I moved to all ubiquity UniFi gear now and very happy…not cheap but hey we live and breath on the net these days and good infrastructure is key.

Thank you for this command
I wonder whether it makes a difference to buy a LAN switch for €100 instead of one for €15
I will see when I have tested the one they ordered yesterday
Thank you very much

I replaced 5 AirPort extremes with one unifi AC pro access point and never looked back

thank you very much indeed! Now I understand, you took a Unifiy WLAN hotspot? (is it the
Ubiquiti UniFi AP AC High Density?)

My issue is:
2nd floor LAN Modem from the provider an working iMac
1st floor: stereo equipment with a PS Audio DAC and an (older) Macbook Pro running ROON
LAN ethernet cable (KAT7) between 1st und 2nd floor
WLAN router (ASUS) in the 1st floor for the whole house

So the Macbook pro is connected to a LAN switch, the WLAN router (ASUS) connected to the same LAN switch.
In this case I do not see the Macbook pro in the Wireless network.
If I connect the Macbook directly to the WLAN router I can see the roon library but have no internet connection (for Tidal acc).
Thus, buying the Unify Hotspot would not solve this issue, correct?
I will have to test another LAN switch (I ordere a netgear giga switch).
Independetly, thank you for the suggestion to use the Unify WLAN Router. Maybe, it will be better than the Asus, as the ASUS router has a bad coverage in the rest of the house…
Regards René

@Rene_R_Wenzel I have a 2 story apartment with all concrete/brick walls and floors. here is the map that the Unifi controller software allows to manage devices and setups etc. Its not what I would call a consumer based deployment perhaps prosumer might be a slight understatement but I am very happy with the results and the Unifi Security Gateway 3P is perfect for keeping out the riffraff as far as I can tell. While the coverage map is basically for a 1 level I have not had ay issues with signals. Im using a single AP AC PRO not the HD. They also have MESH options.



Since the last report I still have the problem described above and I only was able to solve it by switching the LAN connection forth and back of my MacBook between the Netgear switch an the ASUS Router.

I enclose the two screenshots and would be very grateful if somebody could help me solve this problem

It seems not possible to use the same IP addresses in the whole network as you suggested…

When I connect the MacBook running ROON directly to the Asus router everything works but the back ups on the NAS server do not work
When I connect the MacBook directly to the Netgear ethernet switch GS108,
the back up works but I cannot see ROON in my WLAN!
I already tried to exchange the ethernet switch using a TP Link switch - same problem !
Has anybody an idea how to solve this problem?
Thank you again for your help

You have rebooted everything haven’t you? If so it might be worth trying again by turning everything off including the router and the pin starting with the router power up one device at a time and confirm fing finds what you expect?

Thank you RATBERT for your kind REPLY

However I did this already
I guess it has to do with the settings of the ASUS router
Now I connected the MacBook with the Netgear switch and switched on the wireless LAN at the same time on the MacBook
Now I can see everything and even to my back ups
However when I switch off the wireless LAN on the MacBook I cannot see room with my iPad in the same wireless LAN
For me this is the proof that the Asus router does not forward The signals unless directly connected without an ethernet switch…

The title says AC68U but the screenshot shows AC87U, so which is it?

Try to power down all routers, all switches and access points, MacBook, iOS devices and all network devices. Power up the router. Wait for 5 minutes. Then power up the switches and access points. Wait for 2 minutes. Then power up the rest of the network devices.

Hello @Rene_R_Wenzel,

I believe I have some suggestions that can help you with this problem you’re facing. From the second screenshot that you posted, I noticed that the WAN IP address listed by your ASUS router is This address is in the range that most Routers designate to devices on system, meaning I believe that the “Modem” you have from your Internet Service Provider (referred to as ISP from here onwards) is actually a “Modem/Router Combo” unit and this is why you are experiencing problems finding your Core. The ISP Modem/Router Combo you have is assigning an IP address for your devices when it should be the Asus Router that assigns these addresses. Just to make sure I have your network topology correct, I am transcribing it again below, please let me know if I am mistaken.

Modem/Router Combo from Internet Provider -> Lan Switch (wired)
Lan Switch -> Macbook (wired)
Lan Switch -> Asus Router (wired) -> iPad/iPhone (wireless)

In this setup, the Asus Router handles the IP addresses for wireless devices (such as the iPad/iPhone) while the Modem/Router Combo is handling anything that is connected to the LAN Switch and this is why communication is not possible.

There are two possible solutions here:

  1. You reconfigure your network to have this setup:
    Modem/Router Combo from Internet Provider -> Asus Router
    Asus Router -> LAN Switch (wired) -> Macbook (wired)
    Asus Router -> iPad/iPhone (wireless)

Notes: The Asus Router should have 4 LAN out ports on the back of it, you can connect your LAN switch to one of those. If the Asus Router cannot reach the iPad/iPhone because it is on a different floor of your house, I would suggest an Access Point (Note: An access point is not the same thing as a Router since an access point lets the router handle IP addresses)

  1. You let the Modem/Router from your ISP completly handle the IP address assignment. For this step to work, you would need to disable DHCP on your Asus Router and confirm that the Modem/Router Combo has the DHCP settings set up correctly. That setting is probably listed under the “LAN” advanced settings page but cannot be sure since I do not have an Asus Router.

To perform my second suggestion, you will need to find a page similar to this one and switch the Asus Router from “Wireless Router Mode” into "Access Point Mode:

I would try the first option before considering the second one because if you make a mistake in your router settings, you may need to factory restore it to get it operational again, but the second solution will require no physical changes
Note: Please make sure to Reboot both your Asus Router and ISP provided Modem/Router after making these changes

I hope that this was a comprehensive enough answer but if you require help with anything I mentioned, please just let me know!


Thank you Very much , Noris, for this comprehensive explanation.
You described my configuration perfectly!
Indeed the cable modem has also a router included (cisco) and I guess you are right that it serves the IP adresses.
I will be back at home next week and try the configuration you suggested!
Thank you very much again! I will come back and give you feedback if everything worked!

1 Like

I’m not very technically inclined, but I’m trying to upgrade from an old Asus router. I plug my Ethernet cable directly In, and join my phone, laptop, and tablet on the wireless. Right now I have tried several firmware versions. if you also want to upgrade your firmware jus follow these instructions

@John_Sam this probably constitutes a new thread with more details about your network devices.

its also possible that your router is assigning a different IP address range to your wifi network segment that will not see any of the Roon LAN devices.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.