No internet. How do I get the Nucleus working again?

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear AC1750 used as wireless network only. No internet available.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I moved my N+ to a location with no internet access. It worked fine for some weeks but now wont let me sign in without internet access. Any solution? It will be several more weeks before internet access is available.


Hot spot on your phone?

If its possible I cant figure out how. I have the N+ and my D&D 8c’s plugged into the AC1750 to make a small network. I can log into that network wirelessly with my phone and was running Roon from the phone but don’t know how to feed an internet connection via cell to the AC1750 so the N+ can use it to re-login.

Was the N+ assigned a fixed IP or was it, as default, getting it’s IP from DHCP? I’m guessing the latter, and that something happened to cause the Nucleus to reboot and now with no access point (router) in the environment it cannot establish an IP address consistent with whatever you’re using (iPhone or iPad) to access it. Let me know if I’m warm or not.

See this:

By the way, as others have stated, a good little app for Apple devices is fing. It shows what is on your network. If the AC1750 is working as your router, it should show up via this utility, along with your iPhone or iPad that’s running Roon app. Again, my assumption is that the AC1750 is acting as a DHCP server giving out IP addresses as requested by devices like the N+. However, if the N+ had been assigned a fixed IP address then, unless it’s outside of the AC1750 network, it should show up.

@stevebythebay The 1750 is setup to use DHCP but it does not have an internet connection. I do have a Jetpack that I use for internet access but there is no way to connect it to the 1750 to supply internet. You are correct in that we had a power outage the other night so everything restarted. That is most likely the cause of the problem. I can see the N+ when I log into the 1750 network but it wont accept my sign in due to there being no internet access. It does not show up on the network the Jetpack is on. What’s funny is that I moved it here from a different location and different network and it worked fine until now.

I cant get to the web admin page as it wont let me log in to the N+

Thanks for the help

If the 1750 “sees” the N+ that would mean it is in the same network. For example if the 1750 has an IP address of say and gave the N+ an address, say and your iPhone has an IP address of say then when you enter into the address bar of your browser on your iPhone it should display your N+ page. You do not need any internet connection to make this work. All you lose is access to the Internet.

I’m not clear on what you mean by “it won’t accept my sign in”. What is the “it” you’re speaking of? Signing into what on the 1750? Sounds like when you “log in” you’re accessing the 1750 configuration but when you try to “sign in” you’re trying to get to the Internet server that represents your account which includes the router, right? If that’s the case, you don’t need to go there, unless the remote internet server controls the behavior of the 1750, which sounds a bit strange to me. I’m not familiar with the Jetpack and how it’s IP address is defined. If it is in the same network as your 1750 then it should “see” the N+ as well. However, if it’s default network is 192.168.1.x and your router has been set as, for example, 192.168.0.x then they’re never going to speak with one another. If you reconfigure the Jetpack to participate in the 1750’s network then you’ll be able to access the wider Internet.

Steve, after a period without internet access a Roon core will need to be given that access and sign in verified. It will then work for another period of time. A simple 3/4G travel router would probably get the job done if there is good mobile phone reception.

I was suggesting to use a hot spot to talk to the N+. Not the AC1750. You said you count get to the N+. If it has a wireless connection then Turing your phone into a hot spot to connect to the N+ so it has internet access could solve the problem.

@stevebythebay The 1750 does not have anything plugged into its internet port. No wired internet is available here. The 1750 is now just a switch used to connect the N+, D&D 8’c’s, and my laptop or phone to connect wirelessly to the same local network to run Roon from. I have a Jetpack to use for internet access but it is also wireless and there is no way to connect to two networks at the same time or connect the Jetpack to the 1750’s internet port.

@Henry_McLeod I think you are right. This happened yesterday so the N+ must have to phone home once a month even though I have a lifetime subscription. I don’t think it was the power going off that had anything to do with the problem as I have power cycled the N+ several times in the last few weeks getting this system up and running.I think I will take it to work on Monday and see if I can login to the N+ there and then bring it back here to see if it’s good for another month.
I will do some research on a travel router today as we do have cell service here. The Jetpack is a cellular hotspot that uses my Verizon account to supply internet via cell service.

@John_Aiello The jetpack is a router of sorts but cannot be signed into at the same time as the 1750 and the 1750 cannot receive its internet service wirelessly. There is no way to connect the Jetpack to the 1750’s internet port.

When I login or select the 1750 LAN I can start Roon and get this page:

I select the N+ and get this page:

When I login to the N+ I get this message:

Thanks all

I know what the jetpak is and what it does. Your original post said you can’t connect the N+ to the internet. I was trying to say to connect the N+ to the jetpak to get internet access. You want to connect it to the 1750 to go full boat. That’s not what your original post says. Crawl walk run. You need to crawl and you want to run. Good luck sorting it all out.

You need an access point that supports client mode (device that let wireless clients connect to a wired network but that also can be configured to do the reverse) or a wireless bridge (device to connect wired devices to a wireless network). The Archer C7 can’t be configured that way.

I use a MikroTik hAP ac lite (RouterBOARD 952Ui-5ac2nD) for such a task. For me, consumer grade products from market leading brands have regularly failed to do the job properly. MikroTik devices are very flexible but need good network knowledge to make full use of their capabilities but a simple bridge can be configured with the ‘Quick Set’ routine (just choose CPE and provide suitable defaults).

Maybe other users can provide information about devices they use and that do work (and are maybe not so demanding about the users network knowledge).

There is also a thread to share opinions about wireless bridges:

1 Like

If a lifetime account is presumably tagged on Roon’s Cloud service, it would seem logical that there shouldn’t be a requirement to phone home every few weeks and verify the account status.

I know this is not how it works, merely how it should.

Those were my thoughts exactly. That’s one of the reasons I bought the lifetime subscription. I wanted to be able to take the N+ with me. This location doesn’t (yet) have wired internet. We will have it in a couple more months. Until then I think I’ll take the N+ to work, log in to it there to renew the connection/ license and then bring it back here for another period of time (month?) until it needs a refreshed license.

@BlackJack Thanks for the suggestion. I have never heard of a wireless bridge. I will do some research today.


As mentioned above, you will need to periodically connect to the internet to verify your Roon account. If you can get a temporary connection you will be good for some tome without having to check in again.

Thanks @dylan. I’m going to take it to work with me next week and reestablish the license. It seems like with a lifetime subscription this shouldn’t be required.

If there wasn’t a way to verify your license from time to time what would stop someone from buying a lifetime subscription and then putting it on 100 computers after the license was first established. Roon has to be able to verify you from time to time to make sure you are only using one core. Seems very fair to me and if you didn’t have this lack of Internet issue going on you might not even know it was a thing. Just saying.

1 Like

I would think that the first time a license was used that the unique core motherboard ID could be easily recorded (and most likely is).
Then if another instance of the same license was requested it would be rejected as is the case if you want to switch cores now.
I must be one of the few honest people left on earth.

You can swap your license between as many machines as you like as long as only one is current which is a very flexible license so authorising is needed and a small price to play for the inbuilt flexing.

1 Like

It looks like the unit needed an update. That appears to be why it needed to phone home. I have it updated and returned to the network with no internet access and it is working fine again. I will wait and see if it needs to phone home again in the near future.

1 Like

It now appears that once a month the N+ needs to phone home or it will stop working. It quit working on September 3 or 4. I took it to work , fed it some internet and it was happy. I expect that next week it will need more of the same.