Not getting suggestions for me from Qobuz

On the Roon Overview page I’m not getting suggestions for me from Qobuz. I am getting Grand Selection and Top Albums. I’m also not getting Qobuz suggestions on the Album View.

Anyone else having this issue? For reference, I’m in the US.

PS - Roon Radio is also saying it’s restricted to my local library only. Odd, since I can select and play albums from Qobuz no problem (using Roon).

Same here, a lot of confusion on the overview page

Yeah, it’s being really flaky. Now it only shows Top Albums and Recommended Playlists.:roll_eyes:

The Qobuz app seems to be working normally, so there’s something going on between Roon and Qobuz. :confounded:

Edit: Now it’s only showing Top Albums. :face_with_symbols_over_mouth:

There seems to be a problem at Roon’s end with those Valence-related functions. They’re working on it.

Thanks. :+1: (10 char)

Cloud outages I guess.

It’s still being really flaky. Proper interfacing with Qobuz is very hit or miss. :frowning:

Right now it’s even worse

No issues using the Qobuz app.

@support , any ideas?

Are you still having issues?

No, now all is doing fine.

1 Like


It’s been hit or miss here. Sometimes it’s fine, sometimes not. It can go from fine to not within minutes. :frowning:

Hi @Saturn94,

Can you please provide some more details regarding your setup?

How are you router’s DNS servers configured, are you using Cloudflare DNS, Quad9 or Google DNS?

Setup is as follows:

Salkstream III (running Linux Arch; houses Roonserver and music files) > Netgear ProSafe GS105 ethernet switch (unmanaged) > Netgear N300 WNR 2000 v2 router > Arris SurfBoard SB 6121 cable modem. All connected by ethernet wire.

Remotes: iPad (7th Gen), iPhone 6s, iPad mini 2.

All devices running latest OS/software versions. Internet connection seems fine. I have no trouble playing Qobuz albums already added to my library.

I’m not familiar with router DNS server configuration. I logged into the router and I don’t see anything in the router settings that indicate I’m using any of those DNS servers (that I can tell). In the router settings “Domain Server Address” it is checked “Get Automatically from ISP”. We get our internet service from Cox Cable. Does this answer your question?

PS - Right now Qobuz is working fine through Roon (Roon Radio working normally as well). I’ll check it periodically throughout the day to see if it continues to work normally.

I pulled up Roon few times throughout the day yesterday, and for the most part, Qobuz behaved normally (once I had to refresh the Overview page to get the Qobuz suggestions to come up).

I’ll continue to monitor it.

I keep getting this as well, Roon radio has also bee very spotty with Qobuz.

1 Like

Thanks for the report. I think something is going on between Roon and Qobuz. It has been better yesterday and today so far.

Btw, something odd I’ve noticed, sometimes when I click on a Qobuz album/track to play, I get an error message saying track not available, but then a second or two later it plays the track normally.

This could be the DNS server problem @noris suggested you look into. You should be able to do this on your Netgear router How do I set static Domain Name System servers on my NETGEAR router? | Answer | NETGEAR Support
The Google DNS server works fine for me with Verizon service. Those are and

1 Like

Thanks for that information. That is foreign territory for me (I’m not a computer person), but I’ll check out that link.

@noris , what do you suggest?

Btw, I’ve been running Roon Radio the past hour or so and it’s been fine except for skipping one track (track not available error message).

Update: Roon Radio still playing fine, no skips since the first one I mentioned. Oddly, Roon Radio is only playing music from Qobuz, nothing from my local library despite having many of the same tracks (same resolution as well).

Hi @Saturn94,

I’m glad to hear that things are mostly working fine for you now. If you see issues return we can enable diagnostics and take a closer look at thing.

I’d also like to second Scott’s suggestion above of trying to use Google DNS (or any non-ISP DNS). In my experience ISP default DNS options can be a bit flaky compared to some of the other options out there and we tend to see performance improvements that could help in situations like this.

1 Like


So to use a different server is it a simple matter of entering the new server address in the router under “Domain Server Address”, or are there other settings that need to be changed as well? I did some Google searches and got confused/lost really fast! :thinking:

Hi @Saturn94,

You can use this guide from Netgear on how to change the DNS:

We suggest putting in an IP of or in the DNS field as per the guide.

You should also be aware that your router is very old an is an “N-style” router (no 5Ghz support). You might want to upgrade the router for better overall performance too and chance the DNS alongside it as well.

1 Like