Now Playing Screen Clicking on Album/Artist link takes either ages or does not work at all [Ticket In]

Complex behavior, but I’m pretty sure this description is accurate. It’s repeatable. Fairly recent, I would say a few weeks, but I was offline for a few weeks before that — likely most recent build.

On my iPad, I bring up the Now Playing page, and I can follow the links: album pages, artists, composers.

But if I have been doing something else, like reading on the web (or writing this!), when I come back to Roon the links dont work, it hangs with the Roon logo, “Loading…” Only way to break out of it is to shut down the Roon app (which isn’t easy on an iPad!) and restart it.

(Nothing wrong with playback.)

And here is a really arcane case: if I click the Close X in the upper left, it sometimes works and sometimes not. Specifically, if the previous location was something else in a Roon, like another album or artist, I can close NP and get back to it. This works even if the previous page was the same album, reached through some other navigation. But if I have tried to get to the album or artist through an NP link, it is as if that page is poisoned, I can’t get to it through the X either.

Complex to describe, but completely repeatable.

(On two iPad Pros, 9.7” and 11”.)

Hi Anders,

I moved your post to this thread. There is a ticket in for this bug.

Let me know if your situation is different.

Cheers, Greg

When I view the “Now Playing” screen or whatever it’s officially called and click the artist’s name next to Performed By, the screen will just say Loading Artist… forever.

If I search for the artist and click on the artists name, it will populate all the correct data instantly. It should be loading the identical data, but one link works and the other doesn’t.

This only happen on my iPad Pro.

Here are screenshots of what I’m talking about and a video I made showing the issue. In the video I run the standard search at 4:44 so you can see how quick the artist data loads this way.

Video -



Hi @ComputerAudiophile,

Thanks for reaching out! We currently have a ticket open with our development team for this behavior. I can’t give any specific timeframes, but we will be sure to keep everyone updated here as soon as there is new information available.

Thanks for the report!

1 Like

After a while, the transition indicated on the screenshots is impossible (endless waiting) :frowning:
iPad pro, NUC ROCK.
%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5 %D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5 !

It is a pity that such errors are made, and it is even more pitiful that such errors are not corrected for so long that you have to create new topics. :frowning:

I got very often of endless “loading album” problem while remote from iPad/iPad Pro/iphone Xs Max devices.

This problem happens after switching from other apps back to Roon app, or waking up the devices back to Roon app. The app loss control of going back to track list page and freezing on “loading album”. If I wipe out and re-running roon app then it works again.

Any way to improve this problem?

My system:
roon server --> QNAP HS-453DX NAS
roon core & output–> Win 10 PC --> DAC
roon control --> iphone Xs max / ipad pro / ipad mini

Hello @Curtis_Liao,

Thanks for contacting us regarding this issue. We are aware of a similar issue where users are presented with a “loading album” page if they click on the album details or artist name on the now playing screen, see this thread (Now Playing Screen Clicking on Album/Artist link takes either ages or does not work at all [Ticket In]). Is this the same issue as the one you reported here? Are you accessing the “Now Playing” screen or are you accessing the Queue screen on these respective devices?

I can also confirm if this is the same issue by taking a look at the diagnostics from your devices. To do this, can you please reproduce the issue once more and let me know the exact local time in your country (e.g. 6:11PM) that it occurs at? Once I know that info I can enable diagnostics for your account and take a look to see if this is the same class of issue that has been reported and is actively being investigated by the dev team.


1 Like

Yes, same issue as as this link:

It happens during accessing the “Now Playing” screen. The remote app still works in the Queue screen. I can select tracks from Queue screen.

I just tested and quickly get the problem again. Please kindly trace the time of PM 1:25~1:29 , 2019/3/19 (Taiwan time).

Thanks for help.

Hello @Curtis_Liao,

Thanks for confirming that error state, this does indeed appear to be the same issue. I have gone ahead and moved your post over to the main thread for better tracking, once we have addressed this issue someone from the support team will be sure to update you here.


Same here, all links on “Now playing”-page are leading to an ever-spinning Roon animation on my iPad 2018. On iMac the links open almost instantly…

WTF? Now it’s working perfectly? I verified it was still a problem 10-15minutes ago, and right now the issue is gone?

That’s right - it comes and goes.

Core Machine (Operating system/System info/Roon build number)
Roon Core on QNAP NAS (i5 3470T CPU, 16Gb RAM, Roon DB on 250Gb SSD, 150.000 songs on 3*6Tb WD Red) or ROCK on NUC7i3/NUC6i5
Latest build of Roon on all devices

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Main router Asus RT-N66u, NAS Core on WLAN link, other cores hard wired. One HP Gb switch in mix

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/ect.)
Diverse, Auralic Aries G1 and Femto, Raspberry Pi, AlloUsBridge, SOtM sMS-200

Description Of Issue
All of the links on the Now playing-page are dead, leaving an animated Roon icon; “Loading album/artist/composition…”

1 Like

I suspect you have stumbled upon the same bug as

Do your symptoms match?


1 Like

Thanks for the heads-up Brian, didnt find that thread, but yes…. Same issues on my end.

1 Like

Same issue here clicking on ‘Artist’, ‘Album’ or ‘Add Album To Library’. Now Playing is the only page where I’ve seen this occur.

Roon Server running on Late 2012 Mac MIni (2.3 GHz i7)
Mojave 10.14.3
Roon Version 1.6 (build 401)

Do you need any more data to resolve this issue? I can easily reproduce this issue if needed.

Hello @mrvco,

Thank you for the report. We currently have an active ticket with the dev team regarding this behavior, so more information is not necessary at this time. As soon as I have any updates to share, myself or someone from the Roon team will be sure to update this thread.

– Noris

1 Like

I have been experiencing this issue since 1.6 as well. Mac Mini 2012 Core i7. Using local files and Qobuz. It happens regardless of endpoint - KEF LS50W - Bluesound Node2 - AirPlay.

1 Like

Hi everyone,

We’ve made a change here in Roon 1.6 (Build 416) that we believe should address this behavior. Please update Roon and let us know if you’re still seeing any issues. You can read the full release notes here: