NUC Storage Problems

Just installed ROCK on an Intel 7. 8 gig RAM, 128 M2 & 4 TB Internal SSD. Also connected our ethernet to a WD NAS for backup. I had been using the NAS for storage so there is a small amount of ripped CD on the NAS which I ultimately want to move to the internal SSD.

My problem: ROCK does not recognize the internal drive4 TB drive. All other endpoints on the network are working fine:Aries, Bluesound, PS Directstream with Bridge II, Sonos. I must have omitted something during the conversion from my Mac Mini setup. So when I changed to a different core everything worked, but I do not see the 4 TB drive. Is there something I need to do in the settings.

Any help appreciated.

Flagging @support for you on this…did you follow the internal NUC storage installation guide here

When you say you don’t “see” the drive where exactly are you looking? On the Rock web interface? In Roon? On the network when you use a file explorer?

i don’t see the drive when i’m in Roon. Also i don’t see the drive when i look in the network on my Mac Mini. I would need to set up another monitor to go into Rock.If that will help i will disconnect my monitor from the Mac Mini.

Maybe i just need to add a shared network location, but i don’t know how to do that.
Or perhaps the SSD is not formatted correctly?

Did you go to the GUI and format it?

As Tony says - did you format the drive once it was installed in the NUC using the ROCK’s web interface? As stated in the NUC storage installation guide:

The internal drive is formatted from the web interface when you first set up ROCK, so you won’t be able pre-load music onto the drive – you’ll start with an empty drive, and copy your music over later

Until it’s been formatted by ROCK, it won’t be visible.

I just tried to reformat the internal storage and the message I received” It seems the IP Address of your device has changed so you will need to return to the Roon application to determine the new IP of this device.”

Are you using the GUI? Can you post a screenshot?

System Status

Operating System
Version 1.0 (build 158) stable
Running 41 minutes, 42 seconds.
Roon Server Software
RestartToggle Dropdown
Version 1.4 (build 310) stable
Running 37 minutes, 29 seconds.
Roon Database & Settings
100% of 114 GB available.
Internal Music Storage
4000GB, Samsung SSD 850 100% of 3697 GB available.

Not sure how to post a screenshot from the Ipad. This is the best i can do at the moment. It seems to be an IP address issue.

Google is your friend

Lokks like the drive is rhere and ready to go. Just need to access it from your network and load music. Will let someone more familiar with MACs help with that.

With my Roon serup this is what the internal storage on my ROCK looks like. Screen shot from my android phone. It show up as “music folder”

I am still having difficulty. I opened the NUC and connected externally to USB and the drive is recognized. Also reformatted die to EXFAT. Rock for some reason does not recognize Samsung 850. it shows up in Rock configuration, but when you go to storage it’s not coming up.

Does “music folder” show up? If so, that should be your internal drive.

You browse to the Rock on your network and copy your music to “internal storage”
The path should look like this;

“Intrenal storage” would be your installed drive. It will not show as a separate drive but as a folder.
When i get home tonight I can get you a screen shot of what it looks like.

Hi @arthur_Zaretsky ---- Thank you for the continued feedback here bt more importantly, thank you for your patience.

I noticed that you had raised the same issue in this thread here as well. Just to keep you in the loop, I would normally combine the two threads but I don’t want to re-add any any information that has already be stated above. As such, I will be addressing your support request “here” as I can see you have been getting help from other users (thank you everyone :clap:)

Continuing forward, as asked previously, would kindly provide a screenshot of your “storage” tab in Roon so we can see if your “music” folder is appearing. Additionally, can you please verify that you can access the internal storage of your NUC via the OS on another device as can be seen in my screenshots below:



Thank you. I will look into this.

OK, the rocks 128gb m.2 drive shows up (the core) with all it’s sub folders, the 4tb SSD sata drive shows up in the Bios of the nuc, it shows up in the rock management console,it’s a samsung 850 ssd. I pulled the drive put a sata to usb cable on and plugged it into the nuc’s usb port and it showed up every where no problem, move it back to the internal sata of the nuc and it does not show up. I’m working with Arthur.

be aware, most recent Roon version (unsure if this change went out yet) calls this ROCK Internal Storage and not Music Folder. @mike would know since he manages the release notes.

Does that mean that when the update goes out my "music folder’ will be renamed? or is it only on “new” installs that it will be called “Rock Internal storage”?

LOL question answered by the 1.5 update, yes it does rename the location… :slight_smile:

The path on the network is still: \ROCK\Data\Storage\InternalStorage

Do you not see an “InternalStorage” folder? Something like this:

That’s your internal SSD, which shows up in Roon as the default Music Folder in Roon’s Settings/Storage tab.