Nucleus/core not connecting to remote apps

Roon Core Machine

“Nucleus (Roon OS1.0 (build 227), Version 2.0 (build 1143) production”

Connected to router via direct ethernet cable, using Roon Remote App on iPhone and MAC, audio devices: Sonos and Cambridge CXNV2 streamer.

Issue: Nucleus/roon remotes have been running fine for the past 1.5 years. Yesterday I had to re boot my internet (which I often do) and the Nucleus has lost connection with the remote apps. I can see from the administration website that my Nucleus seems to be operating with no issues. I can also see all my files etc. when I connect it to my MAC ( flashing green and solid amber lights on the Nucleus).
Having attempted numerous re-boots on both my internet router and the Nucleus itself without succes I’m getting the “Choose your Roon Core” screen on my remote apps. They are seeing my Nucleus but I’m just getting an “initializing” message (and the “Connect” button is a dark blue and won’t respond).

My internet is working fine, apps and software are all up to date. I have tried deleting the apps and re-installing them. Nothing seems to fix the problem.

Any help much appreciated.

Double check the IP addresses of the Nucleus and your other network devices. You can use a program link Fing. If the Nucleus, for example, had a fixed IP address, the network reboot may have changed the base network subnet.

For Roon, all devices, need to be on the same first three numbers of the IP address. aaa.bbb.ccc. x.

Another thing to check is that, you should be able to get to the nucleus web ui from a web browser on the Mac.

Thanks for getting back to me.

The IP address for the Nucleus is The network IP address is…so this looks to be ok?

Yes, I get the Roon status page when I type in the Nucleus IP address into my Mac browser. All systems are showing as ok.

But its not working…

Just used Fing to verify that the Nucleus is on my network and is online

1 Like

Excellent. So, at this point on that same MAC can you open Roon and connect to the Nucleus core?

No, that’s the problem. Despite the Nucleus seemingly being online with no issues (as per the administration systems report)…my Remotes(i.e MAC and iPhone) won’t connect to it…its perpetually “initializing”,

It has been running like clockwork for 1.5 years…nothing has changed in my network settings and all software is up to date etc…its a bit of a mystery!

Have you tried to Reinstall the Roon OS on your Nucleus by using the Web Administration page?

Yes, I have already tried this to no avail…

2 posts were split to a new topic: Roon Nucleus missing CODECS

Hi @Matt_Dawson,

I am hoping these simple steps will fix the problem for you. Please be sure the Nucleus is connected to your network when performing them.


Reset network settings on RoonOS

Connect the Nucleus to a monitor or TV via HDMI.
Connect a USB keyboard to the Nucleus.
Press ENTER.
Type resetnetwork.
Press ENTER.



press enter

NOTE there is no . after resetnetwork


Thanks Wes

I carried out these steps precisely but it didn’t have any effect. The monitor displayed the details of the Nucleus and the message: "Roon can be accessed by OS devices on your network. If you don’t see this device there, check “Roon OS devices on your network”.

It also displayed the IP address of the Nucleus.

When I typed in “resetnetwork” nothing happened. I rebooted the nucleus and attempted this several times with no success…

Can you post a screenshot of the Web Administration page of your Nucleus? Thanks.

Here is a screen shot. All systems statuses are “OK” on the Admin page.

That looks fine, so it’s a bit of a mystery as to why the Nucleus is showing up as Initializing in your Roon clients. @Wes - what’s next?

Yes, it all looks ok on Admin page…and the Nucleus is certainly connected to my network… think I mentioned above that I’ve also tried re-installing my Remote Apps…I even plugged my MAC directly into my router…still stuck on “initialzing”…

Some other questions/suggestions.

  1. Do you have any VPN going?
  2. Do you have IPv6 enabled on the network?

For your iOS device, when it cannot find the server, the screen has a blue help button which opens a screen to allow you to enter the server’s IP address. Instead use and see if that enables that device to connect.

Hi @Matt_Dawson,

This is indeed an odd issue. I’m seeing your Nucleus online and reporting to us but I am seeing an error in diagnostics that seems to show the Nucleus is having issues with communications on your intranet.

11/10 17:50:21 Debug: [tcptunnel2] error in go_local_to_remote: Unable to read data from the transport connection: Operation canceled.

This might indicate something is stopping the communications as, @Rugby suggested. Can you try his suggestion and report back?

Also, I would like to bring this up with my development group to get some more options here. Can you power on your iMac and leave it going so I can get diagnostics from it as well? I’d like to see what the iMac sees as happening and this will be instrumental in getting a complete picture.


1 Like

Thanks for looking into this further Wes. I am not at home today but will leave my Mac and Nucleus running tonight ( UK time).