Nucleus+ does not recognize external hard drive

Roon Core Machine

Asus ROG laptop; Windows 10 Home; 12 gb RAM; Intel i7-6700HQ @2.6 GHz
Roon Core: Roon v. 2.0; build 1193 updated to 1202 this morning

Networking Gear & Setup Details

Arris Surfboard

Connected Audio Devices

Nucleus+ is my attached (via WiFi) music servers; an external Seagate hard drive is attached to the back of the Nucleus+ by USB

Number of Tracks in Library


Description of Issue

My Nucleus+ does not recognize the attached hard drive. This problem came up suddenly about 2 weeks ago. (Unit is 2.5 years old.) No WiFi or system change preceded problem onset; no changes in Nucleus+ connections were made. The only change to the hard drive was the addition of 3 music files the night before; files were created on my computer and were not downloaded; they were copied to an already existing folder.

I have rebooted my computer, router, and Nucleus+ a number of times.
I have replaced the USB cable between the Nucleus+ and the external Seagate hard drive.

Roon cannot find the hard drive within the program. When I try to access the drive attached to the Nucleus+, it is not found through Windows File Explorer.
When the hard drive is removed from the Nucleus+ and attached directed to my computer, all files can be read (and were backed up).
The only music available through Roon are my Tidal and Qobuz subscriptions. 11,000 or so albums on my hard drive are not found by Roon. When I go to Settings–>Storage–>attached drive, I get error message “This drive is not available. Check the drive or edit this folder if it’s been moved.” Drive has not be changed, edited, or removed.
My dealer suspects the Nucleus+ USB port has gone bad.

Try repairing the drive on a PC, and plugging it back in.

Mike–Not quite following you.
When I attach the drive directly to my computer, I can access the hard drive’s contents and can play the song files without problem.
Doesn’t that suggest there’s no problem with the hard drive itself?

I think rock is more “sensitive” to file system irregularities - I remember previous posts (perhaps wrongly) where a chkdsk fixed it. Perhaps you could search, or just try it :wink:

Is the external drive NTFS formatted? See here:

1 Like

Just to emphasise something in that procedure:

The solution, if your drive is NTFS, is to plug it back into a Windows machine, run chkdsk /f on it, and then eject it properly and put it onto the ROCK machine.

Don’t simply unlpug it from your Windows PC, but safely eject it…

1 Like

I ran a chkdsk, but my command of DOS is weak. Stage 1 (examining basic file system structure) seems to be fine. Stage 2 (file name linkage) seems okay, but after a blank line, it reads “Errors found. CHKDSK cannot continue in read-only mode.”
I then tried chkdsk f /r to repair erros, but access is denied as I don’t have sufficient privileges to run the program. (There’s no locking/password requirement that I know of.)
Any other suggestions?

Thanks, Geoff. I always eject USB drives properly from my computer. I tried running chkdsk /f, but it won’t work as DOS replies I don’t have sufficient privileges to do it.
Still stuck.

Try: chkdsk /f

Aha, you have! Run CMD as admin first…

Search for “cmd” in the Windows start menu. When it shows up, start it as administrator. There may be an option easily visible for this, or else rightclick the start menu entry and choose Run as Administrator from there. A command box will start that shows “Administrator: Command Prompt” in the window title. Then repeat the chkdsk command

Thanks, All…
I wasn’t able to do a fix disc command (chkdsk f: /r) but when I rebooted the computer, it auto,matically ran the routine and repaired the disk.
I reconnected the HD to the Nucleus+ and all appears to be working properly. (Whew!)
I’m still not sure why the hard drive looked and worked fine attached to the computer and not the Nucleus+, but as all is again working well, I won’t dwell on that point. :wink:

It’s /f not f:

Consider using a different file system as recommended in the documentation - unfortunately only the ROCK documentation and not the Nucleus documentation.

NTFS is Microsoft’s, proprietary, and questionably documented. A lot of effort has gone into reverse engineering NTFS for the Linux kernel that RoonOS uses, but it may never be perfect.

The new driver in Linux that is used by RoonOS now is very strict about not touching NTFS disks that are not completely error-free, to avoid later corruption. Maybe more strict than Windows itself :wink:

1 Like

@Michael_Cohen glad you got it going, but please take a hint: its time to move to exFAT :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.