Nucleus Losing its connection to the Router

Core Machine (Operating system/System info/Roon build number)

Nucleus Rev. B

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google AC-1200 Mesh Router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio DirectStream DAC utilizing its I2S input from a Matrix X-SPIDIF 2 and powered by a Teddy Pardo LPS

Controlled by a 3rd generation 128GB 11 inch iPad Pro

Description Of Issue

I started a thread about this exact same problem I was having back in May but then my Nucleus suddenly started working as it should again and so that thread was locked after I said that my problem had been solved. I can no longer post anything to that thread because it has since been locked.

My network is working flawlessly with every device in my home except for my Nucleus. While listening to a song, it will suddenly stop playing without any input from my iPad. I’ve tried reinstalling the app and occasionally that brings the Roon screen back up for a few minutes but then the Nucleus loses the connection again. I’ve tried manually turning off the Nucleus and starting it up again and that occasionally works but only for a short time. I do this repeatedly over the course of an hour or two until I throw my hands up in disgust until the next day. Today if worked for three hours until it failed again.

My original thread can be found here: My Nucleus keeps losing its connection [Resolved with Roon 1.8 (Build 806)]

As stated, I’m having EXACTLY the same problem again.

Here are a couple of the screens that appear while this process is playing out

And I was asked to provide a sceenshot of this message too:

I’m not with support but I noted in the screenshot the url you use is
In the next capture the Nucleus appears to be at

Is this intentional?
How do you have these subnets routed?


Sorry, but I’m not all technical and I don’t know what I did that caused them to be displaying two different numbers. I just now looked at both my iPad and my laptop and they’re both showing

No worries.
I think you are having a problem with devices and where they are on the network.
If you can log into the cable router you have. it should help identify what is where.
Unfortunately, you will need to learn a bit more to get this working well, but it should be doable.

You will want to know what IP address your nucleus is assigned, your laptop and iPad just to know.

Feel free to ask any questions. You may wish to let us know what router you have so we may help better.


Unfortunately it could possibly be an indication of hardware failure, although starting to work again trouble free for a few months is not normal.

Can you confirm that the Nucleus and all your remotes are on the same subnet.
So all the first three sets of numbers have to be the same, and the last three numbers are each units unique identity on your network.
192.168.86.*** looks like your network


Thanks for taking the time. I just went back and entered the devices I’m using for playback in my original post.

I will try to figure out how to get into my Google router to get that info and will post it when I do.


OK, I managed to find my IP addresses and the Nucleus’ ends with 26 and the iPad ends with 27. Should the IP addresses be identical on these two devices?

I really don’t use the laptop to control Roon.

They should not be the same.
It works like a phone number. each device has its own unique IP.
try now to take the client and say. Select a different core. If your Nucleus isn’t visible by name use the IP

1 Like

Sorry again but what is the client in this context?

No worries. Inside the Roon application on your iPad. in your second screenshot above. It asks you to connect or select a new core.
It is the same core but not at that address as you now know.

The Roon client doesn’t know what you do yet. Once you tell it about the new IP address it should work again.

There are ways to make this not happen again later.


OK Paul, I think I understand. Should both devices be set to the Nucleus’ IP address or that of the iPad? Or maybe it doesn’t matter as long as they’re the same?

Any place you have the Roon application installed. iPad, laptop, phone, that application needs to be pointed at the IP address of your Nucleus. They are remote controls. they may all access it at the same. The display will be similar on all clients and update simultaneously. Kind of cool.

1 Like

Each device should keep its own IP address outside of the roon application.
Hope that makes sense.

1 Like

It probably does but it’s over my head. :laughing:

1 Like

I was able to change the IP address on the iPad it reverts back to the previous one. It is also asking for a subnet mask.:flushed:

Where on the iPad did you change the IP address? Just inside the Roon application, I hope.
You should double check on your router but the netmask for the 192.168.86 subnet is probably going to be

1 Like

Oops, I was trying to change it in Settings on the iPad. I’ll try it now where you said.

1 Like

Oh heck, now Roon is up and running again and it’s not asking me if I want to make an changes. :smirk:


As soon as it goes down again ( and it will) I’ll follow your instructions to the letter. Thanks Paul. :+1:

If it goes down again, I think you will be needing @AceRimmer’s advice and will probably be returning it.
It shouldn’t be that unstable.
Make a backup as soon as you can and store it somewhere else.

1 Like