Nucleus no longer scans storage automatically

After upgrading from a Core running on Windows to a new Nucleus doesn’t see new files unless I manually force a rescan. I claims to be watching, but never sees anything. It works just fine when I do rescan, but then still doesn’t see new files without another forced rescan. I’ve reboot several times (Nucleus and NAS) and deleted and re-added the Storage definition more than once but can’t get it properly watching as it did under Windows. I submitted a support ticket to Roon a week ago but haven’t heard anything back yet so figured I’d see what you helpful people can offer. I see similar threads back in 2019 but not anything current so starting a new thread. And yes, it’s been more than 4 hours. :grinning:


Hello @Bob_Johnson and welcome to the forum.

Fellow Roon user here, trying to help.

What is a forced Rescan? That is when Roon actively goes and searches the files and folders of your library for changes.
What does “watching in real-time” mean? It means that Roon requested to be notified about changes in your library and the request got granted by the OS of the device that holds your library. If the requested notifications don’t get sent or don’t reach Roon, there is nothing Roon can do about it. As remote connections are notorious for failing to send notifications, Roon has implement a timed rescan for remote libraries (see your screenshot “Automatic rescan interval”).

So you have three options:

  • Issue a manual rescan after you changed your library
  • Wait for the automatic rescan to catch changes
  • Try to find out what blocks the notifications and fix it

Note: Synology changed a lot of internals with the release of DSM 7 - included is a change that resets the max_user_watches to 8192. So if your NAS runs DSM 7 there is a good chance that your library is bigger than that watch limit. Even if you’re still on DSM 6 that option has a limited value, I just don’t know how much it is, and your library may have out grown it. Please check and take appropriate actions. You can use the information from the posting below to change the value for max_user_watches should this be needed:


The whole point of posting is that waiting doesn’t help – it never updates on its own. I have to manually rescan. Yes, I am asking for help to find out what blocks the notifications and fix it. The Synology (DSM 6.2.4-25556 Update 5) isn’t the issue either since it worked fine from the Window Core and scans fine when I do so manually. It’s Roon that isn’t cooperating. My library currently contains 11165 tracks, but again, Roon on Windows had no difficulties with that.

Which isn’t that far above the often found standard value of 8192. As you wrote that you now added content several times since moving away from your Core on Windows, the fact that it worked on Windows but no longer with the Nucleus is probably just a coincident.

Please read the note in my posting above. Did you check? If you need help on checking use this or wait until maybe someone shows up who can walk you through this or ask on the Synology support forum where it is more likely to find someone able to help you with that.

Due to aforementioned file system notifications and possibly other reasons, real time watching between Linux (which includes ROCK) and NAS often does not work. For that, you probably ought to go back to Windows.

Years ago on OS X or macOS, I had functional real time watching between Roon and NAS. When I switched to ROCK, real time watching ceased working. Ultimately, I was fine with that.

Because I do not recommend real time watching. It has a tendency to create partial albums when file system notifications arrive while files still are being transferred. Those partial albums then have to be merged manually. You are better off relying on automatic scans or forced rescans.



It would seem maybe so. Automatic is more convenient, but so be it. Now all I have to do is remember to do it manually. :nerd_face:

Gentlemen, wasn’t the reason Roon added the “rescan” options in Storage options the very fact that file system change notifications were often being lost, no matter what operating system the files resided on?

And the 4hr rescan setting is there to “force” a rescan from the SMB client side so to speak?
Regardless of any notifications…
So, this seems to be some kind of bug, you shouldn’t have to go into settings and press “Rescan” as this should be done automatically by the Roon Core?

1 Like

That is obviously something Roon support and/or QA need to look into, but they did not participate here so far. Someday they catch-up on the backlog of open requests and look into this.


Would be nice indeed if it did it, even if only after 4 hours. Opened a “I think something is broken” case on 5/10 but nothing so far other than the automatic acknowledgement that Roon received it.

Hi @Bob_Johnson ,

Thank you for your patience while we’ve had a chance to reach your case. Are you still seeing this issue at the present time? If so, I hope that you could reproduce the issue, let us know the time + date + one track of the new content that you import, and then let us know if you don’t see it after the 4-hour mark. We can look over the Nucleus diagnostics to see if the scanning took place. Thanks!

I added a number of new albums yesterday afternoon, and yes, they did finally show up after four hours. It’s nice to have this as a fallback, but I’ll still probably continue to manually rescan anyway. It’s just too tempting to move things along so I can listen to new music a bit sooner than that. Thanks for getting back to me though.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.