Nucleus setup help

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

google nest wifi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Just recently purchased nucelus and am having problems setting it up. I was previously running roon core on a windows laptop. I backed up and installed the backup on the nucleus. seemed to go ok. However, i cannot see the nucleus on my network. i cannot access any of the folders in the nucleus. I have a usb harddrive plugged into the usb on the nucleus but i cannot see it anywhere on my network. Also i accidently deleted my music storage folder path when trying to fix the problem and it looks like all my albums have gone. Could someone help please. Thanks.

Hi @Richard_Lane,

Are you referring to a watched folder in Roon that you deleted? Or did you delete something on the hard drive itself?

What kind of drive are you using? How is it formatted? Have you tried using a different USB cable?

Hi. just the watched folder. i didnt delete anything on the hard drive.

it is a usb drive. the same one i used for installing the roon backup, which worked ok. It is a WD my passport. To be honest, i dont want to use a usb drive connected to my nucleus to listen to music. I would rather it was connected in my office where i run my laptop, but i couldnt see it over the network so i moved the drive.

just to follow up on this. I rebooted the nucleus and it now recognises my usb hard drive. I have told Roon to locate the music storage folder and that seems to work. However, i still cannot see the Nucleus on my network and would rather not have the usb connected to the nucleus. Could I have assistance connecting my nucleus to my network please? thanks again.

Hi @Richard_Lane,

You can definitely add the path over the network. One thing to note, though, is that if the drive is connected to your laptop, the laptop will need to be up and running for the Nucleus to access it. If you’re okay with this, connect the drive to the laptop, and follow these instructions to share the folder and then add it in Roon. Let me know if you have any questions!

Hi. thanks again for your response. Unfortunatly i am getting an error message when i try and connect to my network. please see below:network%20share%20error%202

also, shouldn’t i be able to see the USB device that is plugged into my nucleus on my network? so that i can add files to it etc.

You will need to add your Username and Password for that laptop; and possibly a workgroup if you have one setup.

Hi. I have tried that. I used my microsoft account login details and i still get the same message. Like i also said previosuly, i cannot see the nucleus internal hard drive or the external usb drive on my network when i open my laptop. any other suggestions?

Hi @Richard_Lane,

Can you access the Nucleus Web Administration Interface when from the laptop? If so, can you share a screenshot?

Hi. yes i can. screen grab attached.

The web page does not show an internal drive found. Are you sure it has been installed correctly? I would verify that the computer’s BIOS can see it, and if not, then check to verify that the drive’s power cable is correctly attached.

Use a local login account for the laptop. And then you might also need to modify security privileges. Review this thread: Unable to Add Network Share

Hi. i havent installed an internal drive on the Nucleus, but my understanding was that it had a small internal drive for the OS etc (but not for adding music). Regardless i sitll cannot see that on my network. I am currently using a USB external drive plugged in at the back of the nucleus. It is working, as i am listening to music now. However, this setup is no good for me as when i want to add new music i currently have to disconnect the USB and connect it to my laptop to transfer files. There are 2 problems for me here, 1 - i cannot see the internal or external drives on my nucleus on my network 2 - i cannot work out how to add a networked drive to connect music on my laptop to nucleus core.

The OS locks any access to the OS drive, so you will not see it in Windows. You can not access or view this drive, except for logs. It can never be used for storage. If you want an internal drive for storage, then you will have to buy one and install it into the Nucleus.

If you haven’t yet, please take a look at the solution that I linked in my previous post.

thanks again for your response. and for clarifying that i shouldnt be able to see the internal nucleus OS drive. just to follow up on this, should i not be able to see the attached external usb hard drive on my network?

regarding accessing the networked drive on my laptop, i have looked at your link (thanks for sharing) but i still havent found a solution.

unfortunatly this is all a bit too technical for me, i am sure the fault is with me and my setup but i have already exhasted my time and limted abilities on this issue. The nucleus isnt working how i wanted it to, so i may return it to my supplier as i think i may have taken things a step too far. I am still trying now to fix it, but will have to give up soon!

Hi @Richard_Lane,

In this screenshot


If you replace the Desktop-mat38qe part with the IP address of your Windows computer and add Username and Password is there any change?

Hi dylan. no that doesnt work. just to confuse matters, the IP address that my google wifi app tells me my laptop has is different from the IP address i get when i google “what is my IP address”. could that be an issue?

Just to follow up. My internet setup is Technicolor DGA2231 Modem/Router with WIFI turned off, Google Nest Wifi router plugged in via Ethernet which acts as my only WIFI in my house. Nucleus is plugged in via Ethernet to Google nest router. Laptop connected via WiFi. Internet connection is good and stable through home.

Hi @Richard_Lane,

If you use an app like Fing to scan the network, what does the IP address show up as for the laptop? Does it show up twice? Is it the same as the Google WiFi app is saying?

Hi dylan. thanks for your response. Using Fing the IP address for my Laptop is the same as the Ip address that my google wifi app quotes. Same for the nucelus, both nucleus IP adresses are the same on Fing app and Google WIFI app. The only difference comes when i actually google “what is my ip address” and i get a completely different number.

Thanks for confirming, @Richard_Lane. In that case, I think it’s safe to assume the IP address used by your router is what we’d want to use here.

Are you able to connect to the path from Finder or File Explorer over the network outside of Roon? This will help us determine if the path is at least reachable over the network. If this doesn’t work, we know we need to focus on the sharing setup of the Windows device. If it does work, we know we need to focus on the Nucleus’ ability to connect to it.