OpenGL 3 Issue on New PC[Solved]

I’m moving Roon over from my Mac Mini to a new PC. I loaded Roon, but cannot open software b/c of “OpenGL 3 or higher is required”.

So I installed the OpenGL driver from nVidia ( EVGA GTX 960 SC). Yet, I’m still getting the same error. This is on Windows 10 Pro.


There is a tool called OpenGL Extensions Viewer ( ), which is how I usually test if the drivers are doing what they should be. Want to give it a shot?

Oh, I thought replying by email went to this thread. No wonder you have’t replied, I guess?

I’ve dl’ed the program. Can we proceed? I’m more than ready to have Roon on this new PC.

I meant, can you grab that program and run it? It will tell you what the opengl capabilities of your machine are. You could post those here and we can evaluate.

Danny, I didn’t get far

I cant quite understand whats going on in that screenshot… the upper left shows it running, but then it also looks like you are installing it still.

Hi @fore ----- I just wanted to follow up with you concerning the above. Have you made any progress? Is there anything I can be of assistance with? Let me know, thanks!


none. Probs with HQP req. me to reinstall Windows10. So I’m just now to the point of ready to load Roon. Same exact prob. Here’s a pic

Hey @fore,

Thanks for the screenshot. As you can see, at the moment your machine is using OpenGL ver. 1.1. To run Roon with GUI you need to have OpenGL 3.0 or greater.

Thought so, but when i click on Get Latest Version, I’m simply taken to a Microsoft Help page.

From your above posts you suggest you are using this video card. If that is the case, you do not want Microsoft drivers at all. The link below is for the latest EVGA drivers, assuming you are using Win 10 64 bit.



You can get the correct drivers here:

I tried and tried, using that link. Even a chat w. EVGA didn’t help. So I said to hell with it and I’ll just run Roon Server on my Synology.

All setup, Tidal working, but it won’t take my pathway and am wondering if you could help me with that? It’s a PC and my Synology Pathway given is \DS1515server. Yet it keeps saying it’s invalid.

Btw, using the same Synology info on a Mac Mini, smb://DS1515server and Roon found it easily.

31 posts were split to a new topic: Roon Server on my Synology

2 posts were split to a new topic: Trouble getting HQ Player to work