OpenGL error after upgrade to 1.1

I’m getting the “OpenGL 3.0 or higher is required” fatal error after upgrading to v1.1. I have an I5-2500k CPU with Intel HD Graphics 3000 display driver. Dell U2713 monitor at 2560x1440 resolution I’m running Windows 10 Pro and have installed latest Intel drivers. roon v1.0 ran with no problems.

OpenGL Extensions Viewer v4.3.8 reports OpenGL 3.1. Is it the case that Intel HD Graphics 3000 just doesn’t cut it? It won’t be a tragedy if I have to upgrade.

Any way to roll back to 1.0 (build 30) in the meantime?

Hi @markus, I’m going to PM you so we can get some logs and take a look at this further, hang tight!

I was able to install an I5-3750k CPU with HD Graphics 4000 (OpenGL 4.0) and after a reinstall of roon the error has disappeared. Unfortunately I now have the “blank white screen” problem whenever I minimize and restore.

Not sure what my next move will be. Discrete graphics card? Upgrade to new I5-6600k platform? I’m snakebit since v1.1.

that’s insane… I dont understabd why opengl viewer is able to see the intel gpu and Roon isnt.

The white screen minimize issue is known as an Intel driver bug with the 3000 and 4000 that even affects Microsoft Office

The workaround is to just leave roon full screen and alt-tab back to the desktop. roon is much nicer in full screen anyway. I’ll be upgrading soon to the latest CPU with HD Graphics 530

I am also having an OpenGL error when I try to start Roon. I’m using a CAPS v3 Carbon server, and I’ve recently installed Windows 10 on it. The CAPS Carbon uses a N2800 CPU with a built in graphics card (SGXS45 PowerVR Core). When I use the Intel driver update program, it tells me I have all the most recent drivers. Can you tell me if I can use Roon on this music computer, and if I can, how I go about getting past this problem? The error message I get is “GL_ARB_framebuffer_object Open GL extension is needed”

Thanks for your help! Roon looks interesting.

Frustration! I had no problem to run Roon 1.0 on my system, but when I tried to start version 1.1 I received the openGL-error-message. My graphics adapter intel HD Graphics 3000 should be able to handle openGL 3.1, I run Roon on an Asus UX31E (intel core i7 2677M), windows 10.

What could I do?

@Ron_McKernan: agreed, we did quite a bit of dev with the hd300 early on… the sandybridge cpu has issues with locking the gpu bus at times causing stutters in performance, but it’s capabilities are fine

@mike will ask you for logs so i can see what is missing. can you tell me the exact error you see?

Just sent you instructions @Ron_McKernan – take a look and let me know if you have any questions.


Hi Mike

Since I got an error message when I tried to reply to your PM I try it this way:

I cannot enter the support ID since I am not able to start Roon!! Please let me repeat my message:

Frustration! I had no problem to run Roon 1.0 on my system, but when I tried to start version 1.1 I received the openGL-error-message. My graphics adapter intel HD Graphics 3000 should be able to handle openGL 3.1, I run Roon on an Asus UX31E (intel core i7 2677M), windows 10.

Means: After downloading the recent version of Roon yesterday I was not longer able to open it, I had no problems with the former version (which has vanished now). Would you need any further information?

I would be glad if I would get only one answer from you but not six emails (from Danny, Kevin and Mike) as last night. Thanks.


I am having the same problem. Since the Roon 1.1 update I get the OpenGL error. I also have Intel HD Graphics 3000, 64-bit Windows 10.
I have tried updating drivers, Intel’s app assures me I have the latest.

Guys, in the error, there are 3 sentences:

  1. OpenGL 3.0 or higher is required. The video drivers on this system do not support OpenGL 3.0.
  2. This may be fixable by upgrading your drivers, not using a remote desktop solution, or upgrading your video card.
  3. something here…

I need to know what that 3rd line says. I just checked out the logs of someone who sent in logs, and their log says:

OpenGL Version: 1.1.0
OpenGL Vendor: Microsoft Corporation
OpenGL ShaderLangerVersion:
OpenGL Extensions: GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture
Warn: Broo.Engine.BadOpenGLException: GL_ARB_framebuffer_object extension is missing

This points to lack of OpenGL support, maybe due to remote desktop being used.

The tool I use to get a conclusive answer is this one:

Hi Danny

The third line of the error message reads “GL_ARB_framebuffer_object extension is missing”.

OpenGL Extensions Viewer (v 4.1) says my system is 100% compatibel with OpenGL 3.1, I also ran the 3.1 test without experiencing any problem.

In the Systems menu I switched off all remote desktop options.

What else could I do?

Thank you for your support!

Argh, that last line means we couldn’t load that open extension, which is mandatory for 3.0, and the gl viewer tool is saying you have it, so why can’t Roon get access to it?!

Mind just moving away your 1.1 localappdata/Roon folder and reinstalling 1.0 and see if that fails?

You can’t roll back the db, but we can see if this was indeed a 1.1 update issue.

One other has had this issue and it turned out he upgraded the Intel gpu driver and the issue went away.

Danny, I get the same error (GL_ARB_framebuffer_object extension is missing) on an HP AIO that worked perfectly on 1.0 with Windows 7 and Windows 10, I can provide logs if you let me know what you need?
All drivers are updated to the latest available.


1 Like

Hrm, I wonder if this is a Windows 10 issue.

@Ratbert: can you send me the log from %localappdata%\Roon\Logs\Roon_log.txt

If I can bother you for a bit of your time, what I really want is:

  1. rename the Roon folder in %localappdata% to Roon11
  2. install Roon 1.0
  3. run Roon and close, confirm to me it worked properly, and then send me the log mentioned above.
  4. delete Roon folder in %localappdata%
  5. rename Roon11 to Roon again
  6. run Roon and close, confirm to me that it did or did not work properly, and then send me the log mentioned above.

so in the end, I want the log from 1.0 and 1.1, and confirmation of any errors or if it worked on both runs.

In v1.1, we started to add support for Windows 10. One of the items we had to take care of was when calling into Windows to get the version number. On Windows 10, the call returns “Windows 8” unless you add a manifest file into your .exe that tells it “I am smart, and know about Windows 10, so stop lying to me”.

It seems that adding that manifest file breaks all of OpenGL with that Intel driver. Great job Intel, as usual. If you had 2 GPUs, we force away from the Intel, so many machines were uneffected. Only those with Intel only GPUs seem to be affected.

Anyway, we have a workaround. This will hurt our ability to support Windows 10 features in the future, but we’ll cross that road when we come to it. Blah.

Expect a fix in the next build, very shortly.

Special thanks to @Ratbert for granting us access to his machine as a “window 10 w/ intel gpu only” guinea pig. We solved this quickly with your help.


@danny “This will hurt our ability to support Windows 10 features in the future”.

What does this mean for Windows 10 users?

I just upgraded last weekend, had all kinds of issues with roon stopping to work. Yesterday I did a clean Windows 10 install to see if this fixes the roon has stopped working error and got this open gl error. After a reboot it went away (have Intel an Nvidia). But had another weird issue which I will add to my original thread.

Funny thing is that roon crashes on the ntdll.dll of Nvidia. So potentially both have an issue.

It doesn’t mean anything for Windows 10 users yet. In the future, it is unknown what this means. Most likely it means we will have to revisit this situation when we add more Windows 10 specific features.

ntdll.dll is not nVidia specific, it is where the entire Windows native API lives. It is one of the core pieces of Windows. A crash there usually (but not always) implies mismatched DLLs on your system. It also could mean just corruptness of something.

I see you have some unrelated ASIO issues, but did your graphics and startup related issues post-clean install go away?

Thanks to @Ratbert for supporting the guys at Roon! I am looking forward for the next build; will there be a notice in this forum when this build has been issued?

Meanwhile I misuse my business laptop (Intel HD 4400) to run Roon 1.1.