Playing Linn Jazz Radio Station Crashes Roon [Ticket In]

hi there I I have problem with adding linn jazz radio and linn classic radio it crashes Roon and it shuts down since the new update

I am having the same issue

Can you guys let us know what streaming URL you’re having this issue with?

And also the details of your setups?

Mac mini Roon just shuts down


Thanks for posting that link, I can reproduce the behavior you’re seeing and have filed a ticket with our QA team.


@noris I can confirm that this behavior also occurs when trying to play:

  1. Audiophile Baroque:
  2. Audiophile Classical:

They both worked fine under 1.5…


1 Like

Linn Jazz at works for me 1.6

On further testing this crashes the roon remote while the radio station keep playing. Tried a remote from another device while the core was streaming this radio station. Same result, the remote crashed.

Guys, I have a similar issue when streaming JazzRadio Premium channels…after playing 2 or 3 songs the music stops at the end of a song and requires me to hit the play button again. This is since the 1.6 update. I am using a Lumin x1 streamer and all software is up to date. Please help. Thank you.

Hello @wkimbel87 / @villageworker,

Thanks for the links. We believe to understand where this issue lies and the devs are working on a fix which will be included in our next update.


1 Like

With 1.6 update Roon now crashes every time when I try to stream the Linn Jazz Station. Any help would be great.

However the Linn Radio Station below works fine.

@Benjamin_Gold - Thanks for the report, added it to the list.

– Noris

Hello All,

We have just released Roon v1.6 build 401 which addresses this internet radio issue:

Roon 1.6 (Build 401) Is Live! Software Release Notes

Hi everyone! A new maintenance release is now rolling out for all platforms, with bug fixes, performance improvements, and updated designs for some of the UI changes in Roon 1.6. Today’s release includes a number of refinements for the footer and the Now Playing screen. We’ve heard a lot of great feedback on the changes in Roon 1.6, and we think the changes made over the last few weeks are big improvement. We hope you agree and we’re looking forward to hearing from everyone! We’ve added the m…

Please give the update a try and let me know how it goes!


Thanks Noris. I was too scared to try it again after so many previous crashes but it now works. I assume Robert who had the original post now has no issues, but I thank him for raising the problem (that’s what cousins are for).

1 Like

Hi @Philip_Murray,

Yes, this issue is now resolved, glad to hear that you are seeing the same thing. I am going to go ahead and mark this case as solved but do send @ROBERT_REVAN my thanks for the report!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.