Please make it NOT skip songs when "audio file is loading slowly" error occurs

+1 same problem here. Pause would be much better than a skip.

1 Like

I saw a post in another forum that seemed to indicate that deleting and reinstalling Roon resolved this problem.-- TEMPORARILY. Now, I’m not advocating that anyone should do that, but that might reinforce what @Ward experienced.

And of course, even if it worked, if it’s temporary it’s not a solution.

+10,000. This is indeed a bug.

It makes no sense to skip. The most logical thing to do would be to pause, which is what most audio apps do.


Could you please provide a clear explanation why this has been moved to another section and marked as “Feature Requests”? Is this documented in the knowledge base or elsewhere as an intended behavior?

Because it’s an ask for a change on intended behavior of the software. See also a similar request:

And from there the official statement regarding “skipping to next song”:

1 Like

Every bug report is ‘an ask for a change in behavior of the software’, so I don’t believe it’s a valid argument.

It’s not a bug if it’s acting the way Roon intended. However, if users want to change that behavior, that would be a feature request. The problem that needs resolution is the fact that you are getting the skips in the first place.

Thank you, I go and update my post.

Lots of the same error message lately. ROON quite buggy these days.

So far, so good :slight_smile:

There has only been 1 time since, where RAAT.exe was using 30% CPU, and so performance tanked.

I still have another bug, even after updating today, where Background Audio Analysis is stuck on 0/22996

Not sure if that plays any part in this issue.

Could Roon team kindly evaluate and tag this topic as either ‘on the roadmap’ or ‘not on the roadmap’?

(As per the “we will periodically mark features … if it is done or not on the roadmap” subtitle of Feature Requests section.)

1 Like

For full context of my inquiry, I’ve managed to sufficiently fix the “audio file is loading slowly” or “Tidal media is loading slowly” issues in my setup. That being said, I still find the skipping (if it ever happens again) as highly frustrating and undesirable.

When my wifi becomes unavailable, Roon is able to stop the playback just fine without skipping. Why not to do the same here?

For those still struggling with these issues, here are at least some gathered tips (for the time being):

  • Keep your signal chain as simple as possible. Avoid any switches, hubs or other unnecessary stuff. The higher the amount of devices involved, the higher the risks of failure.

  • Do not automatically assume - despite the popular opinion around here - that your router or access point (wifi) is most probably at fault. Do not automatically assume that using wifi is bad. Do not automatically assume that involving Android or any other “unusual” devices (if required to be involved) in the signal path is bad. Basically do not assume anything and take your time to gain knowledge on the issues over time, as they keep re-occuring. :slight_smile:

  • Do not consider reboot of all involved devices as a solution, rather as a useful way to continue investigating the root cause. The need for reboot is not the root cause.

  • For streaming-related errors, definitely try the usually recommended change of DNS setting to Google or Cloudfare DNS, or streaming service cache erasing, or lowering the streaming quality (bandwidth) to the lowest possible. Also consider testing both Tidal and Qobuz, as one of those might be less prone to network issues geographically than the other.

  • For local-related errors, try to isolate the issue by focusing on all involved devices in your signal chain one by one. Start with devices rather than worrying about cables or other means of signal transport among devices. People usually recommend to verify your core device (CPU single-core speed, cache), router (fast and stable enough?), and core-router connectivity (ideally ethernet).

In my case, the following two actions related to my core device fixed the frequent issues:

  1. Removing USB hub with ethernet port from the device. (Yes, wifi connectivity is absolutely stable with Roon in my flat while the wired ethernet connectivity was causing frequent issues.)

  2. Installing Process Hacker app to automatically max-out Process Priority and I/O Priority of Roon and RAAT, therefore helping out my CPU to handle the load. (I suspect that especially setting I/O Priority = High helped me.)

1 Like

To extend a bit on the above, I’ve been testing the following three computers against Roon recently:

  • Dell Latitude 5401 (core i7 9th gen, 16 RAM, 512 GB SSD)

  • HP Probook 430 G6 (core i3 8th gen, 8GB RAM, 256 GB SSD)

  • Lenovo Ideapad D330 (pentium N5000, 8GB RAM, 128 GB eMMC)

Despite the expected, the Dell has not been the most stable core machine for Roon from the above. (It’s the HP Probook, not needing any help at all so far for stable Roon operation.) This is despite not being simultaneously used for anything else, despite wired to the router via ethernet, and despite fast and reliable operation for any other audio application used so far.

While I am sure there is some reasoning behind the observed behavior, I still find it highly frustrating that Roon is so much more demanding (and hard to understand / “black box”) compared to anything else tested by me over the last decade or two in digital audio. Not cool, sorry.

You could at least fix the annoying track skipping… that would have been enough of a compromise.

It’s so frustrating especially as my setup initially loads slow then catches up. I need to be able to disable skipping and happy to wait for the slow load if thats whats happening


Hi @Jon_Pickles. Welcome to the Roon Community.
I’d recommend you open a ticket in Support to get this problem addressed for you. This is almost always related to a network flaw and Roon can help troubleshoot that for you. You are paying for support, take advantage of it.

Some people get this fixed, and some don’t. There are even a couple users who know they have the problem because they are (underserved) by poor network connectivity in very rural areas.
It’s understandable users might want a different response in this error state, but it would be best if one could get the error state fixed. Most of us just about never have it happen.

We are not complaining about the fact that things are not always 100% stable in our signal chains, be it related or unrelated to Roon.

We are complaining about the fact that the software nonsensically keeps skipping tracks in such situations. We want the software to pause the playback so that our playback queues remain unaffected, that’s all.

Fix the stupid track skipping!


The causes for track skipping will never go away. For users, it would be great if Roon would correct the behavior of the application when the causes occur.
The current behavior is very unpleasant and annoying…


As a workaround to the “skipping” issue, I’ve recently skipped the bloody RAAT and sticked with aptX bluetooth in a way described here:

During the last month, as a result, I’ve had zero issues with skipping. Really, 0 occurences. In the rare moments I’ve observed some potential playback issue, I only heard silence for few seconds instead of actual playback interruption.

Still not sure about the actual cause (might be some background WIN OS processes clashing with Roon playback) but, during the last months, I’ve changed EVERYTHING in my chain including router and modem.

So yeah, until they fix the track skipping bug, bluetooth it is.

extremely annoying behaviour. I think “just stop and wait to resync in stopped place” is how I want it too


I’m a new User of Roon and found out this issue in the past days.
Disturbing behavior. As somebody else said before me when i am listenign to a 10/15/or more minutes track and it’s skipped somewhere in the middle it’s very difficult to find out where it stopped and resume from exactly the right point.